LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   MP3 Quality in Linux (http://www.linuxquestions.org/questions/linux-software-2/mp3-quality-in-linux-243676/)

Rawr101 10-17-2004 04:14 AM

Sound Quality in Linux
 
I saved a few songs that I had from Windows onto my server to test out the quality on Linux. The quality doesn't suck, it's just I have to turn up my volume full blast just to hear the song. CDs are different, they have the same volume quality as on Windows. Is it just me? It's not just with music, but basic sounds you'd hear in Linux or in GAIM. I am due for a fresh installation soon, so if it is me, I'll just take care of it w/ a reinstall. I'm running Slackware 10 and KDE if it matters.

I have messed around with all the Volume Control settings and it's the best I can get, as described.

vinay_s_s 10-17-2004 05:12 AM

looked at the PCM volume ? and the main volume .

Rawr101 10-17-2004 05:38 AM

Yep.

Lenard Spencer 10-17-2004 09:21 PM

In KMix, you will need to turn up one of the four sliders on the right. The fourth one in works for KDE, the third one works for Gnome. I just turned them both up and saved the settings in Control Center > Sound and Multimedia > Mixer. Also, if you want those settings to load at boot, open a terminal, su root, and "alsactl store".

webtoe 10-18-2004 08:53 AM

You may also want to see what sound drivers you are using for your card. A marked improvment, both in response and sound, can be had just by using the right one. Also you may want to see whether esd or artsd are being used for sound. They always give me grief.

Also you might consider a different player if those don't help any.

Hope that helps

Alex

praedictus 10-18-2004 08:41 PM

There's another possibility I didn't see mentioned here.
Shortly after getting ALSA drivers working here I had a similar problem until I hooked up my surround speakers. Turns out WINDOWS was directing the sound to the wrong port all the time, so when I was in linux the main channel (L + R) was going to the correct jack per motherboard specs, in Windows it was being sent to the surround (Rear left + Rear Right) channel jack. If you are using an ALSA driver try playing a file in one window while messing with the ALSAmixer settings in another, there is an option to swap main and surround channels there, see if that suddenly fixes the problem.

For what it's worth I get much better sound, both for CD, MP3/Ogg/Flac and for DVDs (5.1 surround works great) in Linux, turning up volume much in Windows gives me some really nasty distortion.


All times are GMT -5. The time now is 10:25 AM.