LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-20-2006, 12:09 PM   #1
DBabo
Member
 
Registered: Feb 2003
Distribution: Scientific Linux 6, Fedora
Posts: 393

Rep: Reputation: 33
Question mp3 and k3b yet again ( no livna )


100000001 time yet another dummy user ( myself ) wonder, how to get the mp3 support in the k3b if i don't use livna rpms...
Please help.
Oh, i'm on FC5 and the system can play ( xmms ) mp3 ...
thank you a LOT.

Last edited by DBabo; 08-20-2006 at 04:41 PM.
 
Old 08-20-2006, 02:43 PM   #2
Draciron
Member
 
Registered: Jul 2006
Posts: 44

Rep: Reputation: 16
Grrr wiped out my post because I didn't have enough posts to post a URL. Not sure where to get points so just google the file. I used the DAG version of it. If you have DAG set up in your YUM you should be able to yum it also. I would post my dag yum config but it also contains a URL and would make me retype the whole thing again

k3b-mp3-0.11.14-1.2.el4.rf is the file I think your looking for. This will allow you to convert MP3s to audio files in K3b. You can do the same manually before burning or convert them to waves but the sound quality is good enough with this plugin and it's so much easier that I use the plugin %99 of the time. The RPM is for FC4 but installed fine in FC3, though Yum complains when I try to update K3b because of this. Don't see an FC5 rpm either. I run 3 and 5, hated 4. Ran it only long enough to decide I didn't want too.

Google that RPM and you can then burn MP3s as audio fails inside K3b.
 
Old 08-20-2006, 04:48 PM   #3
DBabo
Member
 
Registered: Feb 2003
Distribution: Scientific Linux 6, Fedora
Posts: 393

Original Poster
Rep: Reputation: 33
thank you for the post. i have dag repository.
But it doen'st have the k3b-mp for the FC5.
every rpm, i was able to find, is from livna.

k3b-mp3-0.11.14-1.2.el4.rf .. isn't it for EL4 ?

P.S. this is what i'm getting when i'm trying to force my way through:
rpm -Uhv ./k3b-mp3-0.11.14-1.2.el4.rf.i386.rpm
error: Failed dependencies:
k3b = 0.11.14 is needed by k3b-mp3-0.11.14-1.2.el4.rf.i386
libid3-3.8.so.3 is needed by k3b-mp3-0.11.14-1.2.el4.rf.i386
libk3bcore.so.2 is needed by k3b-mp3-0.11.14-1.2.el4.rf.i386
libk3bdevice.so.2 is needed by k3b-mp3-0.11.14-1.2.el4.rf.i386
libk3bplugin.so.2 is needed by k3b-mp3-0.11.14-1.2.el4.rf.i386
libmad.so.0 is needed by k3b-mp3-0.11.14-1.2.el4.rf.i386

Last edited by DBabo; 08-20-2006 at 05:10 PM.
 
Old 08-20-2006, 05:41 PM   #4
DBabo
Member
 
Registered: Feb 2003
Distribution: Scientific Linux 6, Fedora
Posts: 393

Original Poster
Rep: Reputation: 33
wow - i RTFM finally. and learned that k3b wants/needs :
"
MAD MPEG Audio Decoder Library - MAD is a high-quality MPEG audio decoder. It currently supports MPEG-1 and the MPEG-2 extension to lower sampling frequencies, as well as the de facto MPEG 2.5 format. All three audio layers - Layer I, Layer II, and Layer III (i.e. MP3) - are fully implemented.
Used by the Mp3 decoding plugin.
"

installed it .
Still no luck. maybe i need to configure it somewhere? I mean k3b ?
i don't see it in the list of plugins...
 
Old 08-21-2006, 12:11 PM   #5
.Alexandru.
LQ Newbie
 
Registered: Aug 2006
Posts: 29

Rep: Reputation: 15
where can i find mad?? i have bin been looking for it for some time now and cannot find mad for suse 10.1 does anyone know where the link is or where i can find it???
 
Old 08-21-2006, 07:50 PM   #6
DBabo
Member
 
Registered: Feb 2003
Distribution: Scientific Linux 6, Fedora
Posts: 393

Original Poster
Rep: Reputation: 33
check their site. I think i saw smth there. Not sure though
 
Old 08-21-2006, 09:19 PM   #7
.Alexandru.
LQ Newbie
 
Registered: Aug 2006
Posts: 29

Rep: Reputation: 15
i was searching for mad all day and didnt find anything for suse 10.1 no rpm for some reason does anyone know where i can find the mad rpm for suse 10.1???
 
Old 08-22-2006, 08:52 AM   #8
DBabo
Member
 
Registered: Feb 2003
Distribution: Scientific Linux 6, Fedora
Posts: 393

Original Poster
Rep: Reputation: 33
Based on my expirience with SUSE i would recommend you to iether compile with rpm by yourself or wait another 5-6 months ..
 
Old 08-22-2006, 04:02 PM   #9
.Alexandru.
LQ Newbie
 
Registered: Aug 2006
Posts: 29

Rep: Reputation: 15
wait 5-6 months for what????????
 
Old 08-22-2006, 07:39 PM   #10
DBabo
Member
 
Registered: Feb 2003
Distribution: Scientific Linux 6, Fedora
Posts: 393

Original Poster
Rep: Reputation: 33
to get them to realease the rpm.
 
Old 08-22-2006, 10:22 PM   #11
DBabo
Member
 
Registered: Feb 2003
Distribution: Scientific Linux 6, Fedora
Posts: 393

Original Poster
Rep: Reputation: 33
check here http://k3b.plainblack.com/message-bo...tpH4StOl0nDCHQ
 
Old 08-28-2006, 11:41 PM   #12
DBabo
Member
 
Registered: Feb 2003
Distribution: Scientific Linux 6, Fedora
Posts: 393

Original Poster
Rep: Reputation: 33
well, here is some "progress".. In "" - cause it still doesn't work.
After some pocking around and installing and reinstalling this damn thing.
I gave up and decided to compile form sources - should be simple right ?

Well.
first it asked for the QT libs .. Figured with spec. correct path to those libraries.

Last edited by DBabo; 08-28-2006 at 11:43 PM.
 
Old 08-28-2006, 11:48 PM   #13
DBabo
Member
 
Registered: Feb 2003
Distribution: Scientific Linux 6, Fedora
Posts: 393

Original Poster
Rep: Reputation: 33
ok. got really mad - restarted a server..
Obviously it didn't help

got latest k3b-0.12.17 source. made sure that almost all librarieswith devels are there - see the output after the configure stage.

did make ; went to plugins/.../mp3 and, as root, did make install.

status :
it's burning audio CD from mp3 as i'm writing this ..

Sumup :
this is a f%% pain... Quality of these rpms is low. the FC is another 3 solid years far from been user-friendly...
i see no competition with MS at this point, from user side.

Last edited by DBabo; 08-29-2006 at 09:05 AM.
 
  


Reply

Tags
fc5, fedora 5, k3b, mp3


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Mps call for digital rights safeguards LXer Syndicated Linux News 0 06-07-2006 07:54 AM
livna repo appears to be broken? Is it me or livna? jamesjoy Linux - Newbie 2 11-06-2005 07:09 AM
pdflatex foo.mps (mpost?? Xfig??) kaz2100 Linux - Software 8 06-19-2005 05:52 AM
mps compilation failed ph0enix Linux - Software 3 02-09-2005 05:37 PM
wget won't authenticate with a MPS 2.0 Proxy graywind Linux - Networking 0 12-16-2003 02:49 AM


All times are GMT -5. The time now is 03:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration