LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-25-2004, 11:44 PM   #1
TheGr81
Member
 
Registered: Jan 2003
Posts: 38

Rep: Reputation: 15
Mozilla and font sizes


Hey guys,
I am having a little trouble changing the font size of the menus in Mozilla. I have changed the font sizes in the KDE control panel and in my Mozilla settings but they menus in Mozilla are still using a VERY small font that is almost impossible to read. I have installed all of my windows fonts and seem to have everything working well except for this. I am not the most experienced Linux guru so please give details on how to fix this if anyone is nice enough to help. I would greatly appreciate it.

Edit: I just noticed that it is not just mozilla that has this problem. The mandrake utilities such as rpmd also are using a very small font even thought I have them set to larger ones through the KDE control panel. Is there somewhere else that I must set them?

Last edited by TheGr81; 09-25-2004 at 11:58 PM.
 
Old 09-26-2004, 12:18 AM   #2
tutwabee
Member
 
Registered: Jan 2004
Location: California
Distribution: Ubuntu 10.04
Posts: 145

Rep: Reputation: 15
Just out of curiosity, what is your resolution? That could make your fonts very small. Also maybe the font face you are using is a small font in general?
 
Old 09-26-2004, 09:08 AM   #3
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
Try this. Create a file .gtkrc-2.0 in your home directory (don't forget the 'dot') containing a line such as

gtk-font-name = "Arial 14"

If you don't have the MS Truetype fonts installed you might have to choose something different, like "Helvetica 14". When you restart Moz you should see the new font in the menus.

The problem is that non-KDE apps will take no notice of settings in the KDE control panel
 
Old 09-26-2004, 09:30 PM   #4
TheGr81
Member
 
Registered: Jan 2003
Posts: 38

Original Poster
Rep: Reputation: 15
Thanks for the suggestion. I will boot into Linux and give that a try right now. I'll also let you know what resolution I am running at.
 
Old 09-26-2004, 09:45 PM   #5
TheGr81
Member
 
Registered: Jan 2003
Posts: 38

Original Poster
Rep: Reputation: 15
I am running at 1152x984 or something like that. The font is so small and crappy looking I can't read it. I am about to try the suggestion that was given. If I didn't mention it before, I did mess with the font settings in mozilla but this did not seem to have any effect on the Mozilla GUI.
 
Old 09-26-2004, 10:00 PM   #6
TheGr81
Member
 
Registered: Jan 2003
Posts: 38

Original Poster
Rep: Reputation: 15
OK, I created a file in /home/marc/ called gtkrc-2.0 and added the line gtk-font-name = "Arial 14". I restarted X and the problem persisted so I tried changing Arial to Helvetica, restarted X and the problem persisted. Any other suggestions?

Tutwabee, what do you mean by font face? Where can I change this?
 
Old 09-26-2004, 10:09 PM   #7
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,764

Rep: Reputation: 306Reputation: 306Reputation: 306Reputation: 306
if you do some reading at the Moz website, you'll find documentation on how to change the font sizes using userChrome.css and userContent.css cascading style sheets (.css) in the user's home/.mozilla.
 
Old 09-26-2004, 11:07 PM   #8
tutwabee
Member
 
Registered: Jan 2004
Location: California
Distribution: Ubuntu 10.04
Posts: 145

Rep: Reputation: 15
Quote:
Originally posted by TheGr81
Tutwabee, what do you mean by font face? Where can I change this?
Arial, Times, and Helvetica are all font faces. Some fonts generally run small but it doesn't seem like that is your problem.

What point size does it seem like the font is at in your menus and in Mozilla? The way you can test this is open up OpenOffice and type in different sizes and see which one looks the closest.

Also, this thread may help you: http://www.linuxquestions.org/questi...hreadid=158900
 
Old 09-26-2004, 11:48 PM   #9
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
Hi TheGr81

In your reply to my earlier post you said you used a file 'gtkrc-2.0'. Does this mean you left out the leading 'dot' in the filename? The name you need is

.gtkrc-2.0

The leading '.' is a Unix convention for configuration files. It stops them being listed by the 'ls' command, since most people want to ignore them most of the time.

P.S. You don't need to restart X. Just the app.

Last edited by maroonbaboon; 09-26-2004 at 11:52 PM.
 
Old 09-27-2004, 01:30 AM   #10
TheGr81
Member
 
Registered: Jan 2003
Posts: 38

Original Poster
Rep: Reputation: 15
crap, I did forget the leading . I will try it the right way next time I am in Linux. Thanks a lot.
 
Old 09-28-2004, 01:21 AM   #11
TheGr81
Member
 
Registered: Jan 2003
Posts: 38

Original Poster
Rep: Reputation: 15
OK, I tried what maroonbaboon suggested with no effect whatsoever. I already had a file called .gtkrc-2.0 and I also had a file called .gtkrc which both looked like this...

# -- THEME AUTO-WRITTEN DO NOT EDIT
include "/usr/share/themes/Galaxy/gtk/gtkrc"

# -- THEME AUTO-WRITTEN DO NOT EDIT

I added the line gtk-font-name = "Arial 14" to both files so that they looked like this...

# -- THEME AUTO-WRITTEN DO NOT EDIT
include "/usr/share/themes/Galaxy/gtk/gtkrc"
gtk-font-name = "Arial 14"
# -- THEME AUTO-WRITTEN DO NOT EDIT

This had no effect so I figured I would try using the Helveticaca font just in case it was a problem with the Microsoft fonts I had installed so I made both files look like this...

# -- THEME AUTO-WRITTEN DO NOT EDIT
include "/usr/share/themes/Galaxy/gtk/gtkrc"
gtk-font-name = "Helvetica 14"
# -- THEME AUTO-WRITTEN DO NOT EDIT

This also had no effect and I tried restarting X after each change just to be safe. Is there anything else I should try? I would really like to get this working and greatly appreciate the help I have been given and hopefully will get.
 
Old 09-28-2004, 01:35 AM   #12
wlaw
Member
 
Registered: Jun 2004
Location: HK
Distribution: Ubuntu
Posts: 242

Rep: Reputation: 30
I get exactly the same problem with you ! Let me know the solution if you get it !

Good luck !
 
Old 09-28-2004, 01:44 AM   #13
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
I don't know why this is not working for you, unless it is getting overridden somewhere else. You could try commenting out the line starting 'include...' (just put a # at the beginning). If this line is generating an error the app may give up and not get to the font line.

You can also try some other font names. I am not quite sure how the name is mapped to a particular font. But I tried with a nonsense name and it still worked, using the given size parameter with what looked like a Times Roman font.
 
Old 09-28-2004, 02:00 PM   #14
TheGr81
Member
 
Registered: Jan 2003
Posts: 38

Original Poster
Rep: Reputation: 15
I tried commenting out the include line and it still had no effect. Out of curiosity, I loaded up Gnome to see if they problem existed there as well. In Gnome, if I change the font settings using Gnome's font selector, everything comes out looking great so this is definitely because of something KDE is doing. I would prefer to use KDE over Gnome so if anyone has any other suggestions I would appreciate it.
 
Old 09-28-2004, 05:50 PM   #15
tutwabee
Member
 
Registered: Jan 2004
Location: California
Distribution: Ubuntu 10.04
Posts: 145

Rep: Reputation: 15
Suggestions: delete all KDE configuration files in your home directory. This will clear all of your normal user settings. Hopefully the default is large text.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Font sizes dyrer Linux - Newbie 2 08-28-2005 07:51 AM
Can't get font sizes consistent seanr Linux - Software 2 07-21-2005 12:03 PM
More font sizes enemorales Linux - General 1 04-13-2005 05:37 PM
How to increase toolbar font sizes in mozilla? Slovak Linux - General 2 12-14-2004 07:55 AM
Crazy font sizes...help! TravisOSF Mandriva 1 04-03-2004 02:17 PM


All times are GMT -5. The time now is 06:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration