LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-16-2003, 04:14 AM   #1
mtb
Member
 
Registered: Nov 2002
Location: Italy
Distribution: Linux Mint 14
Posts: 273

Rep: Reputation: 30
moved home: permission denied


Hello,

i have recently created a new partition and moved everything that was on my home on that, and i have added a new line in fstab like the following:

/dev/hda5 /home ext3 default 0 1

Everything seemed to work fine, but i have recently discovered an huge problem:

i can't run anymore programs from my home, i get a permission denied problem always .

This happens both for scripts ( eg. ./configure ) and for stand alone programs ( some programs need to be in my home )

What can i do?

Thanks in advance

ps. of course the permission are ok ( 755 )
 
Old 12-16-2003, 04:44 AM   #2
AltF4
Member
 
Registered: Sep 2002
Location: .at
Distribution: SuSE, Knoppix
Posts: 532

Rep: Reputation: 31
Re: moved home: permission denied

Quote:
Originally posted by mtb

/dev/hda5 /home ext3 default 0 1
are you sure this is the exact line in fstab ?
sounds like you added the "noexec" option either in fstab or while mounting /home
 
Old 12-17-2003, 03:46 AM   #3
miaviator278
Member
 
Registered: Dec 2003
Location: Al-Diwania, Iraq (deployed)
Distribution: Slackware ONLY
Posts: 237

Rep: Reputation: 30
check that your permissions are ok recruisivly, the directory permisions may be ok but not the contents "man chmod" "man chown" post your fstab so we know the exact line.
 
Old 12-17-2003, 04:03 AM   #4
mtb
Member
 
Registered: Nov 2002
Location: Italy
Distribution: Linux Mint 14
Posts: 273

Original Poster
Rep: Reputation: 30
Re: Re: moved home: permission denied

Quote:
Originally posted by AltF4
are you sure this is the exact line in fstab ?
sounds like you added the "noexec" option either in fstab or while mounting /home
i changed the file fstab.bak, there was the option user instead of default in the official one.

Excuse me...
 
Old 12-17-2003, 06:09 AM   #5
AltF4
Member
 
Registered: Sep 2002
Location: .at
Distribution: SuSE, Knoppix
Posts: 532

Rep: Reputation: 31
"user" implies "noexec"
so you have to use default
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
permission denied to home directory ekdya Debian 3 11-08-2005 04:24 PM
permission denied mounting /export/home and /opt/csw xushi Solaris / OpenSolaris 6 07-28-2005 03:45 AM
moved /home - now it seems everythings gone! aes canis Linux - General 4 05-10-2005 03:16 PM
useradd problems - permission denied on /home/* for new users lowpro2k3 Red Hat 1 02-09-2004 11:18 PM
/home has been successfully moved jeremy LQ Suggestions & Feedback 3 08-18-2000 05:25 PM


All times are GMT -5. The time now is 09:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration