LinuxAnswers - the LQ Linux tutorial section.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 12-12-2001, 07:51 PM   #1
LQ Newbie
Registered: Nov 2001
Posts: 3

Rep: Reputation: 0
Arrow Mouse pointer jumps all over screen : xfree86 install

When installing xfree86, via graphical interface, my mouse pointer jumps all over the screen and clicks buttons even though I am not clicking. I am trying to install debian2.2

I have tried both logitech and micro$oft wheel-mice, and get the same behavior. (No reboot, is this a prob?)

My mouse has a PS2 type plug so these are the setting I chose:
Microsoft, /dev/psaux, and kept all the other defaults

Any ideas?
Any help is appreciated,

Thanks. Patrick
Old 12-12-2001, 09:11 PM   #2
Senior Member
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Imwheel used to do this to my mouse.
Old 12-13-2001, 11:47 AM   #3
LQ Newbie
Registered: Nov 2001
Location: Canada
Distribution: RedHat 7.2
Posts: 8

Rep: Reputation: 0
Are you running the GPM in the console? It can interfere with X.

Type gpm -k to stop it, then configure X.
Old 12-13-2001, 07:52 PM   #4
LQ Guru
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
Microsoft under XF86Setup or even xf86config means the Microsoft Intellimouse, different beast than the PS/2. Try configuring from xf86config (which probably won't work, and if it doesn't, it should use your XF86Config file that dosn't work as the default while configuring in the GUI. This will keep your mouse from going berserk.

Killing Gpm may very well fix the problem too... I just remembered that was a problem my friend had when he decided to install DebPotato.

Regardless, Luck

Old 12-14-2001, 04:55 AM   #5
LQ Guru
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
check /dev/mouse to see where it's pointing

in /etc/X11/XF86Config-4

check the Protocal being used

it should be IMPS/2

the Device should be /dev/mouse
Old 12-14-2001, 12:09 PM   #6
LQ Newbie
Registered: Nov 2001
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for the help.

I'm not running gpm.

I think it could be my video card setup. I am going to look into that next. As well as link /dev/mouse to /dev/psaux.
seems weird.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Black screen with mouse pointer X duncnz SUSE / openSUSE 9 09-11-2006 07:58 PM
Mouse pointer jumps around the screen gaz_dc Linux - Hardware 2 01-02-2005 12:22 PM
no mouse pointer on 2nd screen runaway Linux - Laptop and Netbook 2 10-23-2004 05:36 AM
Mouse pointer distorted on XFree86 4.3 with Geforce FX 5200 EnigmaX Linux - General 1 06-06-2004 10:51 PM
Newbie help - mouse jumps in XFree86 Brentiepooh Linux - Newbie 5 02-10-2002 01:22 AM

All times are GMT -5. The time now is 02:01 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration