LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-06-2004, 02:55 PM   #1
peevee
LQ Newbie
 
Registered: Sep 2003
Location: india
Distribution: redhat
Posts: 18

Rep: Reputation: 0
mounting windows partitions in writable mode for a normal user


i am presently using my windows partition in writable mode logged in as a root.
how to make those partitions writable for a normal user also?

when i am aliasing my httpserver to use a directory in windows partition, its telling
permission not there.....
how to solve this prblem?
i am doing all this under root only..
give me some solutions..
thanks in advance
 
Old 11-06-2004, 03:22 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,378

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
add umask=000 to your mount options
 
Old 11-06-2004, 03:24 PM   #3
hitesh_linux
Member
 
Registered: Dec 2001
Location: /root
Distribution: FreeBSD,NETBSD,redhat
Posts: 472

Rep: Reputation: 30
did you check permission for that partitions?

Also, you can try with acid_kewpie suggestion under /etc/fstab (mount point)

-/Hitesh

Last edited by hitesh_linux; 11-06-2004 at 03:26 PM.
 
Old 11-07-2004, 02:09 PM   #4
peevee
LQ Newbie
 
Registered: Sep 2003
Location: india
Distribution: redhat
Posts: 18

Original Poster
Rep: Reputation: 0
i am auto mounting them in fstab,
but i am using those partitions in root as write mode,
but not in normal user
i heard that in fstab also default is write mode mounting..
but not working for normal user
 
Old 11-07-2004, 04:08 PM   #5
ElPuello
Member
 
Registered: Apr 2004
Location: Copenhagen, Denmark
Distribution: Gentoo + Debian PPC
Posts: 44

Rep: Reputation: 15
I assume the disk is vfat? If not, I'm not sure how to do it.

You should add the uid option to your fstab, so you line looks something like this:

/dev/hda3 /mnt/windooze vfat uid=**your user name** 0 0

along with the uid option you should add your other default options.

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DC-Gui, Active mode as normal user? Borka Linux - Software 0 06-25-2004 05:22 AM
mplayer - in normal user mode problem ruhl22 Linux - Software 1 06-20-2004 12:20 PM
Making Windows shares writable when mounting in RH9 biased99 Linux - Networking 2 03-03-2004 04:40 AM
Changing from text to GUI in normal user mode rcmadhu Linux - Newbie 1 11-30-2003 03:05 PM
Slack 9: mounted FAT32 partitions cannot be accessed by normal user Obi-Wan_Kenobi Slackware 6 07-12-2003 11:15 PM


All times are GMT -5. The time now is 04:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration