LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-20-2003, 11:22 PM   #1
praveen_2003
Member
 
Registered: Apr 2003
Location: india
Posts: 144

Rep: Reputation: 15
Mounting Problems


i have installed redhat 8.0 on my machine with kernel 2.4.18-14.i have installed redhat on my 40GB hdd,allocating 5GB for redhat.i have 4 partitions for windows.but i am not able to mount windows FAT32 partitions(Eg "mount /dev/hda1")it says "mount:can't find /dev/hda3 in /etc/fstab or /etc/mtab".so i edited fstab to mount my FAT32 partition.but still i receive another message that "mount:fs type Win95 FAT32 not supported by kernel".is that line i have edited on fstab is correct?i have added one line to enable one partition as

/dev/hda7 /dev/hda7 Win95 FAT32 defaults 0 0

MY PARTITION INFORRMATION IS AS FOLLOWS:

DEVICE BOOT ID SYSTEM
/dev/hda1 c Win95 FAT32 (LBA)
/dev/hda2 f Win95 Ext'd (LBA)
/dev/hda5 b Win95 FAT32
/dev/hda6 b Win95 FAT32
/dev/hda7 b Win95 FAT32
/dev/hda8 83 Linux
/dev/hda9 82 Linux Swap

so what should i do to enable FAT32 support on my kernel.
.......... thank you........
 
Old 04-20-2003, 11:49 PM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Check cat /etc/proc/filesystems to see if vfat is listed. Try modprobe vfat. If you get nothing from either, you'll either need to add a vfat module to your kernel drivers in /lib/modules or rebuild a new kernel to add support for vfat filesystems.

You also have the option to try umsdos or one of the other similar yet more restrictive identifiers for the fat filesystem.

Cool
 
Old 04-23-2003, 05:48 AM   #3
praveen_2003
Member
 
Registered: Apr 2003
Location: india
Posts: 144

Original Poster
Rep: Reputation: 15
I COULD SEE THE VFAT LISTED IN /ETC/FILESYSTEM BUT I GET ANOTHER MESSAGE AS
mount:/dev/hda7 is not a directory
 
Old 04-23-2003, 02:48 PM   #4
AnthonyM
Member
 
Registered: Mar 2002
Location: Toronto, Ontario
Posts: 43

Rep: Reputation: 15
You maybe trying to mount the partition to a /dev directory.

Create a directory (mkdir /mnt/win95), then issue this:
mount -t vfat /dev/hda7 /mnt/win95

The above should work. Once you get it working, change your fstab file to point the partition to the correct directory on your / directory (ex. /mnt/win95). You can then access your partition from the /mnt/win95 directory.
 
Old 04-23-2003, 05:19 PM   #5
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,186

Rep: Reputation: 52
the whole point being that linux calls fat32 vfat,
so when you use the term fat32 in linux, linux says
it doesn't have support for fat32, when actually it means
it doesn't know what you are talking about when
you say fat32. change that fstab entry to vfat
 
Old 04-24-2003, 05:33 AM   #6
praveen_2003
Member
 
Registered: Apr 2003
Location: india
Posts: 144

Original Poster
Rep: Reputation: 15
mounting problems

thank you mr.AnthonyM and mr whansard
.it worked perfectly.thank you very much.hat's off.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting problems ssabljic Slackware 3 11-25-2005 04:27 AM
Mounting problems sri_hassan Linux - Newbie 3 10-07-2005 08:22 PM
mounting problems eo697 Linux - Hardware 1 07-04-2003 06:05 AM
problems mounting ewto Linux - Newbie 18 04-11-2003 03:34 AM
Mounting problems tsitras Linux - Newbie 3 03-23-2003 03:40 PM


All times are GMT -5. The time now is 08:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration