LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-07-2002, 04:18 AM   #1
matjaz85
LQ Newbie
 
Registered: Aug 2001
Distribution: SuSE 8.0
Posts: 26

Rep: Reputation: 15
!mounting in Mandrake 8.2!


I have problems with mounting windows partitions under mandrake 8.2. I can mount them as a root, but if I try to do it as a user, I get the following error message: You don't have enough permissions!
And that's not all; the same problem I have with mounting CDs and floppy!
If I try to change permission to a mounting point (e.g. (/mnt/cdrom) as a root, I can't, because I don't have enough permissions, again!
What do I do wrong???
 
Old 04-07-2002, 04:28 AM   #2
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
hum...
you just CANT mount partition when you are logged in as user.
Create a new group/user with enought permission or use command prompt.
 
Old 04-07-2002, 06:14 AM   #3
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Edit your /etc/fstab file. Add user to the lines for cdrom, floppy, and windows. The lines below are the ones I use.

/dev/fd0 /mnt/floppy vfat user,noauto,rw 0 0
/dev/cdrom /mnt/cdrom iso9660 user,noauto,ro 0 0
/dev/hda1 /mnt/windows vfat user,noauto,ro 0 0
 
Old 04-08-2002, 12:06 AM   #4
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
Quote:
Originally posted by linuxcool
Edit your /etc/fstab file. Add user to the lines for cdrom, floppy, and windows. The lines below are the ones I use.

/dev/fd0 /mnt/floppy vfat user,noauto,rw 0 0
/dev/cdrom /mnt/cdrom iso9660 user,noauto,ro 0 0
/dev/hda1 /mnt/windows vfat user,noauto,ro 0 0
If you want all users to have full permissions to the Windows partition, use the "umask" option in place of the "ro" option. To use linuxcool's example:

/dev/hda1 /mnt/windows vfat user,noauto,umask=0 0 0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Jumpdrive Mounting and Mandrake 9.2 Newb_Linux_Geek Linux - Hardware 5 07-26-2005 01:54 PM
Mounting /fd0 in Mandrake 10.01 gmag Linux - Newbie 3 02-04-2005 05:10 AM
Does Mandrake 10 do a better job of mounting than 9? silentwhispers Mandriva 3 08-01-2004 09:45 AM
Mounting NTFS in Mandrake 9.1 sdr_ar Mandriva 6 05-04-2004 07:39 PM
mounting vfat in mandrake 9.0 bentbike1 Linux - Software 10 04-18-2003 09:48 PM


All times are GMT -5. The time now is 07:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration