LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-10-2003, 09:46 AM   #1
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current, SlackwareARM-current
Posts: 780

Rep: Reputation: 66
Unhappy mounting cd or flop from gnome desktop


Hi,

mounting cdrom or flop from a terminal prompt works fine, but when I want to mount cdrom or flop by rightclicking the desktop (gnome/RH9) does not. The option is somehow blocked.

Should I change some permissions specific for the gnome desktop?

Here is fstab:

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
LABEL=/home /home ext3 defaults 1 2
/dev/hda5 /mnt/data vfat auto,umask=0 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda7 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
[root@leon-fyg leon]#
 
Old 12-10-2003, 03:49 PM   #2
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
Try substituting the 'owner' option with 'user'
 
Old 12-11-2003, 02:28 AM   #3
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current, SlackwareARM-current
Posts: 780

Original Poster
Rep: Reputation: 66
Changing owner to user does not solve it :-(
Other tips?
 
Old 12-11-2003, 06:28 AM   #4
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Debian + Ubuntu
Posts: 4,358

Rep: Reputation: 57
Have you tried rewriting your fstab entry? Mine looks like:
Code:
/dev/fd0 /mnt/floppy auto noauto,users 0 0
The 'users' allows any and all users to mount/umount it regardless of who mounted it (useful) and getting rid of kudzu means that it isn't automatically mounted when you try to read from /mnt/floppy.

I think the kudzu thing is what is causing the problem here.
 
Old 12-11-2003, 06:58 AM   #5
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current, SlackwareARM-current
Posts: 780

Original Poster
Rep: Reputation: 66
Getting rid of kudzu didn't solve it. Strange thing is that mounting from prompt works fine.

Other question: why is there a 'ro' (root?) added in the cdrom line and not in the floppy line?
 
Old 12-11-2003, 07:13 AM   #6
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Debian + Ubuntu
Posts: 4,358

Rep: Reputation: 57
ro stands for read only.
 
Old 12-11-2003, 12:56 PM   #7
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
What error message do you get when you mount from gnome?
 
Old 12-12-2003, 02:31 AM   #8
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current, SlackwareARM-current
Posts: 780

Original Poster
Rep: Reputation: 66
The problems seems to be solved, somehow. The suggested changes in fstab did't have any effect, so I restored the original fstab, and voila, cdrom and flop can be mounted from the desktop. Life's full of surprises ;-) No idea what's changed though...
 
Old 12-12-2003, 03:12 AM   #9
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
maybe fstab wasn't readable by your user?
 
Old 12-12-2003, 05:14 AM   #10
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current, SlackwareARM-current
Posts: 780

Original Poster
Rep: Reputation: 66
I think it was readable because I could mount as user in the terminal. ?
 
Old 12-13-2003, 08:35 AM   #11
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
mount command is setuid root, so you don't need access to fstab to use it. However, gnome might need it to know which device or folder to mount. Just a guess, I don't actually know.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 eth1 flip flop slinky2004 Linux - General 2 11-09-2005 07:21 PM
Loss of desktop functionality after setting new desktop from firefox in fc2/gnome. dr_zayus69 Linux - Software 3 03-09-2005 09:29 AM
Desktop Mounting in Gnome - FC3 RemusX2 Linux - General 0 12-25-2004 05:18 PM
CD-ROM.desktop on KDE desktop / mounting drives as users theabyyss Linux - General 2 02-22-2002 09:07 PM
arpwatch flip-flop masroor Linux - Security 1 12-23-2001 08:53 AM


All times are GMT -5. The time now is 08:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration