LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-26-2005, 03:01 AM   #1
kronchev
LQ Newbie
 
Registered: Jul 2003
Distribution: Debian (sarge)
Posts: 17

Rep: Reputation: 0
mounting and permissions


Hey all,

I have two harddrives, a system drive and a 200 gig drive. the 200 is divided into two 100 gig partitions, NTFS. I want to mount each partition to a directory (/hd2 and /hd3). I can only mount when I su, obviously, but then since its NTFS (i assume), I can only READ as su. That means that XMMS and other things bitch at me when I try to access. How can I get around this? Will adding to fstab fix this? I havent actually tried that but if theres a better way (at the least, for future reference), i'd love to know it.

Thanks!

/edit: I know I can only read NTFS, that doesnt matter

/edit2: I'm still not sure how to edit fstab, even as su it wont


/edit3: completly unrelated, but whats a really easy way to test how well my 3d is working in linux?

Last edited by kronchev; 03-26-2005 at 03:22 AM.
 
Old 03-26-2005, 03:27 AM   #2
Seppel
Member
 
Registered: Aug 2003
Location: Germany
Distribution: Frugalware (everywhere), Ubuntu (notebook only), Tomato (router)
Posts: 73

Rep: Reputation: 15
Hi kronchev,

add these lines to your /etc/fstab:

/dev/hdb1 /hd2 ntfs gid=100,umask=002,noexec,nosuid 1 0
/dev/hdb2 /hd3 ntfs gid=100,umask=002,noexec,nosuid 1 0

The parameters shown above are working in my setup.
This is not the clearest way to do it since permission 775 is given to the disks, but as they are mounted read-only 'cause of NTFS, you can at least read from it with all users. If you want to do it clearer, set the umask option to 222 (it's always 7-(the userperms you want to set for user/group/anybody), so 222 means 555 permissions (all read, all execute) ). I don't know if this will work, but it should.
Be sure that you have created /hd2 and /hd3 (with mkdir) before! And also be sure that the physical hd you're accessing is hdb, which is primary slave. I don't know which device parameters to set for SATA drives. Please report anything you've found out (also if it works!).

Hope I could help you :-)

Seppel
 
Old 03-26-2005, 05:28 AM   #3
kronchev
LQ Newbie
 
Registered: Jul 2003
Distribution: Debian (sarge)
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Seppel
Hi kronchev,

add these lines to your /etc/fstab:

/dev/hdb1 /hd2 ntfs gid=100,umask=002,noexec,nosuid 1 0
/dev/hdb2 /hd3 ntfs gid=100,umask=002,noexec,nosuid 1 0

The parameters shown above are working in my setup.
This is not the clearest way to do it since permission 775 is given to the disks, but as they are mounted read-only 'cause of NTFS, you can at least read from it with all users. If you want to do it clearer, set the umask option to 222 (it's always 7-(the userperms you want to set for user/group/anybody), so 222 means 555 permissions (all read, all execute) ). I don't know if this will work, but it should.
Be sure that you have created /hd2 and /hd3 (with mkdir) before! And also be sure that the physical hd you're accessing is hdb, which is primary slave. I don't know which device parameters to set for SATA drives. Please report anything you've found out (also if it works!).

Hope I could help you :-)

Seppel
Thanks, I added them and will restart. I tried editing fstab before since I thought I could probably guess the params (looks like I was wrong anyway ) but it was read-only, even as su.


/edit: worked like a charm, thanks!

Last edited by kronchev; 03-26-2005 at 06:05 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting Permissions canuck_barlow Linux - Newbie 11 03-16-2005 10:33 PM
folder permissions when mounting to them Lokheed Linux - Hardware 2 09-16-2004 10:52 PM
Mounting and Permissions ngreimel Linux - Newbie 3 08-10-2004 05:26 PM
Mounting Permissions ewto Linux - Newbie 2 09-30-2003 05:22 AM
Mounting permissions loganwva Linux - Networking 2 04-25-2002 05:14 PM


All times are GMT -5. The time now is 05:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration