LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   mount/umount usb stick - PQI Intelligent Stick 2.0 (http://www.linuxquestions.org/questions/linux-software-2/mount-umount-usb-stick-pqi-intelligent-stick-2-0-a-320564/)

sandbag 05-05-2005 08:20 PM

mount/umount usb stick - PQI Intelligent Stick 2.0
 
Hi All:
I'm sure this will be a simple answer for one of you Linux Gurus out there. I have successfully configured, mounted and transferred files from my PQI Intelligent Stick 2.0 to my IBM Thinkpad 570 --which has Fedora Core 1 installed on it. I have done the following to mount the usb stick:

1) Create a mount point - /mnt/usbdisk
2) Add the following entry in /etc/fstab -
/dev/sda /mnt/floppy auto noauto,owner,kudzu 0 0
3) Entered at terminal - mount /dev/sda /mnt/usbdisk

When I unmount the usb stick with the command "umount /mnt/usbdisk" I lose the mount point and fstab entry. I notice that these don't go away when I unmount the floppy, so how can I keep from retyping these commands over and over again?
Thanks,
_sandbag

Valhalla 05-05-2005 08:42 PM

Edit: misread your post

Are you using some kind of automounting software like HAL or IVMAN?

You might also want to set the options you use to mount it as users,gid=users,noauto.

sandbag 05-06-2005 04:12 AM

Nope. Not to my knowledge anyway. I believe Fedora recognizes the usb stick because it sees it under hwbrowser, but I have to go thru the steps outlined to mount the usb stick. Should I consider one of the two apps you cited?

oneandoneis2 05-06-2005 04:38 AM

Eh?

fstab - /dev/sda /mnt/floppy

mount /dev/sda /mnt/usbdisk

Why the mismatch??

Also, are you sure you shouldn't be mounting /dev/sda1 rather than just /dev/sda?

Valhalla 05-06-2005 10:58 AM

It would probably be better to use a single mount /dev/sda command if its in fstab. I don' tknow why you made a seperatemount point then mounted it at floppy. It would probably be better to try mounting /dev/sda1 though, unless your usb has a flipped out partition scheme.

sandbag 05-06-2005 11:12 AM

oops, I think I made a mistake. The line is supposed to be:

/dev/sda /mnt/usbdisk auto noauto,owner,kudzu 0 0

Thanks! I'll try sda1. I think in hwbrowser it listed the stick as sda, which is why I used that instead of sda1.


All times are GMT -5. The time now is 01:04 PM.