LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   mount problem with util-linux-2.12a (http://www.linuxquestions.org/questions/linux-software-2/mount-problem-with-util-linux-2-12a-185533/)

Fonk 05-25-2004 04:34 AM

mount problem with util-linux-2.12a
 
Hello,

I recently compiled & installed the util-linux-2.12a because of the "mount version older than kernel" which comes with the new kernel 2.6.5, but now I can't mount filesystems by passing only the mountpoint to mount (e.g. mount /mnt/cdrom)... I always get

"mount: wrong fs type, bad option, bad superblock on /dev/cdrom, or too many mounted file systems"

and if I try "mount /mnt/floppy" the drive accesses the floppy ans Linux tells

"mount: block device /dev/fd0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/fd0, or too many mounted file systems"

If I pass the fs-type (e.g. mount -t iso9660 /dev/cdrom /mnt/cdrom or mount -t vfat /dev/fd0 /mnt/floppy) it works perfectly...

Now I'm afraid of rebooting my system - perhaps it doesn't mount the root-fs! :-/ I read some articles about mount reading the /etc/filesystems and /proc/filesystems but they are set up correctly I think... any clues?!

Greetings

herbc 05-26-2004 01:17 AM

Did /etc/fstab get clobbered by the new kernel? I'm unfamiliar with 2.6.x so AFAIK it may not
even use /etc/fstab anymore. In which case, I'm of no use.

/herbc

Fonk 05-26-2004 03:11 AM

I think it's a problem of util-linux-2.12a, because before I installed them, it worked... Furthermore it seems like using /etc/fstab, because it knows the mountpoints...

Today I found the message

"hdc: ATAPI 40X CD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
cdrom: This disc doesn't have any tracks I recognize!"

in dmesg... perhaps it helps to give me a hint...

Fonk 05-26-2004 04:55 AM

Finally found the bug after trying around... but I'm not absolutely sure: If you have the same Problem try to remove the "kudzu"-option in /etc/fstab, if it's present... that helped in my case!

herbc 05-26-2004 10:30 AM

kudzu option is a new one to me. So, the HOWTO-util-linux-2.12a should encourage one to review their /etc/fstab after
installing. Or, at least mention that the kudzu option may cause problems mounting. Good catch.

Fonk 05-27-2004 01:57 AM

Found further information on this kudzu option:

Kudzu is the Redhat "New Hardware"-Assistant and removes not attached hardware from /etc/fstab if the kudzu option is given and inserts new found hardware with the kudzu option if it it mentioned in /etc/updfstab.conf... (as far as I understand...) See man updfstab for more...

I re-emphasize that I'm not completely sure if this option causes the Problem - but where can I find this HOWTO-util-linux-2.12a?

Greets
Frank

herbc 05-27-2004 09:38 AM

Well, I couldn't find a man page for util-linux-2.12a. Open mouth, insert foot, I did.

A goggle on 'kudzu fstab' gave hits on what to do when kudzu clobbers your /etc/fstab and
man 8 updfstab (which ref man kudzu). Not being a RH fan, and not liking things being done
behind my back, I don't have kudzu on my machine. However, it appears that kudzu modifies
/etc/fstab when items like disks and cameras are added or removed from your machine, as
stated in the previous post. It removes lines with the kudzu option, and includes the kudzu option when it adds a line.

util-linux-2.12a is just a collection of utlities like mount, umount and more others than I can
count. My apologies for sending you off looking for its mount page.

Now if I had a line

/dev/fd0 /mnt/floppy ext2 noauto, user, rw, exec, sync 0 0

and kudzu adds the line

/dev/fd0 /mnt/floppy vfat defaults, kudzu 0 0

below it, I would expect problems, since the second line may overwrite my mount point, such
that if I insert my Linux floppy, mount expects a Windows floppy and returns the

mount: wrong fs type, bad option, bad superblock on /dev/fd0, or too many mounted file systems

error. Then again, mount may not recognize the kudzu option in /etc/fstab, and is complaining
in the only way it knows how. Just a guess.

So -- remove the kudzu options in your /etc/fstab. Double check the filetypes for each device.
I have multiple entries for /dev/fd0 and /dev/cdrom with different mount points, depending
on the filetype. For example, /mnt/a for vfat floppies and /mnt/floppy for ext floppies. Replace the defaults option with specific options (see man mount and man fstab). Specifically,
add the noauto option (or remove the auto option) to the cdrom device and maybe your
other removable media. This keeps Linux from trying to mount the device on boot.

Additionally, you might want to do without kudzu running behind your back. In Slackware, one
would comment out the kudzu daemon in /etc/rc.d/rc.local. In RH, I wouldn't know where to
look. In any case, from what I read, kudzu is not supposed to mess with /etc/fstab entries
that do not have the kudzu option. So, at the very least, fix those lines and remove the kudzu
option.

HTH


All times are GMT -5. The time now is 09:25 PM.