LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-23-2003, 04:07 AM   #1
nsong
LQ Newbie
 
Registered: Aug 2003
Distribution: RedHat 9.0
Posts: 7

Rep: Reputation: 0
more issues with mplayer


Reading up on the forum, I've noticed a lot of people having issues with mpalyer, especially on redhat.
Unfortunately, I'm going to add to that.

I've tried installing mplayer both from rpm (with apt) and source, and both times it produces the same errors.

MPlayer 0.91-3.2.2 (C) 2000-2003 MPlayer Team
CPU: Intel Pentium 4 Willamette (Family: 8, Stepping: 10)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/nsong/.mplayer/config
[cfg] read config file: /home/nsong/.mplayer/gui.conf
Reading config file /home/nsong/.mplayer/gui.conf
[nsong@x-factor nsong]$ vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
Reading /home/nsong/.mplayer/codecs.conf: can't open '/home/nsong/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf
Font /home/nsong/.mplayer/font/font.desc loaded successfully! (206 chars)
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup
scripts.
Using usleep() timing
Can't open input config file /home/nsong/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or
directory
Falling back on default (hardcoded) input config
Setting up LIRC support...
mplayer: could not open config file
mplayer: No such file or directory
Failed to read LIRC config file ~/.lircrc.
You will not be able to use your remote control.
SKIN dir 1: '/home/nsong/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'

Again, any help would be appreciated.

-NS
 
Old 08-23-2003, 04:42 AM   #2
deepsix
Member
 
Registered: Apr 2003
Distribution: ANY
Posts: 339

Rep: Reputation: 31
ok......I assume you are using the apt rpm from freshrpms for redhat 9...

I assume the apt-get program is working properly?

First at the command prompt as root type apt-get update.......this causes apt-get to update its list of packages on the server available for download

then type(as root)

apt-get install mplayer

and you should have it
 
Old 08-23-2003, 05:13 AM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
what error...? nothing techinially wrong with any of that....
 
Old 08-23-2003, 01:29 PM   #4
mcquay18
LQ Newbie
 
Registered: Mar 2003
Location: Pennsylvania
Distribution: Redhat 9.0
Posts: 17

Rep: Reputation: 0
I installed MPlayer on: Redhat 9.0 compaq Presario 2500 and really had no problems at all, other than having to tweak sound card a little. Maybe you should read the README a couple more times.
 
Old 08-23-2003, 02:16 PM   #5
nsong
LQ Newbie
 
Registered: Aug 2003
Distribution: RedHat 9.0
Posts: 7

Original Poster
Rep: Reputation: 0
got it working

Never mind. Apparently, the reason why it wasn't working was that I was trying to run mplayer in the background (i.e., gmplayer &) and apparently either the gui or gnome didn't like that.

One more thing:
I compiled mplayer using the --with-xvidcore in ./configure, but the output showed this:

Checking for Xvid ...... no.

Looking in GMplayer preferences in the codecs tab, xvid isn't there, but win32, realplay, quicktime, and all the others are.

??????

-NS
 
Old 09-04-2003, 01:53 PM   #6
zroth
Member
 
Registered: Sep 2003
Distribution: Slack 9.1 & EX:RH 6,7.x, 8 and 9 User
Posts: 36

Rep: Reputation: 15
Re: more issues with mplayer

Quote:
Reading config file /home/nsong/.mplayer/config
I went through this over the weekend.

In your home directory should be a config file. If you gedit (edit) this file it says "#Write your options here"

I put two:

gui=yes
skin=phony (or whatever skin you have downloaded)

then I created a launcher using the mplayer *not gmplayer* command and everything loaded correctly.

I hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
MPLAYER issues jon_k Linux - Software 23 08-27-2004 12:45 AM
Help please !!issues getting mplayer installed copter Fedora 3 07-12-2004 10:58 AM
Mplayer issues ch4s3r Linux - Software 2 03-01-2004 10:41 AM
More mplayer issues...no /.mplayer folder?! lt1derful Linux - Software 3 08-03-2003 10:09 PM
MPLayer GUI Issues - Please :) Slinger Linux - Newbie 2 11-09-2002 03:19 PM


All times are GMT -5. The time now is 04:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration