LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   mono (http://www.linuxquestions.org/questions/linux-software-2/mono-218723/)

gtzpower 08-17-2004 08:28 AM

mono
 
I am trying to install MonoDevelop on a mdk10 box, but make fails. I spent 7 hours getting all of the packages installed and setting paths for ./configure to finally complete, but on make, I get the error:

[root@localhost monodevelop-0.5]# make
Making all in gdldock
make[1]: Entering directory `/dls/mono/monodevelop-0.5/gdldock'
Making all in gdl
make[2]: Entering directory `/dls/mono/monodevelop-0.5/gdldock/gdl'
gapi-codegen --generate gdl-api.xml --include /usr/local/share/gapi/gdk-api.xml /usr/local/share/gapi/gtk-api.xml /usr/local/share/gapi/atk-api.xml --outdir=generated --customdir=. --assembly-name=gdl-sharp && touch generated-stamp
/bin/sh: line 1: gapi-codegen: command not found
make[2]: *** [generated-stamp] Error 127
make[2]: Leaving directory `/dls/mono/monodevelop-0.5/gdldock/gdl'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/dls/mono/monodevelop-0.5/gdldock'
make: *** [all-recursive] Error 1




Appearently, gapi-codegen needs installed, and I see that it is installed by the glib-sharp-1.0-4mdk.i586.rpm package, but when I try to install this package, I get the error:

Some package requested cannot be installed:
glib-sharp-1.0-4mdk.i586 (due to unsatisfied mono[>= 0.96])
do you agree ?



but if I go to a terminal and type mono -V, it currently shows version 1.0, I have also tried 0.95 and 1.0.1:

[root@localhost monodevelop-0.5]# mono -V
Mono JIT compiler version 1.0, (C) 2002-2004 Novell, Inc and Contributors. www.go-mono.com
TLS: __thread
GC: Included Boehm (with typed GC)
SIGSEGV : normal
Globalization: ICU
[root@localhost monodevelop-0.5]#



Can anyone shed some light here?

Thanks!!!!!!!!!!!!!!!!!


All times are GMT -5. The time now is 08:33 PM.