LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 10-14-2003, 10:12 PM   #1
skarim
LQ Newbie
 
Registered: Oct 2003
Location: LA,CA
Distribution: Slackware 9.1
Posts: 9

Rep: Reputation: 0
modules after re-compile kernel


Hi,
I'm a newbie of about 1 week on SK 9.1, and I just finished my first re-compile. I was using 2.4.22, and then I re-compiled the same code to optimize for my system.

I installed the nvidia driver, as well as a alsa module for my echo sound card prior to re-compiling.

1) I can't start x unless i change /etc/X11/XF86config to reflect old nvidia drivers (nv). do i need to re-install them, or can i somehow use the previous?

2) can i direct the boot-up to my echo module, or do I need to re-compile, and then modprobe it again?

responses appreciated
 
Old 10-14-2003, 10:58 PM   #2
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
look in /var/log and post what the XFree86.0.log says......this will tell what errors were encountered while X was trying to load.
 
Old 10-15-2003, 12:28 AM   #3
skarim
LQ Newbie
 
Registered: Oct 2003
Location: LA,CA
Distribution: Slackware 9.1
Posts: 9

Original Poster
Rep: Reputation: 0
it did find my driver, but start up stopped because it said something like system does not support MTRR. Oops, I guess I'm going to be recompiling now.
 
Old 10-15-2003, 02:48 AM   #4
skarim
LQ Newbie
 
Registered: Oct 2003
Location: LA,CA
Distribution: Slackware 9.1
Posts: 9

Original Poster
Rep: Reputation: 0
problems solved- still needed to re-install nvidia driver, but only takes 2 seconds. also had to re-compile, and modprobe sound module , but everything works. thanks for interest.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no modules after kernel compile glorsplitz Slackware 7 09-20-2005 11:26 AM
no lib/modules/2.6.13 after kernel compile Motown Slackware 2 09-07-2005 08:59 AM
unable to compile new modules in the kernel Menestrel Slackware 1 01-09-2005 06:41 AM
Modules error after compile 2.6.8.1 kernel mathias1975 Slackware 12 10-05-2004 03:52 AM
No more modules after kernel compile w/ ck patch uglydot Slackware 3 11-10-2003 04:04 PM


All times are GMT -5. The time now is 01:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration