LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-04-2001, 01:25 AM   #1
busybee
LQ Newbie
 
Registered: Oct 2001
Location: Minneapolis, USA
Distribution: RedHat 7.1
Posts: 15

Rep: Reputation: 0
Modify Boot order in Redhat 7.1


busybee

I have installed Redhat 7.1 and winxp on my sonyfx370 laptop. presently, i want it to boot default in winDOZZE. I have tried modifying the lilo.conf and set the default boot to dos. But that doesnt seem to matter while booting and the default is still linux.

can someone help me wat to change !! ??

thanks

deeps
 
Old 11-04-2001, 01:38 AM   #2
marktaff
Member
 
Registered: Jun 2001
Location: Bellevue, WA (Seattle)
Distribution: SuSE 9.3-10.0
Posts: 53

Rep: Reputation: 15
What boot loader are you using?
 
Old 11-04-2001, 02:09 AM   #3
busybee
LQ Newbie
 
Registered: Oct 2001
Location: Minneapolis, USA
Distribution: RedHat 7.1
Posts: 15

Original Poster
Rep: Reputation: 0
re Modify Boot order in Redhat 7.1

I think Im using Lilo. I havent set any options explicitly while installing Redhat. The laptop came pre-installed with WinXP. I made a partition on c: for 3GB and installed RedHat 7.1. Drive D: is NTFS partition.

As soon as I boot up the system, the Redhat logo(graphic) comes in with an option for linux and dos. I guess that the REdhat must have recognised other OS and installed lilo by default. When i used alt+X, it shifted to command mode with a comment of lilo boot.


I tried changing the /etc/lilo.conf file to reflect the "default=linux" to "default=dos". This doesnt seem to make ANY difference buring booting ..
 
Old 11-04-2001, 03:03 AM   #4
marktaff
Member
 
Registered: Jun 2001
Location: Bellevue, WA (Seattle)
Distribution: SuSE 9.3-10.0
Posts: 53

Rep: Reputation: 15
I do not know for WinXP, but for Win2k (and likely WinXP), you will need to use the NTLoader _FIRST_. This means letting windows control the boot process instead of Linux.

You can use the bootpart program http://www.winimage.com/bootpart.htm
to create the required files, including the boot.ini file.

After that, you can (in Windows)(under Control Panel>>System>>Startup in win2K) add an entry for Linux.

So, When the machine powers on, the NTLoader will run, giving you the choice between windows and linux (with default OS and timeouts specified in windows). If you choose Windows, windows will boot. If you choose linux, LILO will run and present you with its menu (which you can set to automatically load linux), after which linux will load.

An important note: The windows primary partition (usually C cannot be NTFS, or this will not work. It must be FAT16 or FAT32.

Also, your ENTIRE /boot partition must be located within the first 1024 cylinders of your hard drive if you only have one physical drive.

It sounds like you may have to repartition and reformat your drive, and reinstall the OS's again.

Mark
 
Old 11-04-2001, 01:15 PM   #5
busybee
LQ Newbie
 
Registered: Oct 2001
Location: Minneapolis, USA
Distribution: RedHat 7.1
Posts: 15

Original Poster
Rep: Reputation: 0
Lightbulb Boot Problem Solved

busybee

Think I have solved the problem. I was reluctant to reformat the disk. So i tried playing around with lilo config.

edit /etc/lilo.conf and set the default to either windows or dos.

after that u NEED to run 'lilo'. cause i think the boot image needs to registered and lilo.conf is not run everytime the bootloader starts.


hope this helps some one ...
 
Old 11-04-2001, 02:24 PM   #6
marktaff
Member
 
Registered: Jun 2001
Location: Bellevue, WA (Seattle)
Distribution: SuSE 9.3-10.0
Posts: 53

Rep: Reputation: 15
That is very good news

I'm glad you got it working. I hope that means windowsXP plays better with others than win2k...

Might want to send a note to the maintainer of the dual-boot howto...

Mark
 
Old 11-04-2001, 03:48 PM   #7
busybee
LQ Newbie
 
Registered: Oct 2001
Location: Minneapolis, USA
Distribution: RedHat 7.1
Posts: 15

Original Poster
Rep: Reputation: 0
dual boot

busybee

The surprising part was, I did not do any of the "complicated" stuff as mentioned in the loading of a dual boot OS. just made a partition and installed Redhat 7.1. Everything else was taken care of ..

You think I shud mention this to some group ? im not aware of any other group ..

mark .. thanks for trying to help me out
 
Old 11-04-2001, 05:36 PM   #8
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Whenever you make changes in lilo.conf, you have to run lilo again for the changes to take effect.
 
Old 11-06-2001, 01:27 AM   #9
marktaff
Member
 
Registered: Jun 2001
Location: Bellevue, WA (Seattle)
Distribution: SuSE 9.3-10.0
Posts: 53

Rep: Reputation: 15
You are welcome. I got my problem fixed as well. Turns out GRUB will dual boot RH 7.2 and win2k using the same procedure as for LILO.

RH 7.2 is much slicker than 7.1, at least as far as KDE and the other apps goes. It is so easy now, I actually have my mother (not a computer geek, by ANY stretch!), wanting to use RH 7.2 w/ KDE instead of win2k.

Mark
 
Old 11-06-2001, 05:45 AM   #10
ugge
Senior Member
 
Registered: Dec 2000
Location: Gothenburg, SWEDEN
Distribution: OpenSUSE 10.3
Posts: 1,028

Rep: Reputation: 45
Re: Boot Problem Solved

Quote:
Originally posted by busybee
busybee

Think I have solved the problem. I was reluctant to reformat the disk. So i tried playing around with lilo config.

edit /etc/lilo.conf and set the default to either windows or dos.

after that u NEED to run 'lilo'. cause i think the boot image needs to registered and lilo.conf is not run everytime the bootloader starts.


hope this helps some one ...
This has to do with the way lilo works in contrast to windows ntloader. Ntloader reads the boot.ini file at every boot.
lilo doesn't actually read the config file, all of the nessesary configuration are written to the boot block at installation of lilo.
Everytime you run the lilo command you do a new installation to the boot block with the new settings.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
grub question changing boot order making windows boot first nfsutim Linux - Newbie 29 10-27-2012 12:53 PM
Unable to modify RedHat Linux BootRecord Darthcoder Linux - Newbie 1 11-07-2003 02:23 PM
how to modify the boot sequence? sirpelidor Mandriva 6 11-02-2003 09:23 AM
changing redhat 7.3 boot order CyberSteve Linux - Software 1 04-20-2003 08:14 PM
How to modify boot up sequence??? Marci Sarwan Linux - General 1 02-23-2001 08:58 AM


All times are GMT -5. The time now is 04:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration