LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Missing folders when accessing samba share from XP (http://www.linuxquestions.org/questions/linux-software-2/missing-folders-when-accessing-samba-share-from-xp-211664/)

IgniZtion 07-30-2004 08:11 PM

Missing folders when accessing samba share from XP
 
I use Samba 3.0.5 on a slackware10 box

I have a Share something like this

//linux-box/Share

this share has 4 directories and in one of these 4 directories there are about 250 directories. The problem being that when I browse this directory from XP only about 140 of the dirs are showing. I can access all the others by manually typing in the name of the directory, but they don't show in Windows Explorer.

When accessing the same share from linux I can see all the dirs, but the first dir that isn't showing has a 'V' in front of it when using smbclient.

Dir1 Perm Size Date
V Dir2 Perm Size Date
Dir3 Perm Size Date

Is there a solution to this, or does windows limit the number of subdirs allowed in a remote dir?

Cheers

IgniZtion 08-18-2004 09:50 PM

Just adding a note. When accessing the share from smbclient I get a 'v' in front of the first share that is not showing in windows. If I however mount the share, everything is normal, and all the directories are there.

Can anyone give me some hints please

Cheers

IgniZtion 08-18-2004 11:34 PM

Finally figured it out. It was a charset problem. Some of the folders used international characters, and I had forgotten to change the unix charset in smb.conf to ISO 8859-1 from the default UTF-8. Samba was then unable to convert the characters to the proper charset for windows. :study: helps


All times are GMT -5. The time now is 06:10 PM.