LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-11-2012, 02:23 PM   #1
Imyrryr
Member
 
Registered: Aug 2003
Location: 3rd electron on the left getting mugged by the nutrinos at Quarks
Distribution: Slackware 13.37, Mint
Posts: 138

Rep: Reputation: 17
Midnight Commander, F-keys, UTF-8 and ASCII characters not showing correctly


I'm pretty sure this is something I've not get set right in my environment variables but I'll be blasted if I know what I'm missing.

When I launch MC (yes I still use MC) from command line or anything that uses the ASCII codes for drawing lines and right angles they come out with:
'q' for the vertical line
'x' horizontal lines
'j,k,l,m' for the right angles
Code:
qqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqq.[^]>kl<q ~ 
qqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqq.[^]>kx'n                         Name                          x Size  xModify time 
xx'n                         Name                                               x Size  xModify time xx/..                                                      xUP--DIRxOct  3 
14:42xx/..                                                                      xUP--DIRxSep 18 16:01xx .directory                                              x     
48xSep  2 18:00xx/.AbiSuite                                                     x   4096xApr  1  2012xx Achafexp.ttf                                            
x  60544xAug 23  2000xx/.BitchX                                                 x   4096xAug 21 18:55xx Achafita.ttf                                            
x  61676xAug 23  2000xx/.Eterm                                                  x   4096xMar 15  2012xx Achaflft.ttf                                            
x  61016xAug 23  2000xx/.adobe                                                  x   4096xJan 31  2011xx Achafont.ttf                                            
x  59760xAug 23  2000xx/.audacity-data                                          x   4096xMar  8  2011xx Achafout.ttf                                            
x 118260xAug 23  2000xx/.blackbox                                               x   4096xSep 11 18:39xx Achafsex.ttf                                            
x  61548xAug 23  2000xx/.cache                                                  x   4096xOct  9 18:22xx AtomicAge-Regular.ttf                                   
x  31048xAug 28 12:59xx/.centerim                                               x   4096xJun 28  2011xx Boogaloo-Regular.ttf                                    
x  33928xAug 28 12:59xx/.config                                                 x   4096xOct  2 12:04xx Cardinal-Alternate.ttf                                  
x  50948xAug 27  2003xx/.dbus                                                   x   4096xJan 31  2011x
I also have to use 'esc+number' to get the function keys from F1-F9 to work in the application, but F10 works just fine.

When I launch into fluxbox and go into xterm/rxvt/terminal everything works just peachy.

In lilo.conf I have
Code:
append = "vt.default_utf8=1"
When I run setconsolefont any font that is selects show the same kind of anomaly with no ASCII lines just letters in their place.

Here are my 'set' configuration
<snip>
Code:
tcsh    6.18.01
term    xterm
tty     pts/2
uid     1000
user    kage
version tcsh 6.18.01 (Astron) 2012-02-14 (i686-intel-linux) options wide,nls,dl,al,kan,rh,filec
visiblebell
mc --version =

GNU Midnight Commander 4.8.4
Built with GLib 2.32.4
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, fish, smbfs
Data types: char: 8; int: 32; long: 32; void *: 32; size_t: 32; off_t: 64;
Any ideas?

Last edited by Imyrryr; 10-11-2012 at 03:27 PM. Reason: More info
 
Old 10-12-2012, 03:26 PM   #2
segmentation_fault
Member
 
Registered: Sep 2008
Location: Ioannina, Greece
Distribution: Gentoo
Posts: 332

Rep: Reputation: 54
I use mc too. In fact, it's the only file manager I use. I had the same issue when I was trying to set up my greek locales correctly. So I believe it's locale related. Do unicode characters display correctly on your terminal? Eg localized filenames with ls ?
 
Old 10-12-2012, 09:16 PM   #3
Imyrryr
Member
 
Registered: Aug 2003
Location: 3rd electron on the left getting mugged by the nutrinos at Quarks
Distribution: Slackware 13.37, Mint
Posts: 138

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by segmentation_fault View Post
I use mc too. In fact, it's the only file manager I use. I had the same issue when I was trying to set up my greek locales correctly. So I believe it's locale related. Do unicode characters display correctly on your terminal? Eg localized filenames with ls ?
If I'm following correctly, here is an example "'ls' of my backups"
Code:
 12M -rw-r--r--  1 evil root  12M Oct 12 02:03 etc.tar.bz
 16G -rw-r--r--  1 evil root  16G Oct  7 06:10 home.tar.bz
 66M -rw-r--r--  1 evil root  66M Oct 12 02:03 usrlocal.tar.bz
 96K -rw-------  1 evil root  95K Oct 12 00:00 webmin-config
If I didn't answer this right, my apologies preemptively.
 
Old 10-13-2012, 02:03 AM   #4
segmentation_fault
Member
 
Registered: Sep 2008
Location: Ioannina, Greece
Distribution: Gentoo
Posts: 332

Rep: Reputation: 54
I was asking if you can see locale characters on your terminal, eg greek, spanish, chinese or whatever your locale is set to. If not, then your locale is not set up properly.
 
Old 10-14-2012, 07:22 PM   #5
Imyrryr
Member
 
Registered: Aug 2003
Location: 3rd electron on the left getting mugged by the nutrinos at Quarks
Distribution: Slackware 13.37, Mint
Posts: 138

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by segmentation_fault View Post
I was asking if you can see locale characters on your terminal, eg greek, spanish, chinese or whatever your locale is set to. If not, then your locale is not set up properly.
Thank you for the assist, I checked out my LOCALE and it was set to 'en_US' which is correct, but it got me thinking about some other settings, so I set "vt.default_utf8=0" and changed my TERM settings from "xterm" to "linux" this seems to have fixed it.
 
Old 10-15-2012, 04:08 AM   #6
segmentation_fault
Member
 
Registered: Sep 2008
Location: Ioannina, Greece
Distribution: Gentoo
Posts: 332

Rep: Reputation: 54
It's good you worked it out! As for the locale settings, if you want to check it further, mine are set to en_US.UTF_8 and my /etc/conf.d/consolefont has
Code:
consolefont="iso07u-16"
consoletranslation="8859-7_to_uni"
unicodemap="iso07u"
but as long as vt.default_utf8=0 works I believe you are ok.
 
Old 10-15-2012, 12:40 PM   #7
Imyrryr
Member
 
Registered: Aug 2003
Location: 3rd electron on the left getting mugged by the nutrinos at Quarks
Distribution: Slackware 13.37, Mint
Posts: 138

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by segmentation_fault View Post
It's good you worked it out! As for the locale settings, if you want to check it further, mine are set to en_US.UTF_8 and my /etc/conf.d/consolefont has
Code:
consolefont="iso07u-16"
consoletranslation="8859-7_to_uni"
unicodemap="iso07u"
but as long as vt.default_utf8=0 works I believe you are ok.
I will check this for sure, thanks!
 
Old 01-23-2013, 08:39 AM   #8
BerzinTehvs
Member
 
Registered: Mar 2005
Location: Latvia
Distribution: Slackware
Posts: 47

Rep: Reputation: 15
I have the same problems, but quite specific:
there is no UTF-8 support in MC's internal viewer and editor, while, for example, cat file.ext displays text correctly in Konsole (KDE 4.9.5).

To add another edge of the problem - all this is happening in VirtualBox (4.2.6) VM, on physical hardware with the same config I have no problems.

Last edited by BerzinTehvs; 01-23-2013 at 08:42 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Midnight Commander F-keys problem. c4c711 Linux - Software 3 05-21-2012 11:56 AM
tmux not showing utf-8 characters correctly zagzagel Linux - Software 4 03-01-2012 04:38 AM
[SOLVED] Shortcut keys in Midnight Commander xeon123 Linux - Newbie 3 12-22-2010 01:58 PM
Midnight Commander 4.6.2 (also 4.6.1) - F1 to F12 keys doesnt work dlugasx Solaris / OpenSolaris 1 06-25-2009 09:06 AM
Midnight Commander: UTF-8.patch for mc-2007-06-23-14 test r2008-09-12. vit_r Slackware 5 09-15-2008 08:06 PM


All times are GMT -5. The time now is 05:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration