LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 10-31-2009, 06:23 AM   #1
[ITA]freeware
Member
 
Registered: Jul 2004
Distribution: Debian jessie
Posts: 75

Rep: Reputation: 15
MIDI trouble with ALSA 1.0.21


hi guys,

i'm in trouble with midi output: it seems to be alive, but it doesn't work. I've installed latest alsa drivers version, and after autoconfiguration (new alsautils seems not to include alsaconf..bah..) midi modules are loaded, but midi output is silent...anyway, i hear every non-midi audio output.

look there..

Code:
debian:/home/marco# lsmod | grep snd
snd_seq_dummy           2424  1 
snd_hda_codec_nvhdmi     2676  1 
snd_hda_codec_realtek   178484  1 
snd_hda_intel          22196  0 
snd_hda_codec          63596  3 snd_hda_codec_nvhdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               6120  1 snd_hda_codec
snd_pcm_oss            32240  0 
snd_mixer_oss          12372  1 snd_pcm_oss
snd_pcm                62424  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_midi            5688  0 
snd_rawmidi            18596  1 snd_seq_midi
snd_seq_midi_event      6212  1 snd_seq_midi
snd_seq                42308  5 snd_seq_dummy,snd_seq_midi,snd_seq_midi_event
snd_timer              17440  2 snd_pcm,snd_seq
snd_seq_device          6136  4 snd_seq_dummy,snd_seq_midi,snd_rawmidi,snd_seq
snd                    49044  12 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               6184  1 snd
snd_page_alloc          8120  2 snd_hda_intel,snd_pcm
Code:
debian:/home/marco# cat /dev/sndstat
Sound Driver:3.8.1a-980706 (ALSA v1.0.20 emulation code)
Kernel: Linux debian 2.6.30-bpo.1-686 #1 SMP Mon Aug 17 14:57:26 UTC 2009 i686
Config options: 0

Installed drivers: 
Type 10: ALSA emulation

Card config: 
HDA Intel at 0xf9ff8000 irq 22

Audio devices:
0: ALC663 Analog (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices: NOT ENABLED IN CONFIG

Timers:
7: system timer

Mixers:
0: Nvidia MCP78 HDMI
Code:
debian:/home/marco# aplaymidi -l
 Port    Client name                      Port name
 14:0    Midi Through                     Midi Through Port-0
why it says not enabled?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MIDI and ALSA: no ports at all! bartkl Linux - Hardware 3 11-22-2008 07:25 AM
midi software and alsa troubles... lostinpurdy Linux - Software 1 05-18-2007 04:35 PM
cannot start ALSA midi ctdarksilver Ubuntu 2 10-18-2006 01:15 AM
ALSA MIDI on Debian Sarge sulfa Linux - Software 1 12-16-2004 04:21 PM
MIDI with ALSA on ESS1869 xianath Linux - Hardware 0 03-02-2004 04:50 AM


All times are GMT -5. The time now is 09:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration