LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   MIDI trouble with ALSA 1.0.21 (http://www.linuxquestions.org/questions/linux-software-2/midi-trouble-with-alsa-1-0-21-a-765753/)

[ITA]freeware 10-31-2009 06:23 AM

MIDI trouble with ALSA 1.0.21
 
hi guys,

i'm in trouble with midi output: it seems to be alive, but it doesn't work. I've installed latest alsa drivers version, and after autoconfiguration (new alsautils seems not to include alsaconf..bah..) midi modules are loaded, but midi output is silent...anyway, i hear every non-midi audio output.

look there..

Code:

debian:/home/marco# lsmod | grep snd
snd_seq_dummy          2424  1
snd_hda_codec_nvhdmi    2676  1
snd_hda_codec_realtek  178484  1
snd_hda_intel          22196  0
snd_hda_codec          63596  3 snd_hda_codec_nvhdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              6120  1 snd_hda_codec
snd_pcm_oss            32240  0
snd_mixer_oss          12372  1 snd_pcm_oss
snd_pcm                62424  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_midi            5688  0
snd_rawmidi            18596  1 snd_seq_midi
snd_seq_midi_event      6212  1 snd_seq_midi
snd_seq                42308  5 snd_seq_dummy,snd_seq_midi,snd_seq_midi_event
snd_timer              17440  2 snd_pcm,snd_seq
snd_seq_device          6136  4 snd_seq_dummy,snd_seq_midi,snd_rawmidi,snd_seq
snd                    49044  12 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              6184  1 snd
snd_page_alloc          8120  2 snd_hda_intel,snd_pcm

Code:

debian:/home/marco# cat /dev/sndstat
Sound Driver:3.8.1a-980706 (ALSA v1.0.20 emulation code)
Kernel: Linux debian 2.6.30-bpo.1-686 #1 SMP Mon Aug 17 14:57:26 UTC 2009 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
HDA Intel at 0xf9ff8000 irq 22

Audio devices:
0: ALC663 Analog (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices: NOT ENABLED IN CONFIG

Timers:
7: system timer

Mixers:
0: Nvidia MCP78 HDMI

Code:

debian:/home/marco# aplaymidi -l
 Port    Client name                      Port name
 14:0    Midi Through                    Midi Through Port-0

why it says not enabled?


All times are GMT -5. The time now is 11:18 PM.