LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Microphone will not work with Skype! (http://www.linuxquestions.org/questions/linux-software-2/microphone-will-not-work-with-skype-888933/)

darkscot 06-29-2011 05:17 AM

Microphone will not work with Skype!
 
Since 'upgrading'(?) from Fedora 14 to Fedora 15 I cannot get my microphone (Logitech USB headset) to work with Skype. It works OK in other applications, such as Audacity.

The headphones work OK but not the mic. When I got to Settings > System Settings Multimedia > Phonon I get set the audio capture to appropriate option (Logitech USB Headset, USB Audio (IEC958 (S/PDIF) Digital Audio Output) but the setting does not stay. If I go out of settings and back in again it has reverted to 'Internal Audio Analog Stereo'.

I have searched high and low for a solution but nothing i have tried has worked. This is a major issue as I work from home and use Skype a lot.

By the way, yes I AM using Pulse audio. I did consider uninstalling it but it wanted to uninstall virtually every other application as well.

{BBI}Nexus{BBI} 06-30-2011 04:34 AM

Try looking in the Pulse Audio Volume Control (pavucontrol).

darkscot 07-01-2011 06:02 AM

Quote:

Originally Posted by {BBI}Nexus{BBI} (Post 4400030)
Try looking in the Pulse Audio Volume Control (pavucontrol).

Thank you for that suggestion. pavucontrol was not actually installed so I installed it and to begin with it did not make any difference. However, after a LOT (and I mean a LOT!) of tinkering I eventually got it working. To cut a VERY long story short here is what I did:
  1. Open Pulse Audio volume control.
  2. Go to the 'Recording' tab. (This will be empty apart from the message "no application is currently recording audio").
  3. Open Skype and make a test call.
  4. Skype will appear on the Recording tab of the volume control.
  5. Click on the current "Input from..." option and select the one you want from the list.
  6. Job done!

Easy when you know how! :banghead:

paparts 07-01-2011 07:40 AM

Thanks for the info...

tomsfeenie 06-22-2012 09:11 PM

Thank you for the info, 'tis easy, once you know how!


All times are GMT -5. The time now is 06:41 PM.