LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 03-23-2004, 01:49 PM   #1
csvke
Member
 
Registered: Oct 2003
Location: Hong Kong
Distribution: Slackware
Posts: 96

Rep: Reputation: 15
menuconfig fails to function properly in kernel 2.6.4


it hangs up when you get into some options (ok, back and exit are not shown at the bottom)
anyone has a similar experience?
it was fine in my previous kernel 2.4.20-28.9
cheers
F
 
Old 03-23-2004, 02:47 PM   #2
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
try getting 2.6.3.
I have upgraded to this kernel and noticed nothing strange about menuconfig.

I will get 2.6.4 and compile it right now and get back with you, as it may be a typo for extra options somewhere that make isnt handling or ignoring.

This can probably easily be fixed.


EDIT: no error or anything huh? do you have the newest automake utilitys and is your version of make up to date?

you have to upgrade make and the other gcc utilitys before compiling even the 2.6.3.
If you are using make that came with the 2.4 kernel this is why.

Last edited by AutOPSY; 03-23-2004 at 02:50 PM.
 
Old 03-23-2004, 04:25 PM   #3
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
your system is either screwed up or you need to upgrade make and itts utilitys.

I get no such activity like you describe.
 
Old 03-23-2004, 05:03 PM   #4
csvke
Member
 
Registered: Oct 2003
Location: Hong Kong
Distribution: Slackware
Posts: 96

Original Poster
Rep: Reputation: 15
got stuck in installing the rpm for automake
will get back to u soon... cheers.
 
Old 03-23-2004, 05:08 PM   #5
csvke
Member
 
Registered: Oct 2003
Location: Hong Kong
Distribution: Slackware
Posts: 96

Original Poster
Rep: Reputation: 15
sorry i dunno what itts is.

I think my rpmutils doesnt support kernel 2.6.x so i got back to 2.4.x and installed the latest version of rpmutil which is rpm-4.2-0.69.
now i got automake installed as well, popping back to 2.6.x n let's see if i m lucky enough...

by the way, what else do i need to upgrade for functioning in 2.6.x? (stuff like utils)
 
Old 03-23-2004, 05:27 PM   #6
csvke
Member
 
Registered: Oct 2003
Location: Hong Kong
Distribution: Slackware
Posts: 96

Original Poster
Rep: Reputation: 15
got no luck at all...
something's gone wrong with my kernel compilation perhaps...

with regard to the rpmutils problem, i've upgraded into version 4.2, but error still occurs
for instance, i ran this
Code:
rpm -ivh automake-1.6.3-5.noarch.rpm
and got this,
Code:
rpmdb: unable to join the environment
error: db4 error(11) from dbenv->open: Resource temporarily unavailable
error: cannot open Packages index using db3 - Resource temporarily unavailable (11)
error: cannot open Packages database in /var/lib/rpm
warning: automake-1.6.3-5.noarch.rpm: V3 DSA signature: NOKEY, key ID db42a60e
rpmdb: unable to join the environment
error: db4 error(11) from dbenv->open: Resource temporarily unavailable
error: cannot open Packages database in /var/lib/rpm
Is there any default .config file that makes kernel compilation easier? coz it seems that i need to re-compile the kernel once again.
 
Old 03-23-2004, 07:41 PM   #7
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
that could be caused by not being root, regardless of what people say to compile a kernel as a normal user thats a lie.

go to http://dictatornet.cjb.net/~AutOPSY

at the bottom left are links,
the first one is a download of 2.6.3
the second is a download of gcc-3.3.3 and other utilities regarding compilers.
the third is module-init-tools.

my version of make used to compile 2.6.3 was:
make -vv
GNU make version 3.79.1

if your version is the same or better, reget the kernel source as it was probably a corrupt download.

Last edited by AutOPSY; 03-23-2004 at 07:47 PM.
 
Old 03-23-2004, 08:20 PM   #8
csvke
Member
 
Registered: Oct 2003
Location: Hong Kong
Distribution: Slackware
Posts: 96

Original Poster
Rep: Reputation: 15
basically i have done everything as root, including compiling the kernel.
i got the same version of make.... but the same problem still occurs...
i need to compile kernel 2.6.4 under 2.4.20-28.9

Last edited by csvke; 03-23-2004 at 08:26 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with make menuconfig for my kernel. Royle Debian 7 01-21-2007 11:05 PM
Solution: ip-up fails to restart SuSEfirewall2 properly during PPTPD initialization Marc Linux - Networking 0 10-22-2005 01:00 PM
menuconfig during kernel upgrade Vindane Slackware 2 06-10-2004 01:27 PM
no make menuconfig in kernel-2.6.6??? kaise_sose Linux - Newbie 4 06-01-2004 11:45 PM
CD-RW drive fails to mount in Gentoo properly. AlwaysConfused Linux - Hardware 1 12-30-2003 06:40 PM


All times are GMT -5. The time now is 08:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration