LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-14-2004, 02:19 PM   #1
bignester
LQ Newbie
 
Registered: Jun 2003
Location: Texas
Distribution: Slackware
Posts: 26

Rep: Reputation: 15
mencoder wont encode the sound


Here is my setup

bttv card huappuage
Soundblaster 16 sound card
slackware 9.1 running alsa

I'm using freevo as the front end for watching tv.

here is the mencoder command that I am using

mencoder -tv on:driver=v4l:input=0:norm=ntsc:channel=7:\
chanlist=us-cable:width=320:height=240utfmt=yuy2:\
device=/dev/video0:alsa:adevice=hw.1,0:amode=2:\
forceaudio:forcechan=2:buffersize=64 -ovc lavc \
-lavcopts vcodec=mpeg4:vbitrate=1200:keyint=30 \
-oac mp3lame -lameopts br=128:cbr:mode=1 -ffourcc \
divx -endpos 3289 -o /home/adam/shows//helpme.avi

I seems to do fine but in the end I get video but no audio at all.

hw:1,0 is my sound card line-in.

thanx for help in advance
 
Old 01-14-2004, 04:41 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,384

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
please provide to real mencoder output, it's there for a reason....

if you can't get alsa going right, you can use oss emulation modules to create the slightly more accessible /dev/dsp entries.
 
Old 01-14-2004, 10:58 PM   #3
bignester
LQ Newbie
 
Registered: Jun 2003
Location: Texas
Distribution: Slackware
Posts: 26

Original Poster
Rep: Reputation: 15
Code:
MEncoder 0.92-3.2.3  (C) 2000-2003 MPlayer Team

CPU: Advanced Micro Devices  (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Reading /home/adam/.mplayer/codecs.conf: Reading /usr/local/etc/mplayer/codecs.conf: Using built-in default codecs.conf
Reading config file /home/adam/.mplayer/mencodersuccess: format: 0  data: 0x0 - 0x0
TV detected! ;-)
Selected driver: v4l
 name: Video 4 Linux input
 author: Alex Beregszaszi <alex@fsn.hu>
 comment: under development
Selected device: BT878(Hauppauge (bt878))
 Capabilites: capture tuner overlay clipping frameram scales 
 Device type: 235
 Supported sizes: 48x32 => 768x480
 Inputs: 4
  0: Television: tuner audio tv camera  (tuner:1, norm:ntsc)
  1: Composite1: audio camera  (tuner:0, norm:ntsc)
  2: S-Video: audio camera  (tuner:0, norm:ntsc)
  3: Composite3: audio camera  (tuner:0, norm:ntsc)
Using input 'Television'
Selected channel: 6 (freq: 83.250)
[V] filefmt:9  fourcc:0x32595559  size:320x240  fps:29.97  ftime:=0.0334
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 44100 Hz, 1 ch, 16 bit (0x10), ratio: 88200->88200 (705.6 kbit)
Selected audio codec: [pcm] afm:pcm (Uncompressed PCM)
==========================================================================
Opening video filter: [expand=-1:-1:-1:-1:1]
Expand: -1 x -1, -1 ; -1  (-1=autodetect) osd: 1
==========================================================================
Opening video decoder: [raw] RAW Uncompressed Video
VDec: vo config request - 320 x 240 (preferred csp: Packed YUY2)
Could not find matching colorspace - retrying with -vop scale...
Opening video filter: [scale]
VDec: using Packed YUY2 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
SwScaler: reducing / aligning filtersize 1 -> 4
SwScaler: reducing / aligning filtersize 1 -> 4
SwScaler: reducing / aligning filtersize 1 -> 1
SwScaler: reducing / aligning filtersize 9 -> 8

SwScaler: BICUBIC scaler, from Packed YUY2 to Planar YV12 using MMX2
videocodec: libavcodec (320x240 fourcc=58564944 [DIVX])
Selected video codec: [rawyuy2] vfm:raw (RAW YUY2)
==========================================================================
Forcing output fourcc to 78766964 [divx]
MP3 audio selected
Building audio filter chain for 44100Hz/1ch/16bit -> 44100Hz/1ch/16bit...
Writing AVI header...

CBR audio: 16000 bytes/sec, 418 bytes/block

Writing AVI index...
Fixing AVI header...

Video stream: 1500.863 kbit/s  (187607 bps)  size: 863863 bytes  4.605 secs  138 frames

Audio stream:  127.998 kbit/s  (15999 bps)  size: 73142 bytes  4.571 secs
I was using the oss emulation and I still had problems with it. The video records great I just don't get any audio. When I start recording I can here the audio through the speakers so I know the audio is working. thanx for the help.
 
Old 01-15-2004, 02:49 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,384

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
well the input is correct there and it has found some audio of sorts to encode. i'd go for mixer and gain volumes personally....
 
Old 01-15-2004, 09:22 PM   #5
bignester
LQ Newbie
 
Registered: Jun 2003
Location: Texas
Distribution: Slackware
Posts: 26

Original Poster
Rep: Reputation: 15
I've tried messing with the mixer settings through gnome-mixer but i still get nothing.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get sound juicer to encode mp3 files sirius57 Linux - Software 3 05-11-2005 01:48 AM
Rip and encode cd Linuxkundi Mandriva 3 05-10-2005 06:49 AM
encode XVID with 23.* or 29.* shanenin Linux - Software 0 05-29-2004 12:41 AM
mencoder: dvd rip to avi, no sound J_Szucs Linux - Software 0 04-08-2004 08:21 AM
Mencoder: encode so that the result will just fit on a CD? J_Szucs Linux - Software 2 03-09-2004 12:45 PM


All times are GMT -5. The time now is 05:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration