LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Mencoder options for encoding to recent DivX compliant LG DVD players? (http://www.linuxquestions.org/questions/linux-software-2/mencoder-options-for-encoding-to-recent-divx-compliant-lg-dvd-players-717931/)

rylan76 04-09-2009 08:51 AM

Mencoder options for encoding to recent DivX compliant LG DVD players?
 
Hi guys

I use the following mencoder commandline to encode to a satisfactory .avi. It plays well in MPlayer itself and in Windows Media Player:

Code:

mencoder dvd://1 -alang en -o dvdrip.avi -oac mp3lame -lameopts vol=8 -ovc lavc -ffourcc DX50 -lavcopts vcodec=mpeg4:aspect=1.78/1:vbitrate=1800:vrc_eq=tex:naq:ilme:trell:cbp:preme=2:subq=8:keyint=132:mbd=1:qns=3:vme=4:dia=3 -noskip
However, on LG DVD players made in the '07 / '08 model year, that have a "DivX" compatible logo on the case, the resulting clip does play, but is heavily artifacted. Audio is 100%, but video is very badly munged up.

I've tried different bit-rates and keyints, but nothing seems to be able to reduce the level of artifacts viewing the clip produces.

Anybody got a commandline for mencoder / codec suggestions that produces a container format that DOES play with little / no artifacts on recent DivX compatible LG DVD players?

Thanks!

pg99 04-09-2009 09:25 AM

maybe a stupid question, but you say you have the DVD and you want to encode it to an avi format that will play on your dvd player.. why not just play the DVD?

Anyway, DivX players usually comply to a certain defined profile (ASP level 5 is popular), so look into the xvidencopts profile=asp5 option of mencoder and see if that works for you. Generally, limiting the max bitrate and not using things like qpel and gmc may work but it very much depends on the player because they use hardware chips for the decoding.

Find out what chip the player uses and search based on that rather than the DVD player model.

I have a cheap DivX-playing DVD player but after much gnashing of teeth I never found a reliable way to encode avis so that they would always play -it was always hit-amd-miss.

Good luck.

H_TeXMeX_H 04-09-2009 11:43 AM

Well, I've found these options for ffmpeg that always work on my LG player, they don't always work well tho, there may be some stuttering, you may need to use 2 pass encoding or maybe quantizer based rather than bitrate based.

Code:

ffmpeg -i TWILIGHT_ZONE_VOL265-1.vob -b 900k -vcodec libxvid -s 640x480 -r 23.976 -aspect 4:3 -ab 128k -ar 44100 -async 44100 -ac 2 -acodec libmp3lame -threads 3 -f avi -g 300 -bf 2 PIANO.avi


All times are GMT -5. The time now is 04:43 PM.