LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-01-2006, 12:00 PM   #1
Skip-DMP
Member
 
Registered: Jan 2006
Distribution: RHEL3
Posts: 97

Rep: Reputation: 15
Mediawiki issue with php and mysql


RHEL3 with MySQL 4.1.20 and have tried php 5.1.4 and 4.4.2 with same problem:

Quote:
Warning: dl(): Unable to load dynamic library '/usr/lib/php4/mysql.so' - /usr/lib/php4/mysql.so: cannot open shared object file: No such file or directory in /var/www/html/wiki/install-utils.inc on line 19
Could not load MySQL driver! Please compile php --with-mysql or install the mysql.so module.
A locate only find one mysql.so file on the box at

/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/auto/DBD/mysql/mysql.so

If I manually copy the file in, it reports errors, so I am certain it isn't the correct file.

I have installed over and over and over again. Tried MySQL 4.1.19 first then went to 4.1.20. Have compiled and installed php as directed. Just running around in circles here and need some help.

Thanks.
 
Old 08-01-2006, 12:06 PM   #2
Skip-DMP
Member
 
Registered: Jan 2006
Distribution: RHEL3
Posts: 97

Original Poster
Rep: Reputation: 15
Been working on this for a couple months and found a note on another site and it "appears" I am past where I need to be... Crossing my fingers from here...
 
Old 08-01-2006, 04:58 PM   #3
Skip-DMP
Member
 
Registered: Jan 2006
Distribution: RHEL3
Posts: 97

Original Poster
Rep: Reputation: 15
Ok, what I have been able to determine is that I have php 4.4.2 and 5.1.4 both on my system. The php-mysql downloaded from redhat is 4.3.2 and Mediawiki wants to use php 5.0.0 or better. I can't seem to find the php-mysql file anywhere for version 5+ of php or documentation to fix it. Any idea?
 
Old 08-03-2006, 02:33 PM   #4
Skip-DMP
Member
 
Registered: Jan 2006
Distribution: RHEL3
Posts: 97

Original Poster
Rep: Reputation: 15
Got it working.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 4 Issue with PHP not recognizing Upgrade to MYSQL DoubleAce3 Linux - General 0 02-17-2006 04:31 PM
Php mysql issue petenyce Linux - Software 4 09-23-2005 02:39 AM
mysql and php issue czarherr Programming 4 04-07-2005 05:36 PM
PHP + MySQL Integration issue digitalgravy Linux - Software 1 01-15-2004 10:07 AM
Apache Mysql Php: mysql with php doesn't work breakerfall Linux - Networking 6 12-27-2003 08:59 PM


All times are GMT -5. The time now is 02:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration