LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-09-2003, 11:37 PM   #1
Grayhane
LQ Newbie
 
Registered: Mar 2003
Posts: 16

Rep: Reputation: 0
Mandrake 91 Graphical login


Mandrake 91 in the graphical mode I cannot get the system to boot up with the standard gdm login . If I startt at init 3 and then type gdm the login screen I want to use is shown rather than the lame Mandrake face thing. Any ideas as to How I chang that for good ?
Have tried GDM configurator but seems to not stick.
Thanks
 
Old 04-10-2003, 12:07 AM   #2
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,200

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
i think one way would be to edit the line in the /etc/inittab file
it should look something like:
x:5:respawn:/etc/X11/gdm -nodaemon
hope this helps, cheers
 
Old 04-10-2003, 01:07 AM   #3
Grayhane
LQ Newbie
 
Registered: Mar 2003
Posts: 16

Original Poster
Rep: Reputation: 0
I dont seem to have any lines in the file close to the one you listed,
 
Old 04-10-2003, 01:49 AM   #4
grub
Member
 
Registered: Mar 2003
Location: Kurnool, India.
Distribution: Redhat 9
Posts: 67

Rep: Reputation: 15
Grayhane you can try this
If you use startx you can enter X windows directly with the present login.
OR use 'init 5' this takes you to a login screen in X.
Hope this helps you
 
Old 04-10-2003, 03:51 AM   #5
Grayhane
LQ Newbie
 
Registered: Mar 2003
Posts: 16

Original Poster
Rep: Reputation: 0
Let me restate whats what, starting from init level 3 ( text mode ) I can type gdm and get one interface for login (gnome ) or using startx get the lame one with the faces on it,

What I want to do is change settings so gdm is the default and the login screen is the one with gnome on it and not the graphic faces

thanks
 
Old 04-10-2003, 04:29 AM   #6
grub
Member
 
Registered: Mar 2003
Location: Kurnool, India.
Distribution: Redhat 9
Posts: 67

Rep: Reputation: 15
Edit the inittab as suggested by frieza.
At one place in the inittab, you will see all the init levels from 0 to 6.
change the level 5, as per the suggestion and set the default init level to 5.
 
Old 04-10-2003, 10:31 AM   #7
neenee
Member
 
Registered: Feb 2003
Location: Netherlands
Distribution: debian (sid)
Posts: 693

Rep: Reputation: 30
but if you're on slackware, set it to 4.
 
Old 04-10-2003, 11:07 AM   #8
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,200

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Quote:
Originally posted by Grayhane
I dont seem to have any lines in the file close to the one you listed,
hmm, it should be at the bottom of the inittab file, but then again my distributions are redhat based, so perhaps the inittab file structure are different
 
Old 04-10-2003, 11:09 AM   #9
tcaptain
LQ Addict
 
Registered: Jul 2002
Location: Montreal
Distribution: Gentoo 2004 from stage 1 baby!
Posts: 1,403

Rep: Reputation: 45
In mandrake 9.1 you go to the Mandrake Control Center... click hardware and click on the display manager chooser (Looks like traffic lights) it will let you choose your DM (just click GDM and when you reboot, that's the one that will pop up)
 
Old 04-10-2003, 03:49 PM   #10
Grayhane
LQ Newbie
 
Registered: Mar 2003
Posts: 16

Original Poster
Rep: Reputation: 0
Thank you all !!!!!!!
I now know how to do it both in the GUI and via the file.

And to tcaptain, thanks for showing me how lame I can be at times, I must have looked at that stop lite a dozen times along the way.
 
Old 04-10-2003, 03:53 PM   #11
tcaptain
LQ Addict
 
Registered: Jul 2002
Location: Montreal
Distribution: Gentoo 2004 from stage 1 baby!
Posts: 1,403

Rep: Reputation: 45
Quote:
Originally posted by Grayhane
Thank you all !!!!!!!
I now know how to do it both in the GUI and via the file.

And to tcaptain, thanks for showing me how lame I can be at times, I must have looked at that stop lite a dozen times along the way.
My intention was not to show you that you are lame You aren't lame, you just missed an option...trust me, I didn't know either until I read a post about switching dm in Mandrake.

And since I've been having problems with KDM, that knowledge came in handy
 
Old 04-10-2003, 11:50 PM   #12
10Forge
LQ Newbie
 
Registered: Apr 2003
Posts: 1

Rep: Reputation: 0
I have the same annoying problem using Redhat 9.
/etc/inittab
x:5:respawn:/etc/X11/prefdm -nodaemon

this line led me to the /etc/X11/prefdm

/etc/X11/prefdm
preferred=
if [ -f /etc/sysconfig/desktop ]; then
. /etc/sysconfig/desktop
if [ "$DISPLAYMANAGER" = GNOME ]; then
preferred=gdm
elif [ "$DISPLAYMANAGER" = KDE ]; then
preferred=kdm
elif [ "$DISPLAYMANAGER" = XDM ]; then
preferred=xdm

so now i'm looking at /etc/sysconfig/desktop

/etc/sysconfig/desktop
DESKTOP="KDE"

finally...i like linux, but there has to be an easier way (maybe that's the newbie talking)
 
Old 04-12-2003, 12:23 AM   #13
slickrcbd
Member
 
Registered: Jan 2003
Posts: 45

Rep: Reputation: 1
probably the newbie talking, but hey, it's just like learning anything. it's hard at first, but 'easy' is relitive, once you become good at linux it will seem easy, and you'll be wondering how you got tripped up on this little snag in the first place, and looking at thins you call a 'little snag' that would have seemed like a brick wall now besides, you don't have to do it entirely alone, there's always this bullitan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Graphical login fail, text login works livewire98801 Linux - General 2 10-11-2004 07:09 PM
Graphical Login trouble (Mandrake 9.2) runeron Linux - General 2 11-17-2003 12:54 AM
Mandrake 9 Graphical Login byersjlpa Linux - Distributions 1 03-24-2003 03:00 PM
Mandrake 9 Graphical Login byersjlpa Linux - General 0 03-20-2003 03:26 PM
Mandrake 8 and graphical login jesusfreak239 Linux - Newbie 11 06-18-2001 12:18 AM


All times are GMT -5. The time now is 06:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration