LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-27-2004, 02:12 AM   #1
tk7967
LQ Newbie
 
Registered: Jan 2004
Location: Atlanta, GA
Distribution: Mandrake 9.2
Posts: 16

Rep: Reputation: 0
Mandrake 9.2/Nvidia problems


I've searched, and read through about every post here to try to fix this and nothing has worked.

Ok downloaded the drivers, 5328 I believe, and edited my xf86config to read "nvidia" and load "glx". When I boot up to level 3 and hit startx it just hangs on a black screen. If I let it sit for 10+ minutes it will flash the nvidia screen but then just go black again. So I have to go back and edit it back to "nv" just to get x.

Ok now when I try to load glx gears I get:

Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual

When I try to load Enemy Territory it goes to a black screen with a blue text box that says something like "proper connection" when I hit enter it turns off the computer.

And here is the other important stuff. Keep in mind I have edited to read "nvidia" with no luck:

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
#DontZap # disable <Crtl><Alt><BS> (server abort)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "en_US"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Hewlett-Packard"
ModelName "HP M700 17-inch Display"
HorizSync 30-86
VertRefresh 50-160

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce3 (generic)"
Driver "nv"
Option "DPMS"
Option "IgnoreDisplayDevices" "DFP,TV"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
Screen "screen1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
EndSection


Any clues?
 
Old 01-27-2004, 10:39 AM   #2
tk7967
LQ Newbie
 
Registered: Jan 2004
Location: Atlanta, GA
Distribution: Mandrake 9.2
Posts: 16

Original Poster
Rep: Reputation: 0
Nevermind I got it. There is a new driver that just came out today and it is working just fine now.

Last edited by tk7967; 01-27-2004 at 10:47 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake 10 nvidia tv out problems nomowinblowz Linux - Newbie 1 01-12-2005 10:41 PM
Mandrake 10.1 and Nvidia problems ifurita Mandriva 10 01-08-2005 12:09 PM
Nvidia problems on Mandrake 9.2 neroagent Mandriva 0 03-27-2004 02:41 PM
NVIDIA and Mandrake problems Veteq Linux - Newbie 5 03-18-2004 11:32 PM
Mandrake 9.2 NVIDIA Problems pieniaszek Linux - Software 5 12-30-2003 04:35 PM


All times are GMT -5. The time now is 04:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration