LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-16-2003, 12:39 PM   #1
mtb
Member
 
Registered: Nov 2002
Location: Italy
Distribution: Linux Mint 17 Xfce
Posts: 284

Rep: Reputation: 30
mandrake 9.1 & cd burning


Hello,

i have recently instaled mandrake 9.1 on a compaq presario with a dvd rom drive ( hdc ) and a cdrw on hdd.

In fact, i have found mandrake has configured the burner with the right line in /etc/lilo.conf ( append hdd=ide-scsi ) and so the cd burner works fine.

But i would like also to use cdrdao to copy from the dvd to the cdrw drive ( even without the on-the-fly option ).

@ home, i use debian 3.0 and i have the following output from cdrecord -scanbus:

Cdrecord 1.10 (i686-pc-linux-gnu) Copyright (C) 1995-2001 Jörg Schilling
Linux sg driver version: 3.1.22
Using libscg version 'schily-0.5'
scsibus0:
0,0,0 0) 'LG ' 'DVD-ROM DRD8160B' '1.01' Removable CD-ROM
0,1,0 1) 'ASUS ' 'CRW-1610A ' '1.20' Removable CD-ROM
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *

Whilst on the compaq, with mandrake, i have only the cdrw.

@ home, to have such a configuration, i linked scd0 to hdc, and scd1 to /dev/cdwriter, and everything works fine.

But with mandrake i am unable to obtain a similar situation.

Does someone can help me?
 
Old 11-16-2003, 02:33 PM   #2
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
Have you tried using K3b? It's on the Mandrake 9.1 CD's. It does all the brainwork for me. You have to run K3b setup as root.
 
Old 11-16-2003, 03:22 PM   #3
carlywarly
Member
 
Registered: Feb 2003
Location: Sunny Southport, again.
Distribution: PCLinuxOS 0.93 and 0.92, Vector sometimes
Posts: 825

Rep: Reputation: 30
Edit your /etc/lilo.conf file and add a second part for your dvd - like this -
append="quiet noapic devfs=mount hdd=ide-scsi hdc=ide-scsi"

Once you do that, run the command lilo as root. Then reboot. That should do it, check with cdrecord -scanbus again, just to make sure.

Andrew - you're just over the water from me. Good to see Linux users in the North West.
 
Old 11-17-2003, 03:09 AM   #4
mtb
Member
 
Registered: Nov 2002
Location: Italy
Distribution: Linux Mint 17 Xfce
Posts: 284

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by carlywarly
Edit your /etc/lilo.conf file and add a second part for your dvd - like this -
append="quiet noapic devfs=mount hdd=ide-scsi hdc=ide-scsi"

Once you do that, run the command lilo as root. Then reboot. That should do it, check with cdrecord -scanbus again, just to make sure.

Andrew - you're just over the water from me. Good to see Linux users in the North West.
Thank you, but i have already tried .

This way i can't access both the cdrom & the cdwriter ( i receive an input / output error ). I can only from one to another, but i can't mount them... .
 
Old 11-22-2003, 08:36 AM   #5
mtb
Member
 
Registered: Nov 2002
Location: Italy
Distribution: Linux Mint 17 Xfce
Posts: 284

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by carlywarly
Edit your /etc/lilo.conf file and add a second part for your dvd - like this -
append="quiet noapic devfs=mount hdd=ide-scsi hdc=ide-scsi"

Once you do that, run the command lilo as root. Then reboot. That should do it, check with cdrecord -scanbus again, just to make sure.

Andrew - you're just over the water from me. Good to see Linux users in the North West.
I have now found a way to add the line and still having both the cdrom and the cdrecord working ( i can read the contents of a cd, cool! ). But the results of cdrecord -scanbus are still the same, i see only the cdrw on 0,0,0. Could you please tell me what's the next step? ( seems that ln -s /dev/hdc /dev/scd1 isn't enought )

Thx in adv.
 
Old 11-22-2003, 03:14 PM   #6
carlywarly
Member
 
Registered: Feb 2003
Location: Sunny Southport, again.
Distribution: PCLinuxOS 0.93 and 0.92, Vector sometimes
Posts: 825

Rep: Reputation: 30
Have you run the command lilo as root in a console? If so, post the results of cdrecord - scanbus, and your /etc/fstab please.
 
Old 11-24-2003, 12:50 PM   #7
mtb
Member
 
Registered: Nov 2002
Location: Italy
Distribution: Linux Mint 17 Xfce
Posts: 284

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by carlywarly
Have you run the command lilo as root in a console? If so, post the results of cdrecord - scanbus, and your /etc/fstab please.
Aargh i forgot ( after loads of reboots doing the right thing ). I'll retry as soon as i can, trying to get both the cdrom and cdrecorder working. Excuse me for my mistake.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Burning CDs w/SuSE & IDE CDRW tmeehan SUSE / openSUSE 7 09-03-2005 08:17 AM
Fedore3 CD burning failure (gnome&kde) padeco Linux - Hardware 1 03-05-2005 10:39 PM
SUSE .iso burning & booting Sober Guy Linux - Newbie 6 02-24-2005 04:41 AM
dvd burning & mkisofs -quite switch broke? pete_g Linux - Software 3 04-30-2004 10:59 AM
burning & installing iso's snafu Linux - Newbie 4 11-23-2002 07:33 PM


All times are GMT -5. The time now is 07:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration