LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-22-2001, 04:36 PM   #1
EyeGuy
LQ Newbie
 
Registered: Nov 2001
Distribution: mandrake 8.1
Posts: 29

Rep: Reputation: 15
Mandrake 8.1 install problem


I start the install and it halts with:

Partition check:
had:hda: timeout waiting for DMA
ide_dma proc: chipset supported ide_dma_timeout func only: 14
hda: status error: status=0x58 {DriveReady SeekComplete DataRequest}
hda: drive not ready for command



The hd is Maxtor and is set to auto detect in the BIOS.
I used Partition Magic to format for Ext2.
Any ideas?
TIA
Curt
 
Old 11-22-2001, 06:55 PM   #2
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
When you get a prompt, try entering linux ide=nodma . This might take of the problem.
 
Old 11-22-2001, 07:56 PM   #3
EyeGuy
LQ Newbie
 
Registered: Nov 2001
Distribution: mandrake 8.1
Posts: 29

Original Poster
Rep: Reputation: 15
Thanks for the help,install went ok.....

....sort of. It's installed, but I get the same message again on first boot!?
I was expecting "Kernel panic: No init found" like last time.
I have the mkinitrd package and booted to the install disk (1st disk) per instructions at mandrakelinux.com - to update, but ....
Now what?

Last edited by EyeGuy; 11-22-2001 at 08:21 PM.
 
Old 11-22-2001, 11:11 PM   #4
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Bootup and at the prompt, enter linux ide=nodma . If that allows you to boot up, then reboot and enter linux hda=nodma . If that works, then hda is the one having the problem. The ide= turns off all the ides' dma.

To have this work at boot up without having to enter it every time, you'll have to put it into lilo.conf or menu.lst. If you're using lilo to boot, then either add an append line to the kernel stanza or add it to an existing one. Like this:

image=/boot/vmlinuz
label=linux
root=/dev/hda1
append="ide=nodma"
read-only

or add it to an existing append:

image=/boot/vmlinuz
label=linux
root=/dev/hda1
append="mem=128M ide=nodma"
read-only

If you're using grub, then add it to the kernel line like this:

kernel /boot/vmlinuz mem=128M vga=768 root=/dev/hda5 ide=nodma



Don't forget, if hda is causing the problem use hda=nodma.

Here's a page that you might find useful.
 
Old 11-22-2001, 11:16 PM   #5
EyeGuy
LQ Newbie
 
Registered: Nov 2001
Distribution: mandrake 8.1
Posts: 29

Original Poster
Rep: Reputation: 15
Thanks for th tip & page....

I'll check it out.

But I'm wondering why this is happening.
A year ago or so I'd installed md7.0 and ran it with no (well ok, minimal) problems - same kind of drive....and had 8.1 running after two weeks of experimenting but couldn't config the ethernet card so I thought I'd try the default kernel... Last week I used 2.2.19 and was able to boot to 2.2 and 2.2 nb (I think it was) but couldn't update the mkinit package.
I'm still missing something.
 
Old 11-22-2001, 11:51 PM   #6
EyeGuy
LQ Newbie
 
Registered: Nov 2001
Distribution: mandrake 8.1
Posts: 29

Original Poster
Rep: Reputation: 15
One problem

I have the GUI set to load at boot so I don't get a prompt.
Using the nodma line allowed me to install but until I can log in, I can't add an append....can I?
How do I get it to give me a prompt at bootup?
 
Old 11-22-2001, 11:55 PM   #7
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
This is from way out in left field, but I read about a similar probelm - it only applies with Utra/66 controllers. The original Ultra/66 standard stated that the jumpers on the drive should be configured as 'cable select'; the controller can pick whether a drive is master or slave by its position on the IDE chain. Some recent linux distros (RH7.2 included) probed the PCI bus and ignored what the BIOS reported from the startup. As a consequence they were not properly recognized and the DMA was disabled - causing problems for most intstallers. IIRC the last time I saw this was on theregister.co.uk in the past week or so. A proposed workaround is to set your jumpers according to the actual layout of your IDE system (master/slave)
 
Old 11-23-2001, 12:28 AM   #8
EyeGuy
LQ Newbie
 
Registered: Nov 2001
Distribution: mandrake 8.1
Posts: 29

Original Poster
Rep: Reputation: 15
I appreciate the input...

hda is the primary master.

I guess I'll go back and use the 2.2.19 kernel - at least that allows me to get in by booting to 2.2 or 2.2nonfb (can anyone explain to me what that is BTW?)
And maybe I should mention that I'm more than a little green when it comes to linux especially where the command line is concerned. So if you have any ideas, I won't be insulted if your reply is extremely simple/detailed.
Thanks to all
 
Old 11-23-2001, 12:34 PM   #9
webtoe
Member
 
Registered: Apr 2001
Location: Cambridge, England
Distribution: Slackware 10, Fedora Core 3, Mac OS X
Posts: 617

Rep: Reputation: 30
with the GUI start up thing you need to use an xterm (its a GUI application that shows you the command line). if you use kde then it should be on the bottom left of the screen. its called konsole in kde, if memory serves me correctly, not xterm.



that will give you a command prompt where you can type commands. type the following at the command prompt
(you will have to be root user to do the following. type
Code:
su
then enter the root password. you'll be root until you type
Code:
exit

Code:

cd /etc/

pico lilo.conf


this should move you into the /etc directory and start the pico text editor with lilo.conf loaded. then and the ammendments that have been suggested and save the file (hold down control and then o to do this. then control and x to exit).


then type this to write the edited file to the Boot Record (the bit that gets your system kicking).

Code:
lilo

if you use grub as the boot loader then you'll have to edit its file which is in /boot somewhere (but im not sure. i don't have grub).



HTH



Alex

Last edited by webtoe; 11-23-2001 at 12:38 PM.
 
Old 11-23-2001, 01:54 PM   #10
EyeGuy
LQ Newbie
 
Registered: Nov 2001
Distribution: mandrake 8.1
Posts: 29

Original Poster
Rep: Reputation: 15
ok, but.....

I can't access the command line with the Default installation kernel, since md won't load.... and with 2.2.19 it seems there's no need to disable DMA.


I've done the install again, using the 2.2.19 kernel and md runs and DMA doesn't seem to be a problem!?
and I am using Lilo.
Trying to config the linksys ethernet card ends with:

"insmod'ing module tulip failed at usr/lib/libDrakX/modules.pm line 532"

same results when I try to do it after install or during.

Installing with the default kernel, the card is recognized (The LAN connection is highlighted for config during install) but then there's the "drive not ready for command" error and I can't get in.

After installing (with 2.2.19) the SCSI cd r/rw works (or at least I think it does) unless I try an audio cd where a dialog box comes up that says something like " no audio cd or make sure you have privledges"
Shouldn't it give access to user by default? I shouldn't need to be root to play a cd - should I?

To complicate things further, the sound card also won't config (Soundblaster Live Value series) and the printer starts to print the test page but halts in the middle of the first line and only ejects the paper when I reboot (also after install)

So the final question is what's the best way to get everything configured - default kernel with some fix for DMA and mkinitrd (if you're not aware - this is a fix for a bug in 8.1, for the SCSI adapter), or maybe 2.2.14 (haven't tried that one) or use 2.2.19 and fix from there?....or maybe the newest kernel that's been released? (and how would I do that?)

Sorry if this is too many issues at once, I'm just not sure where to start.

I just read a tip from Linuxvoodoo.org that gave me an idea...maybe I should compile sound and SCSI card info into the kernel?? Whaddya' think?

Last edited by EyeGuy; 11-23-2001 at 03:01 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake install problem spuzmax Linux - Newbie 1 03-11-2005 10:48 PM
mandrake 10 install problem konan11 Mandriva 3 07-16-2004 07:17 PM
Mandrake install problem chrisellis Linux - Distributions 9 05-09-2004 10:39 PM
install problem mandrake 8.1 himeg01 Linux - Distributions 3 07-03-2002 02:45 PM
Mandrake 7.1 Install Problem happybunny Linux - Software 2 09-22-2001 06:12 PM


All times are GMT -5. The time now is 12:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration