LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-24-2004, 09:44 PM   #1
rekurzion
Newbie
 
Registered: Nov 2004
Distribution: Ubuntu 4.10 (2.6.8.1-3-386) and loving it.
Posts: 15

Rep: Reputation: 0
Aterm man page/utf8 display problem **SOLVED**


I have recently installed and love aterm, and have been spending some time configuring it to the liking . . . i'm almost there.

In aterm, my man pages are a little mangled . . .

SYNOPSIS
aterm [options] [‐e command [ args ]]

would appear with funny characters for the "-" in front of the e option to command

actually, now that i notice it. it's not displaying dashes correctly nor does it have the same color display as xterm.

I know there is some cofig file that will solve the problem. but i have looked through a list of configs and haven't found anything that would give me clue.

.Xdefaults
.Xresources
.viminfo (if maybe that man pages are displayed by using a text editor)
.bash_profile
.bashrc

all within user or root, but can't figure it out. Though I am assuming that the file I'm looking for would be a system wide file since I have no configuration set up for these features in my xterm

thanx in advance

Last edited by rekurzion; 12-02-2004 at 07:40 PM.
 
Old 11-25-2004, 01:21 AM   #2
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
maybe a problem with your environment settings: check your LANG, LANGUAGE, LC_ settings and that the right font format (isoxxxx-x,utf8) is in use. also be sure the selected font is able to print these caracters right.

sl mritch.
 
Old 12-02-2004, 12:45 AM   #3
rekurzion
Newbie
 
Registered: Nov 2004
Distribution: Ubuntu 4.10 (2.6.8.1-3-386) and loving it.
Posts: 15

Original Poster
Rep: Reputation: 0
my current LANG is set to en_US.UTF-8

xterm is working ok with this setting and uses "fixed" for its app font.

If aterm is still not displaying dashes ("-") correctly then are you saying the issue lies with the LANG setting or that I need to choose another font for the app. So far i have chosen several fonts from my "xlsfonts" listing and have been unsucessful (or should i just keep trying more fonts)

I have also tried changing LANG variable to different settings, breaking xterm. So i know that LANG is set correctly (I'm hoping).

Not critical, but annoying (also, aterm is not displaying colors while displaying man pages . . . why just man pages, does it have to do with settings for my pager???)

Anyway, thanks for the reply
 
Old 12-02-2004, 06:48 AM   #4
dustu76
Member
 
Registered: Sep 2004
Distribution: OpenSuSe
Posts: 153

Rep: Reputation: 30
Exactly same is my case (I already posted this in the forum about a month ago).

This happens not only with aterm but with rxvt, xvt etc. too. Only xterm is able to display it properly. I also noticed that wherever aterm was displaying strange chars, xterm was showing colored text. So could this be due to coloring? Is man page coloring something which only xterm is able to handle?

I tried other clients 'cause they are so much lightweight than xterm (heaviest of them all!). But it seems they are shedding some functionality as well with the size...

If you find a reason/solution, don't forget to post it...

HTH.
 
Old 12-02-2004, 07:27 AM   #5
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
im sure it's a font problem. had the same with the "+"-sign once and solved it by selecting another fnt that worked better with the LANG settings. seems to be kind of aterm specific.
have a look for xfontsel and try a few of them.
here's my aterm string..

aterm -fn -jmk-neep-medium-*-*-*-14-*-*-*-*-*-*-* -tr -tint violet -sh 60 -fg white -bg black +sb -sl 256 -vb

.. it depends on fonts that are installed on your system! my LANG isn't utf8 it's de_at@euro (aka iso8859-15 if i'm right).

sl mritch.
 
Old 12-02-2004, 07:39 PM   #6
rekurzion
Newbie
 
Registered: Nov 2004
Distribution: Ubuntu 4.10 (2.6.8.1-3-386) and loving it.
Posts: 15

Original Poster
Rep: Reputation: 0
Aterm utf8 display problem **SOLVED**

OK . . . I fixed the problem. And wouldn't you know, attribute another notch on the belt of RedHat issues. (dustu 76 i think is using Fedora Core)

It seems that Red Hat sets up the default locale settings to en_US.UTF-8

I tried different variations and was unsuccesful in clearing up my issue, either there would be no change in display, or I would break xterm display as well.

It seems the .UTF-8 part of the LANG/LC_ALL setting is not compatible with all apps. Delete this portion of the value and leave only the "en_US" part.

This solved my problem cleanly. I still have color issues, as aterm is not displaying colors in man pages, but I know how to fix that issue.

Also, I have read that aterm does not support utf8 settings, which would explain why there was an issue. If this is wrong please someone make comment.


Thank you again.
 
Old 12-02-2004, 10:03 PM   #7
dustu76
Member
 
Registered: Sep 2004
Distribution: OpenSuSe
Posts: 153

Rep: Reputation: 30
Gr8! I'll try the LANG settings tonight at home.

rekurzion, if you dont mind, could you tell me the solution for color issue? I also want to know how to fix that issue

If this works out, I'll happily switch to aterm/xvt... someone said, xvt is the lightest of them all...

Thanks to all for sharing.
 
Old 12-02-2004, 10:27 PM   #8
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
rxvt is even smaller, but no transparency ;)
had them on my old 32M-box.

sl mritch.
 
Old 12-02-2004, 11:18 PM   #9
dustu76
Member
 
Registered: Sep 2004
Distribution: OpenSuSe
Posts: 153

Rep: Reputation: 30
I use FVWM & love the flexibility of it... however I'm just an "rpm" user & to apply transparency, I have to apply some patch, rebuild from source etc.etc. which is way beyond my league... Plus my PIII PC with 256 MB has hardly any memory left even when running only FVWM (even after brutal removal of all unwanted services)

Transparency is just a dream for me
 
Old 12-03-2004, 01:42 AM   #10
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
are you sure? i don't think so.

if your piii is running that bad something other has to be wrong.

for example: i have an old p233mmx libretto with 64megs (harddrive dma also isn't supported) in use all the time. as desktop i use xfwm4 and the gnome panel. it's important to leave all that junk that comes with gnome (vfs,nautilus,sm-proxy,gconfd..) away. just the plain panel with a few addons (pager,..). everything important like abi-word, sylpheed(mail), aterm, epiphany (or firefox), xmms (better mp3blaster - but can't play streams) and also quite a lot unnecessary things are there. and 3/5 of 4Gig diskspace for oggs (it's also my ogg-player).

memory is different under linux. it is full all the time and that's ok. it get's used as disk- and app-buffer. however with 64M i'm in swap for sure.

to check your memory usage there's "$ free" for short. do a..

$ memstat

..to actually see where you're wasting memory. try to not run too much services you don't need at the moment. don't run more than 2 gettys (login inittab below). don't run a graphical login like gdm. and choose your applications with care: i had xfce before and spotted a memory-leak (it took all mem away by time) in the xfce-panel. so i installed the (larger) gnome-panel. xfce-panel should be solved with version 4.2 now.

this small computer is my favorite since years - and i *have* faster ones.
aterm runs with (pseudo)transparency on it -so i think it should sure be possible on yours.

here are a few speedups that come into my mind now:

hdparm -d1 /dev/hda
..sets dma mode for your first harddisk (hda & hdb on the first ide-controller, hdc & hdd on the second). they have to suppor it! see "$ man hdparm".

change some things in your inittab:
[...]
1:2345:respawn:/sbin/mingetty tty1
2:23:respawn:/sbin/mingetty tty2
#3:23:respawn:/sbin/mingetty tty3
#1:23:respawn:/sbin/mingetty tty4
#2:23:respawn:/sbin/mingetty tty5
#3:23:respawn:/sbin/mingetty tty6
[...] two is usually enough!

see the "$ ps aux" output and check if there are things running you don't need. *caution* here ;) things that you don't know what they do don't mean they are unnecessary :) if you spot something, search for documentation (man, /usr/share/doc/) to get it known better and eventually disable it (lot of them get started in /etc/rc* or come up with your xsession).

afaik there is a small-machine-howto somewhere on the net that may give you some ideas. google.

btw: building from source isn't that hard at all. linux is getting more and more userfriendly and so are the scripts that come with the source. often it's nothing more than a "./configure; ./make; ./make-install" you'll have to do. they even tell if there's something missing in your development environment. worth a try.

luck, mritch.

Last edited by mritch; 12-03-2004 at 01:44 AM.
 
Old 12-03-2004, 02:44 AM   #11
dustu76
Member
 
Registered: Sep 2004
Distribution: OpenSuSe
Posts: 153

Rep: Reputation: 30
Thanks a ton. Would check all those points.

Gr8 being in this forums & people like you keep it so useful...

Regards.
 
Old 12-03-2004, 05:01 AM   #12
rekurzion
Newbie
 
Registered: Nov 2004
Distribution: Ubuntu 4.10 (2.6.8.1-3-386) and loving it.
Posts: 15

Original Poster
Rep: Reputation: 0
Yeah, sounds like other issues are at work.

My laptop only has 256MB. Which is why I'm trying so hard to get aterm to the liking, because it takes up so little memory real estate, even with the transparency. But remember it's only psuedo trans, so you should have no problem.

aterm from source is not that bad at all. i don' t think there are any depends required. It would be a great small application to try installing from soure if you have never done it before.

Maybe try stripping down your desktop. I tried just running enlightenment with no Desktop and started missing icons. After trying epplets and not being satisfied (also running gnome-session with E as window manager) I am now running this command at startup

(in my .Xclients-default)
gnome-panel &
magicdev &
exec enlightenment

this gives me the small footprint of a full featured window manager without all of Gnome's heavy apps. Though I still have access to any program from Gnome if I need them. But don't run nautilus . . . its a lot more than meets than eye (is it a window manager??? why does it load backgrounds and icons when run. I though metacity was the wm for Gnome???)

Anyway, there are plenty of smaller apps available if you start missing your file manager. But I have been long used to doing things from the command line.

Anyway, when finals are over I will post those results for clearing up the color issue (2 weeks).

Unless mritch would like to beat me to it.

Good Luck
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
man page display problem staul Linux - Software 0 02-22-2005 02:01 AM
man alsamixer not showing the man page nosaku Slackware 1 12-20-2004 08:52 AM
Is there a man page on how to use man page? jdruin Linux - Software 2 10-30-2004 09:29 AM
getting out of a man page! naijaguy Linux - Newbie 2 08-13-2004 09:28 PM
man page often display: see also .....(X).. nutshell Linux - General 3 03-02-2002 05:43 AM


All times are GMT -5. The time now is 11:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration