LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-02-2003, 09:01 PM   #1
Pinkdog
LQ Newbie
 
Registered: Oct 2003
Posts: 25

Rep: Reputation: 15
"make" gives error in kismet


This is the error that i can after doing make, make dep works fine but i get the error doing "make". IM using slackware9
Anyone know how i can fix this problem?

g++ -Ilibpcap-0.7.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/src/ethereal-0.9.15/wiretap -I/usr/X11R6/include -I/usr/include/freetype2 -D_FILE_OFFSET_BITS=64 -D_REENTRANT -I/usr/X11R6/include -I/usr/include/libxml2 -O2 -Wall -DVERSION_MAJOR=3 -DVERSION_MINOR=0 -DVERSION_TINY=1 -DTIMESTAMP=\"`cat TIMESTAMP`\" -g -O2 -g -O2 -O2 -march=i386 -mcpu=i686 -Wall -c expat.cc -o expat.o
In file included from expat.cc:27:
/usr/include/expat.h:657: use of enum `XML_Status' without previous declaration
/usr/include/expat.h:735: multiple definition of `enum XML_Status'
/usr/include/expat.h:657: previous definition here
make: *** [expat.o] Error 1


thank you
Laura
 
Old 11-02-2003, 10:07 PM   #2
ToniT
Senior Member
 
Registered: Oct 2003
Location: Zurich, Switzerland
Distribution: Debian/unstable
Posts: 1,357

Rep: Reputation: 47
That is a bug in some versions of libexpat1-dev package. Upgrade your expat library to a version atleast 1.95.6-3.

If you are a debian user, pick one from the testing or unstable distribution (or use apt-get if you have configured your sources.list to contain testing/unstable).If not, you hopefully find your way to get newer version(or somebody else might help you).

In the other hand, if the upgrading of libraries doesn't seem cool, the bug is easy to fix by hand with help of the bug-report mentioned above

Last edited by ToniT; 11-02-2003 at 10:11 PM.
 
Old 11-03-2003, 04:00 PM   #3
Pinkdog
LQ Newbie
 
Registered: Oct 2003
Posts: 25

Original Poster
Rep: Reputation: 15
Thanks that helped. Got it installed, but configuring it, thats another problem =X

thanks
L
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"FATAL: Unknown capture source type" error from Kismet atlantanewbie Linux - Wireless Networking 2 04-03-2010 06:34 AM
General question while running make "make[2]: *** [main.o] Error 1" matazar42 Linux - Software 3 08-15-2005 01:39 PM
error running "make" and "arkollonrc"... Toro Linux - Software 1 04-19-2004 01:24 AM
help with "make" error "Missing seperator" hrishikesh Linux - Software 1 07-18-2003 02:40 AM
LFS 4.1: Stalled at Perl, "missing seperator" error from "make" SparceMatrix Linux From Scratch 1 06-07-2003 04:31 PM


All times are GMT -5. The time now is 03:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration