LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-23-2012, 07:47 AM   #1
fabe856
Member
 
Registered: Apr 2012
Posts: 99

Rep: Reputation: Disabled
make failed Error in GNuRadio installation on fedora 17


Hi,
I wanted to build GNURadio on fedora 17. I used build-gnuradio install script available on http://gnuradio.org. After following the instructions, at the end it shows following:
Starting function gnuradio_build at: Sun Dec 23 18:36:03 IST 2012
/usr/local/lib already in ld.so.conf.d
Doing ldconfig...
Building Gnu Radio...
...Doing cmake
...Cmaking
...Building
make failed
Exiting Gnu Radio build/install


Complete file containing terminal commands is attached for reference.
Please guide me what should I do now.

Regards
Fabe

Last edited by fabe856; 12-23-2012 at 07:48 AM.
 
Old 12-23-2012, 08:19 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,522

Rep: Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503
? How about using the default Fedora 17 package ?

# yum install gnuradio
Provides gnuradio-3.5.3.1-3.fc17.


'gnuradio-3.6.1' packages
http://www.silfreed.net/download/rep...ages/gnuradio/
32bits : gnuradio-3.6.1-1.fc17.i686.rpm
64bits : gnuradio-3.6.1-1.fc17.x86_64.rpm

.
 
Old 12-23-2012, 08:42 AM   #3
fabe856
Member
 
Registered: Apr 2012
Posts: 99

Original Poster
Rep: Reputation: Disabled
Thanks for quick response.
Quote:
Originally Posted by knudfl View Post
? How about using the default Fedora 17 package ?

# yum install gnuradio
Provides gnuradio-3.5.3.1-3.fc17.
.
My initial aim was to use the same. However the following statement from gnu.org prompted me to use the way I did it.
The build-gnuradio is an install script for recent Fedora and Ubuntu systems provided by Marcus Leech. For most users, this is the recommended way.

But if in your opinion this is going to solve my problem, I will prefer because you helped me in various installations on fedora.

Should I remove the previous files from the system or should I use a different folder for yum install.

Thanks once again for prompt response.
 
Old 12-23-2012, 08:59 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,522

Rep: Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503
Quote:
Should I remove the previous files from the system
or should I use a different folder for yum install.
If make failed : No files have been installed.
( A "build folder" can usually be removed.)

Yum or any other command will never install an rpm package to a folder.

The gnuradio-3.5.1 rpm installs to :
/etc/gnuradio/conf.d/***
/usr/bin/***
/usr/lib/libg*
usr/lib/python2.7/**
/usr/share/*
... totally more than 1000 files.

.
 
Old 12-23-2012, 09:15 AM   #5
fabe856
Member
 
Registered: Apr 2012
Posts: 99

Original Poster
Rep: Reputation: Disabled
Thanks:
I used yum install gnuradio.
It got installed with following:
Total download size: 3.8 M
Installed size: 27 M
Is this ok [y/N]: y
Downloading Packages:
gnuradio-3.5.3.1-3.fc17.i686.rpm | 3.8 MB 01:12
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : gnuradio-3.5.3.1-3.fc17.i686 1/1
Verifying : gnuradio-3.5.3.1-3.fc17.i686 1/1

Installed:
gnuradio.i686 0:3.5.3.1-3.fc17

Complete!


Is anything else needed.
Do you suggest any test/command for verification.

Regards
 
Old 03-28-2013, 06:58 AM   #6
maresca
LQ Newbie
 
Registered: Mar 2013
Posts: 1

Rep: Reputation: Disabled
If you also need UHD, you need to install it separately or it is included in gnuradio? Do you have any idea?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Failed on chapter 6.7.1. Installation of Linux API Headers, make headers_check sunmoon Linux From Scratch 11 02-16-2012 12:51 PM
problem regarding installation of RDS on gnuradio bghori Linux - Software 1 08-18-2011 06:55 PM
[SOLVED] gnuradio installation problem bghori Linux - Software 2 07-23-2011 02:01 PM
Error: Ns make failed! terbulance129 Linux - Newbie 8 06-11-2011 10:39 AM
installation of NS2 (otcl make failed) NabiVakili Linux - Newbie 4 04-11-2011 02:45 AM


All times are GMT -5. The time now is 09:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration