LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-21-2005, 12:43 PM   #1
ryedunn
Member
 
Registered: Jul 2003
Location: Chicago
Distribution: Fedora, ubuntu
Posts: 458

Rep: Reputation: 30
make error: /usr/bin/ld: cannot find -lXext


when attempting to run make I ran into the error:
Code:
/usr/bin/ld: cannot find -lXext
collect2: ld returned 1 exit status
hmm okay so I googled it and it looks like I dont have the static lib...but...
Code:
[root@me plugins]# ll /usr/X11R6/lib/*ext*
lrwxrwxrwx  1 root root    14 Sep 14 11:18 /usr/X11R6/lib/libXext.so -> libXext.so.6.4*
lrwxrwxrwx  1 root root    14 Sep  9 04:33 /usr/X11R6/lib/libXext.so.6 -> libXext.so.6.4*
-rwxr-xr-x  1 root root 55892 Sep  1 17:57 /usr/X11R6/lib/libXext.so.6.4*
am I missing libXext.a ???? do I need it? where can I get it?

Interesting so maybe Im missing something?.....
Code:
[root@me plugins]# urpmi kdelibs-devel
The package(s) are already installed
The following package names were assumed: libkdecore4-devel
At this time I have no idea where to go.. I would be grateful for any help you could provide.

Thank you,
TheGNUbie
 
Old 09-21-2005, 01:56 PM   #2
WuKitty
LQ Newbie
 
Registered: Sep 2005
Posts: 2

Rep: Reputation: 0
Hi,

first of all, the message "/usr/bin/ld: cannot find -lXext" seems curious...
Is the make command-line correct?
It might contain a double '-l' prefix (e.g. '-l-lXext').

If not, check your LD_LIBRARY_PATH variable includes the right paths (/usr/X11R6/lib).

If it is correct, then ... I cannot help you for the moment ! ;o(
But ... perhaps I will if you give me a more precise description of your problem (*), I'll try to find out the real reason of this error.

Good luck,
Hope it helps


(*) the details of the make command, your environment (dump of the 'env' command), ...
 
Old 09-21-2005, 03:17 PM   #3
ryedunn
Member
 
Registered: Jul 2003
Location: Chicago
Distribution: Fedora, ubuntu
Posts: 458

Original Poster
Rep: Reputation: 30
Thank you for your help.. lets see... first Im trying to install a plugin for kxdocker... nothing too difficult.

# ./configure
checking if src should be compiled... yes
configure: creating ./config.status
fast creating Makefile
fast creating src/Makefile
config.pl: fast created 2 file(s).
config.status: creating config.h
config.status: config.h is unchanged
config.status: executing depfiles commands

Good - your configure finished. Start make now

# make
I get a ton of warnings like this:
/usr/lib/qt3//include/private/qucomextra_p.h:87: warning: 'struct QUType_varptr' has virtual functions but non-virtual destructor
then....
/usr/bin/ld: cannot find -lXext
collect2: ld returned 1 exit status
make[2]: *** [GAClock.so] Error 1
make[2]: Leaving directory `/home/me/Download/kxdocker-gaclock-0.6/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/me/Download/kxdocker-gaclock-0.6'
make: *** [all] Error 2

[root@me gdate]# cat /etc/ld.so.conf
include ld.so.conf.d/*.conf
/usr/X11R6/lib
/usr/lib/qt3/lib

[root@me kxdocker-gaclock-0.6]# env
LESSKEY=/etc/.less
LC_PAPER=en_US
LC_ADDRESS=en_US
LC_MONETARY=en_US
HOSTNAME=me.hostname.com
SHELL=/bin/bash
TERM=xterm
LC_SOURCED=1
HISTSIZE=1000
TMPDIR=/root/tmp
LC_NUMERIC=en_US
QTDIR=/usr/lib/qt3/
USER=root
LS_COLORS=no=00:fi=00:di=01;34:ln=01;36i=40;33:so=01;35:bd=40;33;01:cd=40;33;01r=01;05;37;41:mi= 01;05;37;41:ex=01;32:*.cmd=01;32:*.exe=01;32:*.com=01;32:*.btm=01;32:*.bat=01;32:*.sh=01;32:*.csh=01 ;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz =01;31:*.bz2=01;31:*.bz=01;31:*.tz=01;31:*.rpm=01;31:*.cpio=01;31:*.jpg=01;35:*.gif=01;35:*.bmp=01;3 5:*.xbm=01;35:*.xpm=01;35:*.png=01;35:*.tif=01;35:
LC_TELEPHONE=en_US
ENV=/root/.bashrc
USERNAME=root
SCREENDIR=/root/tmp
NLSPATH=/usr/share/locale/%l/%N
MAIL=/var/spool/mail/root
PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/bin:/usr/local/sbin:/usr/bin/tcc:/usr/lib/tcc
LC_MESSAGES=en_US
SECURE_LEVEL=2
LC_IDENTIFICATION=en_US
LC_COLLATE=en_US
INPUTRC=/etc/inputrc
PWD=/home/me/Download/kxdocker-gaclock-0.6
LANG=en_US
PYTHONSTARTUP=/etc/pythonrc.py
LC_MEASUREMENT=en_US
PS1=[\u@\h \W]\$
SSH_ASKPASS=/usr/lib/ssh/gnome-ssh-askpass
HISTCONTROL=ignoredups
LESSCHARSET=koi8-r
SHLVL=1
HOME=/root
LANGUAGE=en_US:en
GCONF_TMPDIR=/tmp
TMP=/root/tmp
LESS=-MM
G_FILENAME_ENCODING=@locale
LOGNAME=root
LC_CTYPE=en_US
LESSOPEN=|/usr/bin/lesspipe.sh %s
DISPLAY=:0.0
LC_TIME=en_US
LC_NAME=en_US
XAUTHORITY=/root/.xauth5GAq4D
_=/bin/env
OLDPWD=/home/me/Download/kxdocker-gaclock-0.6/src


Good luck!
TheGNUbie
 
Old 02-28-2009, 05:36 PM   #4
mmrtnt
LQ Newbie
 
Registered: Nov 2006
Location: las vegas, nevada
Distribution: fedora core x
Posts: 25

Rep: Reputation: 7
Three years too late, but when I Googled for a solution to this, this was the first hit.

Here's what I had:

/usr/bin/ld: cannot find -lXxf86vm 2008

RPM insisted that libXxf86vm was installed. When I looked at the directory, I saw this:

#> ll /usr/lib64/ | grep Xxf86vm
libXxf86vm.so.1 -> libXxf86vm.so.1.0.0
libXxf86vm.so.1.0.0

It turns out the RPM installer didn't set a symbolic link. I did this:

cd /usr/lib64
ln -s ./libXxf86vm.so.1 ./libXxf86vm.so

and I was off to the races.

Hope this helps someone...
 
Old 03-01-2009, 01:33 AM   #5
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,441

Rep: Reputation: Disabled
FWIW all my libXext.so files are in /usr/lib/ Maybe you need to set a flag in the config stage to point the compiler to the correct folder (/usr/X11R6/lib/ in your case)
Cheers,
jdk
 
Old 11-17-2009, 06:50 AM   #6
apjena
LQ Newbie
 
Registered: Nov 2009
Posts: 4

Rep: Reputation: 0
Thumbs up really helped

Thanks Man.
I got some trouble where "gpaw" couldn't find lblas and llapack whereas I had both the packages installed.
I made those symlinks:
]# cd /usr/lib
]# ln -s ./libblas.so.3 ./libblas.so
]#ln -s ./liblapack.so.3 ./liblapack.so

and that worked !!! Thanks.

Quote:
Originally Posted by mmrtnt View Post
Three years too late, but when I Googled for a solution to this, this was the first hit.

Here's what I had:

/usr/bin/ld: cannot find -lXxf86vm 2008

RPM insisted that libXxf86vm was installed. When I looked at the directory, I saw this:

#> ll /usr/lib64/ | grep Xxf86vm
libXxf86vm.so.1 -> libXxf86vm.so.1.0.0
libXxf86vm.so.1.0.0

It turns out the RPM installer didn't set a symbolic link. I did this:

cd /usr/lib64
ln -s ./libXxf86vm.so.1 ./libXxf86vm.so

and I was off to the races.

Hope this helps someone...
 
Old 11-17-2009, 06:59 AM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,522

Rep: Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503
All those links are in the development packages.
( lib<name>.so )

Ubuntu : sudo apt-get install libxt-dev

Fedora : # yum install libXt-devel

Not installing the ' -devel ' packages :
you will miss out all headers ( files.h )
+ /usr/lib/pkgconfig/<name>.pc ... and more ..
.....
.....

When e.g. configure asks for "name" it means
lib<name>-dev .. or ... lib<name>-devel
.....

Last edited by knudfl; 11-17-2009 at 07:02 AM.
 
Old 12-24-2009, 12:47 AM   #8
shariefbe
Member
 
Registered: Aug 2008
Location: Trichy,India
Distribution: UBUNTU 10.10
Posts: 363

Rep: Reputation: 31
Hello,
Now i am getting the following error. dont kow what to do

Code:
/usr/bin/ld: cannot find -l_aac_dec_arm12_elinux
collect2: ld returned 1 exit status
make[1]: *** [libmfw_gst_aacdec.la] Error 1
make[1]: Leaving directory `/home/ariem/Desktop/plugins/fsl_linux_sdk_gstreamer_plugins_1.6.0_1/gst-fsl-plugin-1.6.0/src/audio/aac_dec/src'
make: *** [all-recursive] Error 1
kindly help me
 
Old 02-10-2010, 10:44 AM   #9
somesayinice
LQ Newbie
 
Registered: Feb 2010
Posts: 2

Rep: Reputation: 0
Talking

Quote:
Originally Posted by mmrtnt View Post
Three years too late, but when I Googled for a solution to this, this was the first hit.

Here's what I had:

/usr/bin/ld: cannot find -lXxf86vm 2008

RPM insisted that libXxf86vm was installed. When I looked at the directory, I saw this:

#> ll /usr/lib64/ | grep Xxf86vm
libXxf86vm.so.1 -> libXxf86vm.so.1.0.0
libXxf86vm.so.1.0.0

It turns out the RPM installer didn't set a symbolic link. I did this:

cd /usr/lib64
ln -s ./libXxf86vm.so.1 ./libXxf86vm.so

and I was off to the races.

Hope this helps someone...
Thank you so, so much. This fixed all the issues i was having compliling vlc.
 
Old 02-10-2010, 10:49 AM   #10
somesayinice
LQ Newbie
 
Registered: Feb 2010
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by shariefbe View Post
Hello,
Now i am getting the following error. dont kow what to do

Code:
/usr/bin/ld: cannot find -l_aac_dec_arm12_elinux
collect2: ld returned 1 exit status
make[1]: *** [libmfw_gst_aacdec.la] Error 1
make[1]: Leaving directory `/home/ariem/Desktop/plugins/fsl_linux_sdk_gstreamer_plugins_1.6.0_1/gst-fsl-plugin-1.6.0/src/audio/aac_dec/src'
make: *** [all-recursive] Error 1
kindly help me
Well, if you follow mmrtnt post about two up, you can go /usr/lib to see if the libaac_dec_arm12_elinux is actually there. Once you've confirmed it there, there should be a symbolic link libaacxxx.so (where xxx is the end of the file name). Make sure it's pointing to the actual file libaacxxx. Make sure the file that libaacxx.so is pointing to and the actual file libaacxxx have the same exact name. If not then make a new symbolic link name it libaacxxx and make sure it points to libaacxxx (the actual file). This worked for me when i had to remake libavutil and libavformat when compiling vlc. Hope this helps and is not too late.
 
Old 02-16-2010, 03:26 AM   #11
shariefbe
Member
 
Registered: Aug 2008
Location: Trichy,India
Distribution: UBUNTU 10.10
Posts: 363

Rep: Reputation: 31
Hello,
when i try to use "ll" i am getting the following error as
Code:
sharief@sharief-desktop:/mnt/omap/sources/dbus-1.2.20$ ll /mnt/freescale/nfs-develop/usr/local/lib/ | grep expat
bash: ll: command not found
sharief@sharief-desktop:/mnt/omap/sources/dbus-1.2.20$
I didnt understand in my case
see
Code:
sharief@sharief-desktop:/mnt/freescale/nfs-develop/usr/local/lib$ ls -l /mnt/freescale/nfs-develop/usr/local/lib/libexpat.so
lrwxrwxrwx 1 sharief sharief 17 2010-02-16 14:38 /mnt/freescale/nfs-develop/usr/local/lib/libexpat.so -> libexpat.so.1.5.2
sharief@sharief-desktop:/mnt/freescale/nfs-develop/usr/local/lib$ ls -l /mnt/freescale/nfs-develop/usr/local/lib/libexpat.so.1
lrwxrwxrwx 1 sharief sharief 17 2010-02-16 14:38 /mnt/freescale/nfs-develop/usr/local/lib/libexpat.so.1 -> libexpat.so.1.5.2
sharief@sharief-desktop:/mnt/freescale/nfs-develop/usr/local/lib$ ls -l /mnt/freescale/nfs-develop/usr/local/lib/libexpat.so.1.5.2 
-rwxr-xr-x 1 sharief sharief 193763 2010-02-16 14:38 /mnt/freescale/nfs-develop/usr/local/lib/libexpat.so.1.5.2

Last edited by shariefbe; 02-16-2010 at 03:42 AM.
 
Old 02-16-2010, 11:48 PM   #12
mmrtnt
LQ Newbie
 
Registered: Nov 2006
Location: las vegas, nevada
Distribution: fedora core x
Posts: 25

Rep: Reputation: 7
when i try to use "ll" i am getting the following error as

Oh, sorry about that!

"ll" is an alias for "ls -l"

You can set up aliases on the command line:

Code:
alias ll='ls -l'
Or you can set them up in .bashrc or .cshrc in your home directory.

Code:
# .bashrc

# Source global definitions
if [ -f /etc/bashrc ]; then
        . /etc/bashrc
fi

# User specific aliases and functions

alias ll='ls -l'
alias lg='ls -lg'
alias hoffman='ssh 192.168.0.2'
alias home='cd ~/'
 
Old 02-16-2010, 11:51 PM   #13
shariefbe
Member
 
Registered: Aug 2008
Location: Trichy,India
Distribution: UBUNTU 10.10
Posts: 363

Rep: Reputation: 31
oh fine. now it works for me. Thanks a lot
 
Old 11-23-2010, 04:53 PM   #14
krestel1
LQ Newbie
 
Registered: Nov 2010
Posts: 1

Rep: Reputation: 0
Talking /usr/bin/ld: cannot find -lz and libxml2 not found

The thread helped me solve my issue of not finding the zlibs
I was getting an error "/usr/bin/ld: cannot find -lz" while trying to compile a perl module.
The actual message without the DEBUG flag was "libxml2 not found" which lead me down a different path.
Only after I turn debug on "perl Makefile.PL DEBUG=1" did I notice that it said cannot find -lz

After some searches, I realized that z here means the zlibs.. and checking this thread made me realize that there were no symlink in /usr/lib64
ll /usr/lib64 |grep libz
libz.so.1 -> libz.so.1.2.3
libz.so.1.2.3

I added a symlink
ln -s libz.so.1 libz.so

and now make completes!
Thanks for the tip, I thought I post my experince.
 
Old 11-24-2010, 11:42 AM   #15
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,522

Rep: Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503
@ krestel1, post # 14 : Welcome to LQ.

A link is not a real solution.
For the most development, you will probably also need one of these :
/usr/include/zconf.h , /usr/include/zlib.h

So correct is : Install zlib-devel or whatever name it has on your OS.
..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/usr/bin/ld: cannot find -lqt, make xconfig tuxandme Linux - Software 5 06-19-2005 01:04 PM
/usr/bin/ld error recieved on make jmonolith2001 Linux - Software 4 12-28-2004 03:23 AM
when running make get: usr/bin/ld: cannot find -lart_lgpl_2 nigma Linux - Software 0 02-12-2004 09:22 PM
error compiling cdrtools on kernel 2.6.0: /usr/bin/ld: cannot find -lscg schatoor Linux - Software 1 12-21-2003 08:15 AM
/usr/bin/ld: cannot find -lusb error?? Hyperion007 Linux - Newbie 1 08-21-2003 04:16 AM


All times are GMT -5. The time now is 03:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration