LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-08-2004, 12:03 PM   #1
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
make an alsa program use OSS output ?


Hi, i have downloaded a game (quake2forge)
which can be configured to use libao or ALSA sound.

for whatever reason, using libao causes a compile error.

im am using fedora core 1 (kernel 2.4.22)

and although i have installed the correct
alsa-driver
alsa-lib
alsa-utils

alsa tells me that there is no support for my sound card (SiS 7012)
i have done my research and confirmed this, alsa does not support my sound card unless i download the latest 2.6 kernel. Which unfortunatly is NOT an option, as i only have drivers for my winmodem under kernel 2.4

Sooooooo.
is there a program / tweak i could do to make alsa (which is installed)
output through OSS (which works).. or change quake2 to use OSS instead of alsa ?
OR... use the 2.6 Kernel ALSA drivers with my 2.4 kernel ?

thankyou.
 
Old 03-08-2004, 12:13 PM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
Doesn't the snd-intel8x0 Alsa module support this card? What happens when you modprobe that module (as root, obviously)?


Håkan
 
Old 03-08-2004, 05:30 PM   #3
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
Quote:
modprobe: Can't locate module snd-intel8x0
whenever i search for "intel810 ALSa" or "sis 7012 ALSA"
all i find is failure stories about alsa with my motherboard.
(my sound card is integrated onto my board)

i didnt know there was such a module, where can i get it.

lsmod shows the following sound related modules....

soundcore [used by i810_audio]
ac97_codec [used by i810_audio]
i810_audio

and with this config, sound works fine, (except with alsa output)

cat /etc/modules.conf contains. the following sound related enteries.
alias sound-slot-0 i810_audio

thanks for the reply.
do you have an url for the intel 8x0 module ?
 
Old 03-08-2004, 05:35 PM   #4
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
i810_audio is the OSS sound module, snd-intel8x0 is the Alsa module. At least give Alsa a try before you decide it doesn't work.


Håkan
 
Old 03-08-2004, 05:50 PM   #5
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
the module is reported to be supplyed by alsa-driver.
which i installed via rpm, yet there is no module by that name.

any ideas anyone ?
 
Old 03-08-2004, 05:59 PM   #6
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
if all else fails, use the source !
hopefully ./configure --help will be of more help.
 
Old 03-08-2004, 06:13 PM   #7
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
okay.... getting closer... BUT..

[root@localhost root]# modprobe snd-intel8x0
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: insmod /lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o failed
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: insmod snd-intel8x0 failed

and dmesg shows
Intel ICH soundcard not found or device busy

and insmod shows
[root@localhost root]# insmod snd-intel8x0
Using /lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_ac97_pcm_open
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_ac97_pcm_close
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_pcm_lib_free_pages_Raabb5db2
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_ac97_set_rate
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_pcm_suspend_all_Rb1e2f375
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_pcm_limit_hw_rates_R1707d4c0
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_card_proc_new_R4994be5b
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_ac97_pcm_assign
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_ac97_tune_hardware
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_pcm_lib_preallocate_pci_pages_for_all_Re88d585c
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_card_register_Rf5a68e86
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_pcm_period_elapsed_Rb4b49390
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_card_new_Rc8bb881b
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol gameport_unregister_port_R70daab68
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_device_new_R993525d3
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_pcm_lib_malloc_pages_R5b8c16b3
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_kcalloc_R4da9e78a
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_pcm_set_ops_Rea08fdb0
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_pcm_hw_constraint_list_R2d55a124
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_pcm_hw_constraint_integer_R57963b4c
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_mpu401_uart_new_R0a4ceff1
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_free_pci_pages_Ra2184231
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_ac97_mixer
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_malloc_pci_pages_R516d0d40
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_iprintf_R2f0b152f
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol gameport_register_port_R98692e58
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_ac97_resume
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_pcm_new_R108b8f8e
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_verbose_printk_Rf52a421e
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_ac97_bus
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_pcm_lib_ioctl_R04d896c8
/lib/modules/2.4.22-1.2115.nptl/kernel/sound/pci/snd-intel8x0.o: unresolved symbol snd_card_free_Rfae4f6ed


whats the deal with this ?

Last edited by qwijibow; 03-08-2004 at 06:16 PM.
 
Old 03-08-2004, 10:59 PM   #8
nyclinux
LQ Newbie
 
Registered: Mar 2004
Location: brooklyn
Posts: 4

Rep: Reputation: 0
first off: your /etc/modules.conf line is trying to use the oss system according to hw-tph.
Look at alsa-project.org and you will see examples of how to setup modules.conf, you need about 12 lines in there, mostly for OSS compatibility.

If you setup modules.conf and still get the unresolved symbol error then it could be that you have ALSA rpm packages that don't match the kernel you're running. This is why qwijibow recommended you install alsa from source code, the compilation process will autodetect the kernel you are running at the time of compilation. But you really shouldn't have a problem using alsa modules built against 2.4.20 with 2.4.22 for example. Note that this is not an option unless you install the kernel headers as well or build your kernel from source.

Finally, if you get alsa installed properly and really can't get that card to work then just by a generic $20 pci audio card. These cards are standard enough to use generic ones(unlike more recently developed types of hardware) as they all use the same chipsets in the same way. The $20 is worth the hassle and will prevent you from getting that zipper noise in your speakers everytime you move the mouse. Believe me, onboard soundcards are the absolute bottom of the foodchain.

-jacob

here's my modules.conf for alsa:

#ALSA
alias char-major-116 snd
#OSS/Free
alias char-major-14 soundcore

#ALSA details
#LAW auto-entry
#alias snd-card-0 snd-echoaudio
alias snd-card-0 snd-trident

#OSS/Free details
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
 
Old 03-08-2004, 11:29 PM   #9
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
i have an old pc (about 5 years old) with a pci sound card,
uses a es13XX module. maybe i will try that.

however, i noticed all those modules named things like snd-XXX-oss

should i have installed the alsa-oss package ?
i saw it on the ftp servers but none of the install guides mentioned it.

looks like you have it ?

i will try it, thanks for the info.

the confusing thing is, i once compiled a 2.6 kernel on this machine,
and after saying yes to alsa in configureating it, ALSA worked 100%
but with my 2.4 kernel, i cannot find an ALSA section in the make xconfig.

if i had broadband, i could bin the winmodem and install the 2,6 kernel, but being a skint student, with drinking friends to keep up with... well you get the idea, lol.

thank for all the help guys.... ill either sort this problem, or just bin quake2
 
Old 03-09-2004, 08:45 AM   #10
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
isnt it the case that the problem is obviouse after a good nights sleep...
i had to rmmod the OSS driver before i could modprobe the ALSA driver.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel-2.6.3 compiled with alsa but xmms alsa output dont plays demmylls Linux - General 3 09-01-2006 05:32 AM
How to make ALSA not "interruptable" like OSS? kornerr Linux - General 0 07-29-2005 11:35 AM
Necessity of OSS+ALSA, and Program conflictions Synesthesia Linux - General 1 05-21-2005 12:09 PM
ALSA-oss compatability works, but not programs intended for alsa ? qwijibow Linux - Software 5 03-14-2004 08:28 AM
Can't activate OSS sound output in games dushkinup Linux - Software 0 03-11-2004 03:36 PM


All times are GMT -5. The time now is 07:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration