LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 08-15-2003, 02:04 AM   #1
sebastianjustin
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Rep: Reputation: 0
Question mail replication postfix + procmail + fetchmail



There is a problem with my mailserver(postfix+procmail+fetchmail +redhat 9.0).If a mail is sent to multiple recipients (ie:To,Cc,Bc) ,all the recipients will get multiple copies of same mail.The number of multiple copies is proportional to the number of addressee.There is no problem if there is only one recipient ,ieonly To).
I checked all the configuration files (ie .procmailrc,.fetchmailrc ),but all seems to be fine.The same configuration was working fine till the other day.What may have gone wrong?
Please help me to find a solution.

jus
 
Old 08-15-2003, 07:14 AM   #2
cnjohnson
Member
 
Registered: Nov 2002
Location: Nashville
Distribution: FreeBSD, Linux, OS-X
Posts: 544

Rep: Reputation: 30
Check to make sure that fetchmail is deleting the mail from the server from where it is getting the mail. Have you been testing fetchmail at all, trying out different cmmand line switches and the like?

Cheers--
Charles
 
Old 08-19-2003, 11:14 PM   #3
sebastianjustin
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Original Poster
Rep: Reputation: 0
I checked abt what U said.Fetch mail is deleting mail from the server.
Cheers
jus
 
Old 08-20-2003, 07:50 AM   #4
cnjohnson
Member
 
Registered: Nov 2002
Location: Nashville
Distribution: FreeBSD, Linux, OS-X
Posts: 544

Rep: Reputation: 30
OK. What does your .procmailrc file look like?

Cheers--
Charles
 
Old 08-21-2003, 06:33 AM   #5
sebastianjustin
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Hello Charles,
I found out a solution to my problem.It was related to size of duplicates file.It got flooded with duplicate mails.So the mails were flushed to user's directory.I deleted the duplicate file and created a new one.Now every thing is working fine.

Cheers ,
jus.
 
Old 08-21-2003, 07:45 AM   #6
cnjohnson
Member
 
Registered: Nov 2002
Location: Nashville
Distribution: FreeBSD, Linux, OS-X
Posts: 544

Rep: Reputation: 30
Ah, good to know. Thanks!

Cheers--
Charles

Last edited by cnjohnson; 08-21-2003 at 07:51 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix - procmail, fetchmail varun_saa Mandriva 3 09-11-2005 12:53 AM
email from the console (fetchmail/procmail/mutt/postfix) TedMaul Linux - Software 0 03-04-2004 12:07 PM
IMAP and fetchmail / postfix / procmail / spamc etc... fordboy0 Linux - Networking 2 09-17-2003 07:51 PM
configuring mail server (postfix+fetchmail+procmail) amolchikhale Linux - Networking 0 08-01-2003 04:59 AM
Spamassassin conf with fetchmail, postfix, procmail, kmail iihay Linux - Networking 0 05-25-2003 09:03 AM


All times are GMT -5. The time now is 07:55 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration