LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 05-15-2010, 06:04 PM   #1
programmer1985
LQ Newbie
 
Registered: May 2010
Distribution: Archlinux
Posts: 25

Rep: Reputation: 15
LXDE error


I just installed LXDE and configured the .xinitrc file and when I gave the command "startx" and it tried to start, but stopped with this error message


waiting for X server to shut down error setting MTRR (base = 0xf0000000, size = 0x04000000, type = 1) Inappropriate ioctl for device (25)



Im not sure if I configured the .xinitrc file correctly, so that may be the problem,
I really dont know how to fix this, im new to linux, I would appreciate some instruction, thanks
 
Old 05-15-2010, 06:13 PM   #2
zuzoa
Member
 
Registered: Nov 2008
Location: USA
Distribution: Arch 64-bit
Posts: 159

Rep: Reputation: 35
Can you please post your .xinitrc file?
 
Old 05-15-2010, 06:18 PM   #3
programmer1985
LQ Newbie
 
Registered: May 2010
Distribution: Archlinux
Posts: 25

Original Poster
Rep: Reputation: 15
yes here it is

#!/bin/sh
#
# ~/.xinitrc
# Executed by startx (run your window manager from here)

# exec openbox
# exec ck-launch-session startlxde


I have a feeling this is the problem, i just dont know how to fix it
 
Old 05-15-2010, 06:20 PM   #4
brucehinrichs
Member
 
Registered: Mar 2008
Location: US
Distribution: Debian Sid; Sabayon, UbuntuStudio, Slackware-multilib 13.1, Peppermint Ice, CentOS
Posts: 575

Rep: Reputation: 67
Quote:
# ~/.xinitrc
Uncomment this line (remove the # sign).
 
Old 05-15-2010, 06:23 PM   #5
programmer1985
LQ Newbie
 
Registered: May 2010
Distribution: Archlinux
Posts: 25

Original Poster
Rep: Reputation: 15
tried it, still got this

waiting for X server to shut down error setting MTRR (base = 0xf0000000, size = 0x04000000, type = 1) Inappropriate ioctl for device (25)
 
Old 05-15-2010, 06:33 PM   #6
programmer1985
LQ Newbie
 
Registered: May 2010
Distribution: Archlinux
Posts: 25

Original Poster
Rep: Reputation: 15
actually theres a new line now it says

/home/matt/.xinitrc: line 3: /home/matt/.xinitrc: permission denied

waiting for X server to shut down error setting MTRR (base = 0xf0000000, size = 0x04000000, type = 1) Inappropriate ioctl for device (25)

all uncommenting "# ~/.xinitric" did was add a new error message
 
Old 05-15-2010, 06:35 PM   #7
zuzoa
Member
 
Registered: Nov 2008
Location: USA
Distribution: Arch 64-bit
Posts: 159

Rep: Reputation: 35
Try uncommenting the line: exec ck-launch-session startlxde
and try running startx again.

And also post the output of "stat /home/matt/.xinitrc"
 
Old 05-15-2010, 06:35 PM   #8
brucehinrichs
Member
 
Registered: Mar 2008
Location: US
Distribution: Debian Sid; Sabayon, UbuntuStudio, Slackware-multilib 13.1, Peppermint Ice, CentOS
Posts: 575

Rep: Reputation: 67
Sorry, my fault. Put that # sign back and uncomment these lines:
Code:
# exec openbox
# exec ck-launch-session startlxde
 
Old 05-15-2010, 06:38 PM   #9
zuzoa
Member
 
Registered: Nov 2008
Location: USA
Distribution: Arch 64-bit
Posts: 159

Rep: Reputation: 35
Quote:
Originally Posted by brucehinrichs View Post
Sorry, my fault. Put that # sign back and uncomment these lines:
Code:
# exec openbox
# exec ck-launch-session startlxde
I think he should probably just uncomment one or the other, can't have openbox and LXDE running at the same time AFAIK :P
 
1 members found this post helpful.
Old 05-15-2010, 06:42 PM   #10
programmer1985
LQ Newbie
 
Registered: May 2010
Distribution: Archlinux
Posts: 25

Original Poster
Rep: Reputation: 15
Thanks alot guys, it works perfectly now, all i did was uncomment "# exec ck-launch-session startlxde", ive been having problems with this all week, thanks again!
 
Old 05-15-2010, 06:43 PM   #11
zuzoa
Member
 
Registered: Nov 2008
Location: USA
Distribution: Arch 64-bit
Posts: 159

Rep: Reputation: 35
No problem Remember to mark your thread as solved!
 
Old 05-15-2010, 07:08 PM   #12
programmer1985
LQ Newbie
 
Registered: May 2010
Distribution: Archlinux
Posts: 25

Original Poster
Rep: Reputation: 15
ok, this is my first day here, how do i mark it as solved, for future reference?
 
Old 05-15-2010, 07:21 PM   #13
brucehinrichs
Member
 
Registered: Mar 2008
Location: US
Distribution: Debian Sid; Sabayon, UbuntuStudio, Slackware-multilib 13.1, Peppermint Ice, CentOS
Posts: 575

Rep: Reputation: 67
At the top of the thread, select Thread Tools>Mark Thread Solved
 
  


Reply

Tags
lxde


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Opensuse 11.2 lxde or PclinuxOs 2009.4 lxde damipereira Linux - Distributions 1 02-16-2010 03:51 AM
LXDE distros Rick069 Linux - Desktop 1 11-22-2009 06:31 PM
Gamin error message after log-in with LXDE the trooper Debian 1 11-05-2009 12:33 AM
LXDE Alelinux Linux - Newbie 1 06-26-2009 04:55 PM
Lxde ronlau9 Linux - Software 0 08-04-2008 07:56 AM


All times are GMT -5. The time now is 11:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration