LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 01-11-2010, 09:07 AM   #1
shariefbe
Member
 
Registered: Aug 2008
Location: Tiruchirappalli, India
Distribution: UBUNTU 11.04
Posts: 368

Rep: Reputation: 31
LTIB compiling error


Hello. When i try to run LTIB tool i am getting this error. I dont know how to solve this error. So please help me
Code:
checking for XORG... configure: error: Package requirements (xorg-server >= 1.0.99.901 xproto fontsproto ) were not met:

No package 'xorg-server' found
No package 'xproto' found
No package 'fontsproto' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XORG_CFLAGS
and XORG_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

error: Bad exit status from /home/ltib/tmp/rpm-tmp.19123 (%build)


RPM build errors:
    Bad exit status from /home/ltib/tmp/rpm-tmp.19123 (%build)
Build time for xserver-xorg-video-fbdev-ipu: 6 seconds

Failed building xserver-xorg-video-fbdev-ipu


f_buildrpms() returned an error, exiting
traceback:
 main:560


Started: Mon Jan 11 19:15:14 2010
Ended:   Mon Jan 11 19:15:23 2010
Elapsed: 9 seconds

These packages failed to build:
xserver-xorg-video-fbdev-ipu 

Build Failed

Exiting on error or interrupt
 
Old 01-11-2010, 10:42 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,615

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
I gather you're trying to build a src rpm. There's 2 databases you need to be aware of

/usr/lib/pkgconfig for configure scripts of source code
/var/lib/rpm/__db.001, __db.002, & __db.003 Installed rpms.

Best try installing an xserver. I think there's a --justdb option.
 
Old 01-11-2010, 11:36 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,272

Rep: Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663
Quote:
No package 'xorg-server' found
No package 'xproto' found
No package 'fontsproto' found
When configure asks for "package" or "name"
it means (lib)"name"-dev , or the package / file
name in /usr/lib/pkgconfig/ .. i.e : /usr/lib/pkgconfig/"name".pc

When I once compiled LTIB ( part of )
http://www.linuxquestions.org/questi...e-9.04-771464/

.. I had these installed :
libx11-dev
libxft-dev
x11proto-composite-dev
x11proto-core-dev → → /usr/lib/pkgconfig/xproto.pc
x11proto-damage-dev
x11proto-fixes-dev
x11proto-fonts-dev → /usr/lib/pkgconfig/fontsproto.pc
x11proto-input-dev
x11proto-kb-dev
x11proto-randr-dev
x11proto-render-dev
x11proto-xext-dev
x11proto-xinerama-dev
( xorg-dev )
xserver-xorg-dev → /usr/lib/pkgconfig/xorg-server.pc
.....
Search method , example :
http://packages.debian.org/search?su...=fontsproto.pc
.....

Last edited by knudfl; 01-11-2010 at 11:52 AM.
 
  


Reply

Tags
ltib


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Failure to install LTIB on Jaunty Jackalope 9.04 Kesem Linux - Software 1 11-28-2009 03:32 PM
failed building ltib with can4linux package susan07 Linux - General 0 04-21-2008 06:46 AM
Failed building ltib with can4linux package susan07 LinuxQuestions.org Member Intro 0 04-21-2008 04:40 AM
installing LTIB problem and cant set the user privilege section rohit83.ken Linux - Software 0 02-05-2008 12:16 AM
how to install LTIB ? jay_CMRIT_3477 Linux - Software 0 07-27-2006 09:37 AM


All times are GMT -5. The time now is 09:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration