LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Low screen resolution ubuntu feisty (http://www.linuxquestions.org/questions/linux-software-2/low-screen-resolution-ubuntu-feisty-557453/)

Brynn 05-29-2007 10:23 AM

Low screen resolution ubuntu feisty
 
I've recently upgraded my computer and i decided to go for change over to the 64 bit ubuntu, the install went fine and i've worked most of the bugs out of it now except for my screen resolution. When i installed ubuntu last time it recognized my monitor as Samsung Syncmaster 710v and i set it to 1280 x 1024, unfortunately this time my monitor is set to "Generic monitor" and the maximum screen resolution it will let me set it to is 1024 x 768.
Quote:

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 28.0 - 51.0
VertRefresh 43.0 - 60.0
Option "DPMS"
Modeline "1280x1024_60.00" 108.88 1280 1360 1496 1712 1024 1025 1028 1060 -HSync +Vsync

EndSection

Section "Device"
Identifier "nVidia Corporation G70 [GeForce 7600 GS]"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation G70 [GeForce 7600 GS]"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
The bits in red are what i added and the modeline was generated with
Code:

gtf 1280 1024 60 -x
but none of this seemed to help, any idea what i should be doing?
Also i have a new video card, its an Nvidia 7600gs using the Nvidia drivers from there website.

Wim Sturkenboom 05-30-2007 02:54 AM

Check the HorizSync and VertRefresh against the specs of your monitor. 51kHz as a max for HorizSync is not enough for your resolution at 60 Hz.

PS1 Modeline might not be required after above modification
PS2 I've heard that X does not like modelines with a dot; call it something else like 1280x1024_60
PS3 Your default depth is 24 (see top of screen section) and you have not added 1280x1024 to the subsection for depth 24, so X will not use it.

Brynn 05-30-2007 08:28 AM

Cheers man, I hadn't realized that I missed 1280x1024 from the section for 24 bit colour, that seemed to do it.
Thanks

Whitestar 05-31-2007 01:04 PM

Newbie Q with similar issues. I've never had a problem installing Ubuntu before. I just tried to install a version of Feisty, but I can't because the screen resolution isn't right and when I go to the screen resolution menu, it offers two choices: 800x600 or 640x480. This, of course is using the settings from the start menu, system, preferences, screen resolution...it isn't from the command line. How do I change the resolution? I need better than those two choices. I didn't have problems with Edgy. Maybe I should just go back to the old system and wait for Gutsy Gibbon?

Brynn 06-01-2007 05:10 AM

try modifying you xorg.conf file as i have,
Code:

sudo gedit /etc/X11/xorg.conf
Make a backup first though
Code:

cp /etc/X11/xorg.conf /var/backups/X/xorg.backup
then try adding the necessary bits to get your desired screen resolution just try adding the resolutions at the bottom section first

Wim Sturkenboom 06-01-2007 06:29 AM

We might be able to help if you post your specs (make and model of monitor and video card) as well as the sections device, monitor and screen from the file /etc/X11/xorg.conf .

Mike Graham 06-09-2007 01:36 AM

Another n00b here with a similar problem.

I just installed 7.04. My graphics card is an nVIDIA GeForce 7300GS made by EVGA. My monitor is an old CRT, a Envision EN-710, which nvidia-settings calls "@@@".

My resolution is stuck at exactly 800x600. If I try to change resolution by System>Preferences>Screen Resolution, my screen resolution won't change from 800x600 and my refresh rate from 50Hz. If I open nvidia-settings, resolution sticks to auto. (All of this is with the nVidia Accelerated Graphics Driver enabled--otherwise everything sticks at 1024x768.

Here are the sections of my xorg.conf file you asked for:
Code:

Section "Device"
        Identifier        "nVidia Corporation G71 [GeForce 7300 GS]"
        Driver                "nvidia"
        Busid                "PCI:1:0:0"
        Option                "AddARGBVisuals"        "True"
        Option                "AddARGBGLXVisuals"        "True"
        Option                "NoLogo"        "True"
EndSection

Section "Monitor"
        Identifier        "Generic Monitor"
        Option                "DPMS"
        Horizsync        28-51
        Vertrefresh        43-60
EndSection

Section "Screen"
        Identifier        "Default Screen"
        Device                "nVidia Corporation G71 [GeForce 7300 GS]"
        Monitor                "Generic Monitor"
        Defaultdepth        24
        SubSection "Display"
                Depth        1
                Modes                "1024x768"        "800x600"        "640x480"
        EndSubSection
        SubSection "Display"
                Depth        4
                Modes                "1024x768"        "800x600"        "640x480"
        EndSubSection
        SubSection "Display"
                Depth        8
                Modes                "1024x768"        "800x600"        "640x480"
        EndSubSection
        SubSection "Display"
                Depth        15
                Modes                "1024x768"        "800x600"        "640x480"
        EndSubSection
        SubSection "Display"
                Depth        16
                Modes                "1024x768"        "800x600"        "640x480"
        EndSubSection
        SubSection "Display"
                Depth        24
                Modes                "1024x768"        "800x600"        "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier        "Default Layout"
  screen "Default Screen"
        Inputdevice        "Generic Keyboard"
        Inputdevice        "Configured Mouse"
        Inputdevice        "stylus"        "SendCoreEvents"
        Inputdevice        "cursor"        "SendCoreEvents"
        Inputdevice        "eraser"        "SendCoreEvents"
EndSection


I've tried to implement the solutions talked about in this thread, but I really don't know what I'm doing. I end up rebooting to major graphics problems and just replace my xorg.conf with my backed-up copy.

dcarrco 06-10-2007 11:20 PM

i just installed Ubuntu Feisty 7.04 onto my machine, which has an nVidia GeForce 5600 Dual Head. i have tried to edit my xorg.conf, i have run nvidia-settings (and i have confirmed that i am using the restricted driver), and i have run the Xconfig. i can get resolution working fine up to 1024x768, but not at 1248x1024 which is how i run it in XP. i have added modelines to my xorg.conf, expanded refresh numbers for my monitors, reduced to one screen and tried there, but cannot get the nvidia-settings to show 1248x1024. the only thing i havent done is install the latest nvidia driver because it wants to recompile my kernel and i havent figured out how to do that. heres my xorg.conf. any ideas appreciated.

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder3) Thu Nov 9 17:56:12 PST 2006

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Princeton Graphics Systems VL173"
HorizSync 31.0 - 95.0
VertRefresh 56.0 - 160.0
Option "DPMS"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor1"
VendorName "Unknown"
ModelName "Princeton Graphics Systems VL173"
HorizSync 31.0 - 95.0
VertRefresh 56.0 - 160.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6200"
BusID "PCI:2:0:0"
Screen 0
EndSection

Section "Device"
Identifier "Videocard1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6200"
BusID "PCI:2:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "metamodes" "CRT-0: 1024x768 +0+0; CRT-0: 800x600 +0+0; CRT-0: 640x480 +0+0"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
Option "metamodes" "CRT-1: 1024x768 +0+0"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Mike Graham 06-12-2007 01:33 AM

Try re-installing using method two from this HOWTO. It will walk you through installing the latest drivers.

(This was prettymuch the solution for me, by the way. My problem was resolved.)

Brynn 06-12-2007 05:07 AM

On your screen1 you only have the option of 1024 x 768, I'm pretty sure the meta modes have to be the same for both monitors and you need to add the resoloution 1280 x 1024. Try this for editing you xorg.conf file http://wiki.arslinux.com/Twinview

dcarrco 06-12-2007 09:40 AM

thanks. i'll try these ideas. the resolution issue is the only realy thing keeping me from using linux instead of windows. i use firefox, thunderbird, and openoffice anyway, so i am mostly there. its the high-res twinview configuration that has been a pain for years.

Whitestar 06-23-2007 09:21 PM

Thank you for your replies. I have a Dell E177FP monitor, resolution 1280x1024. I have an Nvidia video card. How do I access /etc/X11/xorg.conf?

Quote:

Originally Posted by Wim Sturkenboom
We might be able to help if you post your specs (make and model of monitor and video card) as well as the sections device, monitor and screen from the file /etc/X11/xorg.conf .


Whitestar 06-23-2007 09:24 PM

Quote:

Originally Posted by Brynn
try modifying you xorg.conf file as i have,
Code:

sudo gedit /etc/X11/xorg.conf
Make a backup first though
Code:

cp /etc/X11/xorg.conf /var/backups/X/xorg.backup
then try adding the necessary bits to get your desired screen resolution just try adding the resolutions at the bottom section first

Thank you for the information. How do I add the resolutions?

boyer420z 08-08-2007 11:45 AM

Max Res 800 x 600 GeForce FX 5600
 
See my xorg.conf below:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
Fontpath "/usr/share/fonts/X11/misc"
Fontpath "/usr/share/fonts/X11/cyrillic"
Fontpath "/usr/share/fonts/X11/100dpi/:unscaled"
Fontpath "/usr/share/fonts/X11/75dpi/:unscaled"
Fontpath "/usr/share/fonts/X11/Type1"
Fontpath "/usr/share/fonts/X11/100dpi"
Fontpath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
Fontpath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
Identifier "nVidia Corporation NV31 [GeForce FX 5600]"
Driver "nvidia"
Busid "PCI:2:0:0"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "DELL E173FP"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV31 [GeForce FX 5600]"
Monitor "DELL E173FP"
Defaultdepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"
Inputdevice "stylus" "SendCoreEvents"
Inputdevice "cursor" "SendCoreEvents"
Inputdevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection

flangemonkey 08-15-2007 01:09 AM

Thanks guys, this helped, I'd done it before, but never needed to change the horizontal and vertical settings, that one had me flummoxed for a while :)


All times are GMT -5. The time now is 11:47 AM.