LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-15-2003, 01:07 PM   #1
LaughingJon
LQ Newbie
 
Registered: Feb 2003
Posts: 5

Rep: Reputation: 0
Red face Lots of NooB Questions...


Hey all.

I am very much a NooB when it comes to linux, i have only just got a box up and running recently, with lots of help LOL.

I am using Suse8 btw.

problems

I am trying to get vsFTP up and running on my system, however, i dont seem to be getting very far. I "think" it is installed as i can try and run it, but it says, this has to be called from inetd. Okay i think i add it into that.

Like this? Dunno if this is right for a start

Code:
case "$1" in
    start)
        echo -n "Starting inetd"
        ## Start daemon with startproc(8). If this fails
        ## the echo return value is set appropriate.

        # startproc should return 0, even if service is
        # already running to match LSB spec.
        startproc $INETD_BIN

        # Remember status and be verbose
        rc_status -v
        vsftp
        ;;
I then read that i need to restart it. I can do this either by rebooting the machine or finding the PID of inetd and calling
kill -1 PID... However, when i do a ps -x there is no process of inetd.. Have i broken it already? LOL So i resort to rebooting the machine.

Yet this still isn't working and i cant get any FTP access to the machine..

If anyone knows what i may have done wrong then i would be very grateful of some help

Cheers
your local


Laters
Jon
 
Old 02-15-2003, 01:10 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
that really doesn't sound like much of a newbie question... where was "how do i turn my monitor on?"

you need to use xinetd and not inetd, which was superceded about 3 years ago in the main. you should have a config file in /etc/xinetd.d/ if that is how it's meant to be started.
 
Old 02-15-2003, 01:14 PM   #3
LaughingJon
LQ Newbie
 
Registered: Feb 2003
Posts: 5

Original Poster
Rep: Reputation: 0
LOL i had to ask that question on a different forum before i got to this bit tehehe..

I have been looking for this xinetd thing as lots of places mentioned it, but even running a locate on that file/dir i get nothing...

Laters
Jon
 
Old 02-15-2003, 02:20 PM   #4
ranger_nemo
Senior Member
 
Registered: Feb 2003
Location: N'rn WI -- USA
Distribution: Kubuntu 8.04, ClarkConnect 4
Posts: 1,142

Rep: Reputation: 47
I can't help too much with the vsFTP part. If it's run by xinetd, then there will be an entry in /etc/xinetd.d . These are just text files. RedHat uses xinetd, so I don't know where inetd would be off-hand... Somewhere in /etc , most likely.

Onto services... inetd and xinetd are services / daemons. You can use the service command on them...

To see the status of all the services... service --status-all It will tell you which are stopped, which are running, and their PID.

To control an individual service... service service_name command Use the correct service_name. Command can be start, stop, restart, status, etc. Restart is useful anytime you've changed a service's config file. service smb restart to restart Samba.

As for not finding it in the ps -x, I usuallly use ps -ax | grep inet . You can replace the inet with any partial process_name. The grep searches the list for the ps and returns only those lines with an inet in it. It won't return anything if it doesn't find a match. That would happen if the service wasn't running.
 
Old 02-15-2003, 08:28 PM   #5
simbolo
Member
 
Registered: Mar 2002
Location: US, CT
Distribution: Gentoo
Posts: 56

Rep: Reputation: 15
xinetd is for girls, if this is not a real server just something your planning on letting couple of friends steal some files off you via ftp configure the server to standalone bypassing inetd, not sure where the vsFTP config files are, /etc/ most likely
 
Old 02-16-2003, 07:51 AM   #6
LaughingJon
LQ Newbie
 
Registered: Feb 2003
Posts: 5

Original Poster
Rep: Reputation: 0
well cheers peeps i will try again at getting this working.. but i think i really messed it all up last night by trying to install mysql LOL so probs going to re-install suse and start a fresh.. Then start again at trying to get vsFTP installed again

Cheers peeps you may well be hearing from me again soon
Laters
Jon
 
Old 02-16-2003, 11:30 AM   #7
LaughingJon
LQ Newbie
 
Registered: Feb 2003
Posts: 5

Original Poster
Rep: Reputation: 0
me again

i managed to sort the mysql thing, i think i have 2 versions of it installed so have started it using the later version and all seems to be working well..

also FTP seems to be working as well, i dont know if it is vsFTP or a default one though, however, when i ftp into the site i get a default directory of /pub Upon trying to find this location on my server i dont seem to be able to find a directory called /pub

Also is there any way i can find out which FTP service it is using so i can add users to it etc.

Cheers in advance
Jon

*edit actually none of that is right as i just realised i was ftp'in into a different site.. Doh! LOL.. Goes off to try vsFTP Again

Last edited by LaughingJon; 02-16-2003 at 11:33 AM.
 
Old 02-16-2003, 12:41 PM   #8
LaughingJon
LQ Newbie
 
Registered: Feb 2003
Posts: 5

Original Poster
Rep: Reputation: 0
right well i have vsFTP installed, and i managed to get it working by following the instructions and adding the line
Code:
listen=YES
to enable it to run from the command line. However...

When i follow the instructions to get it working from inetd i get problems... ie..

i uncomment this line
Code:
#ftp stream tcp nowait root /usr/sbin/tcpd /usr/local/sbin/vsftpd
i take it the "#" was a comment anyway.

And now when i try and restart inetd..

by doing ./inetd stop then ./inetd start

I get an error
Code:
./inetd: vsftp: command not found
Anyone know what could be wrong?

Cheers
Jon
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
lots of questions istratos Conectiva 4 10-12-2005 10:30 AM
Lots of questions sumedhk Linux - Newbie 3 01-27-2005 04:21 AM
10.1 Linux Noob Needs Help lots of Questions ddrfreak Mandriva 2 12-06-2004 11:46 PM
Lots of questions.. Xploder Linux - Newbie 2 07-22-2001 08:40 PM
Lots of questions Carrot Linux - Newbie 4 04-08-2001 02:33 PM


All times are GMT -5. The time now is 10:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration