LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-28-2003, 10:42 AM   #1
dwpondscum
LQ Newbie
 
Registered: Apr 2003
Location: Oklahoma
Distribution: Redhat
Posts: 25

Rep: Reputation: 15
Loading PHP into Apache


I am trying to get Apache to load PHP. Both packages are installed from my SuSE RPMs. I have added the following lines in my httpd.conf file:

LoadModule php4_module modules/libphp4.so
AddType application/x-httpd-php php

However, the following error is displayed when apache is started:
Cannot load /modules/libphp4.so into server:
/modules/libphp4.so: undefined symbol: ap_block_alarms

I have been searching the Internet and have read that there are some version conflicts with the newest versions of Apache and PHP. However, I have seen a couple different version numbers where the conflict starts. I have Apache 2.0.40-12 and PHP 4.2.2-82.

What are some other possible reasons for the conflict other then version errors? Is there another option besides reverting back to a previous version? If not, which should I revert Apache or PHP?

I do appreciate any feedback.
 
Old 10-18-2003, 05:34 PM   #2
everythingand2
Member
 
Registered: Oct 2003
Location: Kansas City, MO
Distribution: Slackware 9.1
Posts: 61

Rep: Reputation: 15
I'm getting this same error...help!
 
Old 10-18-2003, 05:56 PM   #3
simplico
Member
 
Registered: Jul 2003
Location: Orlando, FL
Distribution: mandrake 10
Posts: 62

Rep: Reputation: 15
just to make sure. that file is in the modules folder in the apache dir, right?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache 2, PHP 5, SuSE 9.2 - cannot run php files dickohead Linux - Networking 6 06-28-2006 11:25 AM
php apache or php cgi - php learner rblampain Linux - Security 3 12-18-2004 12:10 AM
Apache httpd not loading php pages properly. queezythegreat Linux - Networking 0 09-26-2004 04:50 PM
slackware, apache and PHP from .tgz - problems with PHP szymon Slackware 2 09-06-2004 05:57 PM
PHP not loading on Apache, help! enteal Linux - Software 3 04-19-2004 11:30 AM


All times are GMT -5. The time now is 07:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration