LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-18-2003, 01:52 PM   #1
nidua18
LQ Newbie
 
Registered: Sep 2003
Posts: 26

Rep: Reputation: 15
lm_sensors install problem.


I installed the i2c then lm_sensors according to instructions, there were no errors and everything seemed to go smooth. However during start up I am getting an error:

Executing /etc/rc.d/init.d/lm_sensors start ..
Starting up sensors: starting module __i2c-i801__
starting module __eeprom__
/usr/local/bin/sensors: error while loading shared libraries: libsensors.so.2: cannot open shared object file: No such file or directory
[FAILED]

The libsensors.so.2 is located in /usr/local/bin/ so it should be no problem. I did everything according to the instructions and I am running out of ideas as to how to fix it.
 
Old 10-18-2003, 02:58 PM   #2
larrystorch
Member
 
Registered: Mar 2003
Location: Reading, PA
Distribution: Slackware
Posts: 32

Rep: Reputation: 17
Your libsensors.so.2 should reside in /usr/local/lib, so that's why it can not find it. The script "make install" should have automagically put it in /usr/local/lib and ran ldconfig to "register" it.

Move it to /usr/local/lib and run ldconfig afterwards, then your problem you disappear.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
lm_sensors problem mkzmonkeylagger Linux - Software 1 04-16-2004 08:29 PM
Unable to install lm_sensors 2.8.2 fr0zen Linux - Software 4 12-21-2003 08:40 PM
lm_sensors and i2c install help Giallo998 Linux - Software 0 11-08-2003 01:16 AM
lm_sensors problem! r3l4x Debian 4 10-20-2003 11:15 AM
lm_sensors - help with install? clemensp Linux - Hardware 0 08-09-2003 07:07 AM


All times are GMT -5. The time now is 01:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration