LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-19-2001, 08:58 AM   #1
Avatar
Member
 
Registered: May 2001
Location: Canada
Distribution: old ones
Posts: 538

Rep: Reputation: 30
Linux Mandrake 8.0 -- HELP I made a mistake during install and don't know how to fix!


Help me please! This is not a serious problem but a really annoying one. I feel like a huge idiot for this, but we all make mistakes right! :-)

When I installed LM8, there was a question during the install screens regarding setting the system's clock. I don't remember the exact question, something about the time zone or GMT or something. You had to answer YES or NO to the question by clicking on the appropriate button.

I remember it said "if you have MS Windows installed on this computer, CLICK NO" and of course I must have clicked on YES with out paying attention because now my clock in Windows and Linux are 4 hours apart even though they are both set to EST. Also, even if I change the time zone on one of the OSes, the clock is still always 4 hours wrong.

The reason I want to fix this is because in Linux you have to be root to change the clock and I hate always having to su. Plus its super annoying.

It took so long to configure my Mandrake just the way I want, I don't want to re-install. Any ideas?????

Thank you in advance.
 
Old 07-19-2001, 09:22 AM   #2
trusouthrnplaya
Member
 
Registered: Jun 2001
Location: (Cashville) Nashville, TN
Distribution: CentOS 4.0, Slackware 10.2,
Posts: 223

Rep: Reputation: 30
I had the same problem...all I did was click on the clock below right corner in Mandrake 8 and changed it that way to the right time zone....doing that it adjusted my MS clock when I logged into windoze
 
Old 07-19-2001, 12:28 PM   #3
Avatar
Member
 
Registered: May 2001
Location: Canada
Distribution: old ones
Posts: 538

Original Poster
Rep: Reputation: 30
Unhappy Yes i tried that....

Thanks for the reply... I have reset my Linux clock and that works fine, but then when I go into Windoze.. my clock is four hours fast. If I reset it in Windows, it will then be four hours slow in Linux.. this is *independent* of what the time zone is or how many times I log on.

Please, help... there must be a way to undo this without reinstalling!
 
Old 07-20-2001, 09:51 PM   #4
Avatar
Member
 
Registered: May 2001
Location: Canada
Distribution: old ones
Posts: 538

Original Poster
Rep: Reputation: 30
Anyone?
 
Old 07-20-2001, 11:38 PM   #5
rolf
Member
 
Registered: Jul 2001
Location: Oakland, CA
Distribution: Mageia 5 x86_64
Posts: 186

Rep: Reputation: 33
IIRC, this might have to do with whether your system clock uses universal (GMT) time, or UTC. In /etc/sysconfig/clock, I have

UTC=false

If yours says true, you might try to edit (as root) to have it say false.

Oftentimes, doing a search here:

http://groups.google.com/

for some keywords related to your problem will turn up the solution.
 
Old 07-21-2001, 12:01 AM   #6
Avatar
Member
 
Registered: May 2001
Location: Canada
Distribution: old ones
Posts: 538

Original Poster
Rep: Reputation: 30
Smile Thanx

Thank you, I am sure that this is the case!! I knew it would be something simple like this! I will try it on Monday and let you know.

Thanks again
 
Old 07-22-2001, 06:21 PM   #7
rolf
Member
 
Registered: Jul 2001
Location: Oakland, CA
Distribution: Mageia 5 x86_64
Posts: 186

Rep: Reputation: 33
oopdate

I just went through a little accelerated hair loss over this time deal. I found the boot messages declaring the system clock being set to UTC and the little clock applet was 7 hrs off so I went straight to /etc/sysconfig/clock and found UTC=false --> much hair pulling activity --> long story short, I went to DrakConf > System > Date & Time, ran through the settings, even though they showed what I want, and, at one point, a dialog pops up asking, "Is your hardware clock set to GMT?", where I say no and everything is groovy again.

I think I get in trouble when I go snooping through the configuration gui tools without setting things and stuff comes out not good

Anyway, just another datum in case the other one is not the right one. Good luck.
 
Old 07-26-2001, 06:39 PM   #8
Avatar
Member
 
Registered: May 2001
Location: Canada
Distribution: old ones
Posts: 538

Original Poster
Rep: Reputation: 30
We'll see..... :-)

Well, I have tried setting UTC to false (it *was* set to true) and we'll see how it goes when I boot up next time.

thanks for your help!!

 
Old 07-26-2001, 11:02 PM   #9
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
This is talking about the bios clock or hardware clock being set to UTC or GMT whatever. As you are using windows on the same machine the bios time is used in windows. So you must set hardware clock UTC false and also set proper time zone.


[root@beta sysconfig]# cat ./clock
ZONE="America/Chicago"
UTC=false
ARC=false

Last edited by DavidPhillips; 07-26-2001 at 11:10 PM.
 
Old 07-27-2001, 11:30 AM   #10
Avatar
Member
 
Registered: May 2001
Location: Canada
Distribution: old ones
Posts: 538

Original Poster
Rep: Reputation: 30
Well, I have set my clock to UTC=false, so far, so good... when I rebooted Linux, the time was 4 hours behind what it had been. (That's the time that Windows had). I then set the clock and time zone properly.

I have not booted into Windows since, but I am sure this fixed the problem. Thanks to everyone for your help.

:-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
made a time mistake speel Linux - Newbie 2 04-30-2005 04:20 AM
I made a big mistake? BajaNick Linux - Software 8 12-28-2003 10:18 PM
I made a mistake! Need help now jcksrobbins Mandriva 8 08-30-2003 11:17 PM
Made mistake in install of Samba ikw38 Linux - Networking 0 07-09-2003 01:49 AM
I made a mistake need help here ikw38 Linux - Networking 4 06-16-2003 02:06 PM


All times are GMT -5. The time now is 05:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration