LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-20-2002, 02:58 PM   #1
Serena
Member
 
Registered: Apr 2002
Location: Moon Kingdom
Distribution: Debian 4.0
Posts: 94

Rep: Reputation: 15
Unhappy Linux install 3x failure


I was trying to install Debian for the first time using the boot floppies from 6/01 and getting everything else via http. Most of it installed ok, but 3 things didn't.

My sound card is a Crystal 4235. There are no 4235 drivers so I tried the 4232 drivers and they reject the card. I'm told I have to give the IRQ and DMA, but with it being a PnP card I have no way of knowing.

The lp module rejects my parallel port. I tried both with and without parameters, and all I get is a failure message. I tried it with IRQ0 (for polling) as well. This is the motherboard's (FIC VIA 503+) parallel port it's rejecting.

XF86Setup causes a total lockup, and I have to turn the power off to recover. I only get as far as where it says I have to configure the mouse, keyboard, etc. Video card is a ATI All-In-Wonder PCI with 4M and monitor is a NEC Multisync E500.
 
Old 04-20-2002, 04:47 PM   #2
pbharris
Member
 
Registered: Apr 2001
Location: chicago, IL
Distribution: debian, redhat
Posts: 280

Rep: Reputation: 30
hello,
for the interrupts on the sound sound card do an pnpdump to get what values you can use to set it up as, and please chack out the isapnp page.

for the parallel port try modprobe parport then the modprobe lp

what xserver did you install ? make sure you get the right one then try xf86config the server is XF86_Mach64.
hth
 
Old 04-20-2002, 10:53 PM   #3
Serena
Member
 
Registered: Apr 2002
Location: Moon Kingdom
Distribution: Debian 4.0
Posts: 94

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by pbharris
hello,
for the interrupts on the sound sound card do an pnpdump to get what values you can use to set it up as, and please chack out the isapnp page.

for the parallel port try modprobe parport then the modprobe lp

what xserver did you install ? make sure you get the right one then try xf86config the server is XF86_Mach64.
hth

modprobe parport does nothing. I was able to get some errors with modprobe --all lp*. I got /lib/modules/2.2.19/misc/lp.o: invalid parameter parm.io insmod /lib/modules/2.2.19/misc/lp.o failed insmod lp* failed I was never able to get the installer to accept the parallel port with any parameters or with no parameters, so I guess I don't really have parallel port support.

pnpdump has pages of output and it's beyond me. I did figure out that the sound card is Card 1. I do know that IRQs and DMAs are available for it.

I got a bit further with X. I made a symlink of /dev/mouse to /dev/psaux and now XF86Setup doesn't crash. I can't get X to use 1024x768x65536 (it always goes back to I guess 320x200). And I never get any windows either. If startx even works (and most of the time it doesn't) I just get a gray screen with a big X pointer sitting atop it. Nothing happens after then and I have to power off to recover.
 
Old 04-21-2002, 06:20 PM   #4
AutoBot
Member
 
Registered: Mar 2002
Location: I can see you from here.
Distribution: Gentoo 1.3b
Posts: 182

Rep: Reputation: 34
To setup X I always use:

dpkg-reconfigure xserver-xfree86
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Failure to install Linux from Windows ME Osborne1934 Linux - Newbie 2 03-10-2005 10:41 PM
failure to install Linux from Windows Osborne1934 Linux - Newbie 2 03-09-2005 04:13 PM
mandrake 10 1.st install dual XP, login failure on Linux sverre Linux - Newbie 1 09-04-2004 06:12 AM
Linux noob, RH8 install failure Eastree Red Hat 4 01-29-2004 03:51 PM
Linux Install Failure with Dual OS robnelli Linux - General 7 11-11-2002 10:12 AM


All times are GMT -5. The time now is 06:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration