LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-31-2006, 08:27 AM   #1
marisdembovskis
Member
 
Registered: May 2006
Posts: 37

Rep: Reputation: 15
Linux ACPI and BIOS ACPI - problem to understand and giving out bugs


Problem
Crontab switches off pc at 23.00. PC is off for 6 hours.
At 05.00 in morning PC should be turned in and running. But Im trying to setup this, but no success.

If I restart BIOS then it can start pc by itself, if pc is shuted down by Linux ACPI BIOS doesn't start the pc.


Solution
Any solution is welcomed.
Thanks.


History for digging around

I have tried 2 methods how to startup my pc in 5.00 morning. The most realistic was to start it with BIOS. but there still are problems with ACPI, if ACPI switches pc off. Bios can not start it. If ACPI is off (in grub.conf acpi=off), computer by command poweroff is going to halt (System halted) but will NOT switch off.
So I need that pc switches off (without ACPI) still can not understand how to manage this.
If I restart BIOS then it can start pc by itself, if pc is shuted down by Linux ACPI BIOS doesn't start the pc.

Somebody knows/have solution for this?
Thanks.
 
Old 01-27-2007, 09:40 PM   #2
jim-j
LQ Newbie
 
Registered: Nov 2003
Location: Norfolk NE
Distribution: Fedora Core 6
Posts: 24

Rep: Reputation: 15
"apm=power-off" saved me

Quote:
Originally Posted by marisdembovskis
Problem
If ACPI is off (in grub.conf acpi=off), computer by command poweroff is going to halt (System halted) but will NOT switch off.
I had a similar problem with my Shuttle ak31 v2 motherboard. First off, this motherboard must not handle ACPI correctly. Ever since FC2 I've had to use "acpi=off" in the grub.conf which disables ACPI in Linux, but everything worked fine (it uses APM instead) in FC2, FC3, FC4 and FC5. Once I upgraded to FC6, however, Fedora would no longer turn off the power on my PC when I shut it down. It would just stop, with the last message on the screen being "System halted.". After much googling I found this page, http://mandrivausers.org/index.php?showtopic=38210
which recommended adding "acpi=off apm=on apm=power-off" to the grub.conf. Since my acpi was already off, and I new my APM was already on I simply had to add "apm=power-off" to my grub.conf and now Linux will shut the power off on my PC after it shuts down!

My relevant grub.conf entry now looks like this:

title Fedora Core (2.6.19-1.2895.fc6)
root (hd0,1)
kernel /boot/vmlinuz-2.6.19-1.2895.fc6 ro root=/dev/hda2 selinux=0 vga=791 acpi=off apm=power-off elevator=anticipatory
initrd /boot/initrd-2.6.19-1.2895.fc6.img
savedefault

Hope this info helps.
 
Old 09-20-2007, 03:17 PM   #3
yawe_frek
Member
 
Registered: Sep 2005
Distribution: feather 0.72-usb, DSL,CentOS,Ubuntu, Redhat 9
Posts: 144

Rep: Reputation: 15
Thumbs down

hi jim,

I am having a similar problem, so all i have to do now is to append

this acpi=off apm=on apm=power-off to my /boot/grub/grub.conf

Hope it works for me. The box is a redhat 9
 
Old 09-20-2007, 10:22 PM   #4
jim-j
LQ Newbie
 
Registered: Nov 2003
Location: Norfolk NE
Distribution: Fedora Core 6
Posts: 24

Rep: Reputation: 15
redhat 9 is pretty old

Quote:
Originally Posted by yawe_frek View Post
hi jim,

I am having a similar problem, so all i have to do now is to append

this acpi=off apm=on apm=power-off to my /boot/grub/grub.conf

Hope it works for me. The box is a redhat 9
Redhat 9 is pretty old. It uses the 2.4 kernel whereas I'm using a 2.6 kernel, so I don't know if the options work the same. Anytime you're editing your grub.conf file it's a good idea to have a backup and to know how to restore it if it doesn't work. Additionally you could create a whole other kernel section in your grub.conf file just for testing new options.

One other thing to note, those options should be appended to your kernel line. In my post they may have wrapped, but your kernel line should look something like this:
"kernel /boot/vmlinuz-2.6.22.5-49.fc6 ro root=/dev/hda2 acpi=off apm=on apm=power-off"
Everything between the quotes is on one line.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ACPI: 2.6.17.7; nothing in /proc/acpi/fan; fans not running; problem not seen before. zetabill Linux - Kernel 1 07-30-2006 04:27 PM
ACPI disabled because bios is from 99 and too old laurahlane Linux - Newbie 2 06-04-2005 09:32 PM
Simple Question re: enabling ACPI in BIOS tigerflag Slackware - Installation 11 04-21-2004 06:40 AM
FreeBSD 5.1 giving ACPI error on first login Jonz *BSD 1 09-28-2003 02:57 AM
ACPI Bios Problem GoRinNoSho Linux - Newbie 1 06-27-2003 08:30 AM


All times are GMT -5. The time now is 08:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration