LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-03-2003, 04:22 PM   #1
bronxtale187
LQ Newbie
 
Registered: Jun 2003
Posts: 10

Rep: Reputation: 0
linux 9.1


newbie to the linux world
Upgraded from mandrake7.2 to 9.1 bought the CD'S cheap .have sound &everything in working order .I have only Gnome & missing KDE etc. When booting up It's missing the password for root etc ..It just boots up to Gnome .Did I miss something on the install---All input --Much appreciated-Bronxtale
 
Old 06-03-2003, 04:32 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
At boot - add the word "single" to the kernel arguments.

Once you boot you will be in single user mode. You can type:
passwd root

To change the password.
 
Old 06-04-2003, 09:34 AM   #3
bronxtale187
LQ Newbie
 
Registered: Jun 2003
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks Dave , Don't know how to add single to boot , while booting up .Is there a way that u can explain .Most appreciated .
 
Old 06-04-2003, 10:03 AM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
What bootloader do you use - look at the documentation for either grub or LILO.
 
Old 06-04-2003, 01:23 PM   #5
sbadelt
Member
 
Registered: May 2003
Location: Los Angeles, CA
Distribution: Mandrake 9.2
Posts: 36

Rep: Reputation: 15
As for KDE not installed, once you have root access you can go to the Configuration->Packaging->Install SW (titles not exact). This will load the Mandrake RPM manager and allow you to install KDE, and whatever else you've missed installing. I find it's easy to run a search for the package you're looking for within the RPM manager.
 
Old 06-04-2003, 03:00 PM   #6
bronxtale187
LQ Newbie
 
Registered: Jun 2003
Posts: 10

Original Poster
Rep: Reputation: 0
Pretty sure its GRub Dave
 
Old 06-04-2003, 03:08 PM   #7
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
1) Reboot
2) Highlight the entry for your os
3) Press e
4) Select the kernel line
5) Press e
6) Append " single" no quotes to the line
7) Press enter
8) Press b
 
Old 06-04-2003, 03:24 PM   #8
bronxtale187
LQ Newbie
 
Registered: Jun 2003
Posts: 10

Original Poster
Rep: Reputation: 0
Holding down the E key when i highlight to boot up to linux-Could it be Lilo . I have options for linux smb linux something else windows (2000) & floppy .So when I hit Linuxsmb &hold down the E key nothing --Sound like a real Newbie Don't I
 
Old 06-04-2003, 07:39 PM   #9
emetib
Member
 
Registered: Feb 2003
Posts: 482

Rep: Reputation: 33
did you make a boot disk? either way, have your bios set to boot from the floppy or the cdrom first. then put what you have in, floppy or cdrom.

floppy-
boot: linux root=/dev/hd? --single

the ? is where your root is, if you don't know go to a console and type 'df'. and take a look.

cdrom-
more options
boot: linux root=/dev/hd?

you should be able to hit the esc key when your lilo comes up. you could also select the floppy from lilo. there's lots of options to do.

if you didn't make a boot disk. go to the mdk control center and boot, Drakfloppy. you should also be able to do that from the command line.

here's one more, for others that might be looking at how to make one. put your disk, #1, in the drive. take a look at it in the command line.

ls /mnt/
ls /mnt/cdrom?/images/

dd if=/mnt/cdrom/images/cdrom.img of=/dev/fd0

the ? is whether your cdrom is 'cdrom', or cdrom2. just ls your /mnt/

that should basically do it for you.

cheers
 
Old 06-04-2003, 09:58 PM   #10
bronxtale187
LQ Newbie
 
Registered: Jun 2003
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks very much for being kind and all that good stuff .will try it in the morning ,and will let u know how I made out .Thanks Much Em
 
Old 06-05-2003, 09:29 AM   #11
bronxtale187
LQ Newbie
 
Registered: Jun 2003
Posts: 10

Original Poster
Rep: Reputation: 0
Emetib,Hit the escape key & typed in the commands at the Prompt.Then hit enter & there was some errors .So when it has the boot:at the prompt I'm not sur if i had the right spaces between the Synatax that u gave me .This what I typed exactly after I got the prompt .boot: linux root =/dev/hd ?--single & then hit enter .Am I spacing this synatax Right or Wrong --Thanks Again
 
Old 06-05-2003, 09:57 AM   #12
MatthewSabin
LQ Newbie
 
Registered: Mar 2003
Location: Middletown, CT, USA
Distribution: Mandrake, Xandros and Undead
Posts: 10

Rep: Reputation: 0
Are we missing the point of the question?

Mandrake's default install in 9.1 is to automagically log-in a user and start X.

bronxtale187 didn't miss anything, it's a feature.

Fire up a terminal window and try to become super user (type 'su') you will be prompted for your root password, which won't have changed from your 7.2 installation.

--Matthew
 
Old 06-05-2003, 01:03 PM   #13
JustSlack
Member
 
Registered: Jun 2003
Location: Gurnee, IL
Distribution: Mandrake
Posts: 65

Rep: Reputation: 15
It's been awhile since I used Mandrake, but the option should be in the Mandrake Control Center to disable or enable auto-login so you can choose who (root, user) and what (Gnome, KDE) you want to load up. Here's the link to explain the process:
http://www.mandrakeuser.org/docs/mdo.../drakboot.html
 
Old 06-05-2003, 07:30 PM   #14
emetib
Member
 
Registered: Feb 2003
Posts: 482

Rep: Reputation: 33
get rid of the question mark and tell linux where your root partiion is.

df

look and see where your root is and then put that behind the linux root=

thanks mathew and just slack, i totally missed the point when i first read it. tired at the time.

to change from gnome to kde, take a look at justslacks responce. go into the mdk control center, boot, and then select the auto login to where ever. that will cure it. also you can get rid of the auto and just go to a login and then choose.

cheers.
 
Old 06-05-2003, 09:12 PM   #15
bronxtale187
LQ Newbie
 
Registered: Jun 2003
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks Much to Emitib,Just Slack,MathhewSabin,David Ross---Most Appreciated .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
link dies intermittently-seemingly at random- between win<->linux not linux<->linux?? takahaya Linux - Networking 10 03-09-2007 11:37 PM
triple boot linux/linux/linux No Windows involved toastermaker Linux - Newbie 12 03-02-2006 11:40 PM
Redhat (rhel v2.1) bootup problem with linux (linux vs linux-up) namgor Linux - Software 2 06-24-2004 03:49 PM


All times are GMT -5. The time now is 06:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration