LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-05-2000, 01:14 PM   #1
dustntime
LQ Newbie
 
Registered: Dec 2000
Location: Mexico
Posts: 19

Rep: Reputation: 0
Unhappy


Iīm a newbie using linux. I installed a winlinux dristribution, that is a modification of Slackware distribution. My mother board has a "winmodem" integrated and i dowload the pctel.zip to install the driver. I followed the instructions in the zip file, and i read some od the advice on a previos question in the forum but i couldnīt make it work.
When i just installed linux, the modem dialer (kppp) said a message that the modem was busy, after installing the hsp56 pctel driver, the message says that the modem is busy. Does anyone knows what else can i do? I just donīt know what else to do.

 
Old 12-06-2000, 02:51 PM   #2
CragStar
Senior Member
 
Registered: Oct 2000
Location: UK - Frome
Distribution: Ubuntu
Posts: 1,081

Rep: Reputation: 47
If you have a problem with a linmodem then I have probably experienced it!

The first thing is to make sure that you know that the driver you downloaded is the correct one. The PCTEL driver is for HSP modems. You seem pretty adament that it is the right one so it probably is.

Now, it is not just a case of insmod the driver. Once it is successfully loaded you need to configure the port which the modem is loaded to. Mine was com 15 in Linux (or ttyS15). To find that out just type in a terminal window
#setserial -agv /dev/ttyS*
and you will see a list of /dev/ttyS* files. Find the one which says communications device or something of that sort. This is where the modem is installed. You may know where it is anyway through windows.

The important thing is to make sure that the information is correct, and that includes the port, irq and I/O information. If is it not (again check in windoze), then you need to change it using the setserial command.

If that information is correct then you need to make sure that there is a symbolic link between /dev/modem and /dev/ttyS15 so type:
ln -sf /dev/ttyS15 /dev/modem
One more thing is that you make sure that both /dev/modem and /dev/ttys15 are available to all users, so type
chmod 666 /dev/modem (and then /dev/ttyS15 if necessary)

Make sure kppp is set for /dev/modem.

The error message means that the modem is not detected.

If you dont get anywhere post back with what you can do, but what goes wrong.
 
Old 12-07-2000, 11:13 AM   #3
dustntime
LQ Newbie
 
Registered: Dec 2000
Location: Mexico
Posts: 19

Original Poster
Rep: Reputation: 0
Unhappy i already did that

I tried using the setserial command and it displayed 4 tttysī: ttyS0, ttyS1, ttyS2, ttyS3. None of them said about communication device. " of them said that was using irq 3 and the other 2 said that they were using irq 4.

The next thing that i did, was to configure the 4 ttysī in my kppp. When i used ttyS0 sent me a message that the modem canīt be opened, and when i tried the others, a message that the modem was busy was sent.

If someone can tell whatīs going on now, iņīd really appreciate. Maybe i did something wrong before this, i donīt know. Is there any way yo know if everything is correctly installed?

Thanx
 
Old 12-08-2000, 04:35 AM   #4
CragStar
Senior Member
 
Registered: Oct 2000
Location: UK - Frome
Distribution: Ubuntu
Posts: 1,081

Rep: Reputation: 47
You may need to give yourself the ability to access the file from your username, not root (who owns the file). Is com1 where your modem resides? If so then you need to type the following to give yourself access to that file:
chmod 666 /dev/ttyS0

This should allow you to connect (assuming that you have insmod the driver first)

To check to see if the modem driver is installed just type:
lsmod

as root user and you will be given a list of modules which have are available. My driver is called pctel, so that is what I see in the list.
 
Old 12-11-2000, 02:47 AM   #5
dustntime
LQ Newbie
 
Registered: Dec 2000
Location: Mexico
Posts: 19

Original Poster
Rep: Reputation: 0
I was cheking once again, if i could try make my modem work. Suddenly when I "insmod"ed the pctel driver and i check with setserial now the dev/ttyS15 started to appear.

It sends this message. I don't know what i means, but maybe this is the final step to make my linmodem work.

/dev/ttyS15, line 15, UART: undefined, port 0xde00, IRQ: 10
Baud_base: 115200, close_delay: 50, divisor: 0
closing_wait:3000, closing_wait2: infinite
Flags:spd_normal skip_test

Could someone explain me what this means or what else to do?
Thanx again
 
Old 12-11-2000, 07:31 AM   #6
CragStar
Senior Member
 
Registered: Oct 2000
Location: UK - Frome
Distribution: Ubuntu
Posts: 1,081

Rep: Reputation: 47
The pctel driver inistialises the com port that the modem is going to use. It makes ttyS15 available.

All you have to do now is link the ttyS15 file to /dev/modem like this:
ln -sf /dev/ttyS15 /dev/modem

Make sure kppp is configured to use /dev/modem and you should be able to dial out.

You may also have to be able to access files from your account, to do this just type

chmod o+rwx /dev/ttyS15
chmod o+rwx /dev/modem

If you manage to dial out let me know if pppd dies unexpectedly.
 
Old 12-12-2000, 02:02 PM   #7
dustntime
LQ Newbie
 
Registered: Dec 2000
Location: Mexico
Posts: 19

Original Poster
Rep: Reputation: 0
Still the same Cragstar. Donīt know what else to do. When I use the Kppp, and try with the query button, says the modem doesnīt respond.

Whatīs next?
Maybe if I remove everything thaīt iīve done, could work.. donīt you think...

Iīd have tried but i donīt know what to remove or what to keep.
 
Old 12-13-2000, 05:49 AM   #8
lynch
Member
 
Registered: Nov 2000
Location: A Mid-Atlantic state
Distribution: SuSE 8.1,Knoppix 3.2,Mandrake 9.1
Posts: 388

Rep: Reputation: 30
Smile

Is PNP disabled?Just a thought.
 
Old 12-13-2000, 11:07 AM   #9
dustntime
LQ Newbie
 
Registered: Dec 2000
Location: Mexico
Posts: 19

Original Poster
Rep: Reputation: 0
how do i know....?
where do i check it?
 
Old 12-13-2000, 02:30 PM   #10
CragStar
Senior Member
 
Registered: Oct 2000
Location: UK - Frome
Distribution: Ubuntu
Posts: 1,081

Rep: Reputation: 47
Did you get any errors in what I told you to type?

The fact that the setserial thing works means that the modem is there are recognised. Try typing this instead:
chmod 666 /dev/ttyS15

as root user. Are you sure that you are linking the files, and using /dev/modem in kppp?

I wouldn't bother starting all over again, you want to keep the progress you have made.
 
Old 12-13-2000, 04:24 PM   #11
dustntime
LQ Newbie
 
Registered: Dec 2000
Location: Mexico
Posts: 19

Original Poster
Rep: Reputation: 0
Yes... iīm sure...

Iīm not hetting any error messages...
Did you check the setserial response that i sent the other day?

is everything correct? i odnīt know if the parameters are right...
 
Old 12-13-2000, 05:02 PM   #12
CragStar
Senior Member
 
Registered: Oct 2000
Location: UK - Frome
Distribution: Ubuntu
Posts: 1,081

Rep: Reputation: 47
Right, here is what I think you should do to get the modem to dial out.

insmod pctel
rm /dev/ttyS15
mknod /dev/ttyS15 c 62 79
ln -sf /dev/ttyS15 /dev/modem
chmod 666 /dev/ttyS15
chmod 666 /dev/modem

And that should be it. If you follow those instructions you should be able to use kppp. Let me know if it works. Or not.

BTW, when I try to query my modem I get nothing coming up in the boxes, but can still dial out.

The setserial output was fine as long as it matches the settings you have in windows, or the BIOS.
 
Old 12-15-2000, 01:57 AM   #13
dustntime
LQ Newbie
 
Registered: Dec 2000
Location: Mexico
Posts: 19

Original Poster
Rep: Reputation: 0
i did it once again

Cragstar... i did it once again... and is still the same... I check my windows modem configuration, after i read your last note.... Itīs not the same...

in windows, my modem is installed on com4 and itņs on 2E8 adresss with an interruption of 3. In linux is installed like:/dev/ttyS15, line 15, UART: undefined, port 0xde00, IRQ: 10
Baud_base: 115200, close_delay: 50, divisor: 0
closing_wait:3000, closing_wait2: infinite
Flags:spd_normal skip_test

but i donīt know how to change this configuration.. what can i do?
 
Old 08-14-2003, 01:45 AM   #14
morfeeus
LQ Newbie
 
Registered: Aug 2003
Location: USA - NH
Distribution: FreeBSD 5.1
Posts: 1

Rep: Reputation: 0
Lightbulb Win Modems

I'm pretty convinced that winmodems are the root of all evil in the universe. I use FreeBSD 5.1 and unfortunately my Compaq 5001SR came with a gods-be-damned HSP56 WinModem... Needless to say it has about as much chance of getting me to the internet as my pet python does. If anybody has some info regarding a linux driver port, or some other resource, I'd be grateful.

Thanks...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware and Linmodem installing problem ansicpp Linux - Hardware 0 08-08-2005 07:36 AM
LinModem installing problem ansicpp Slackware 2 06-29-2005 11:09 PM
Linmodem driver installation problem seagreen Linux - Hardware 0 12-18-2004 05:07 AM
Linmodem Problem sammy2299 Linux - Networking 1 08-18-2004 03:48 PM
SmartLink Linmodem problem ugenn Linux - Hardware 4 01-02-2003 07:42 AM


All times are GMT -5. The time now is 01:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration