LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-20-2004, 09:13 PM   #1
Icarus56
LQ Newbie
 
Registered: Oct 2003
Distribution: mandrake 9.2
Posts: 15

Rep: Reputation: 0
Lilypond/Rosegarden/midi problem


I'm having a small problem with lilypond and rosegarden (both programs have the same problem) I can't get either program to make any sound. My soundcard works ,the Alsa program works, I have what seems to be the proper configuration selected , but still no sound at all. What could be the solution. I really like to stop using noteworthy composer and use one of these linux program, but without midi playback I'm stuck using a mickeysoft program ,instead of running straight linux (SuSE 8.2).
 
Old 09-15-2004, 09:08 AM   #2
thegnu
Member
 
Registered: May 2004
Location: St. Petersburg, FL USA
Distribution: Arch Linux, Fedora Core 3
Posts: 51

Rep: Reputation: 15
Is the jack audio connection kit running? What I did is in Configure Rosegarden >> Sequencer >> Startup I made sure that the autoloading of the jack daemon was pointing to the right program (in my case /usr/bin/jackd, could be jackstart, or something else)

If you don't know where jack daemon is, as root type:
Code:
updatedb
[wait till it finishes]
locate jack
It will show you any file with jack in the path.

Also in Rosegarden I had to click the "Manage MIDI Devices" button (keyboard with green over it" and under Record devices click the box next to my cards MIDI device so it says YES.

If any of this doesn't show up:
1. Install JACK, you need it.
2. http://www.alsa-project.org/ has manual alsa configurations.
3. http://www.djcj.org/LAU/guide/index.php has the MIDI HOWTO (read it) and the JACK setup howto (read it, it's really short)

I installed qjackctl, a graphical jack front-end, it helps when trying to find the jack configuration that works. If you run the jack daemon from a virtual terminal then exit, it will kill the jack daemon, even if you end the line with &

Even I only got MIDI working in Rosegarden, but as I was only working with MIDI, it would play back via the keyboard.

----[EDIT]
I just found this:
http://www.alsa-project.org/alsa-doc...neric#jackplug

Last edited by thegnu; 09-15-2004 at 09:12 AM.
 
Old 09-28-2004, 06:03 PM   #3
ocasta
LQ Newbie
 
Registered: Sep 2004
Posts: 3

Rep: Reputation: 0
Quote:
If you don't know where jack daemon is, as root type:
Code:
 updatedb
[wait till it finishes]
locate jack
What if updatedb doesn't work? Command not found or something of the like.
 
Old 09-29-2004, 06:35 AM   #4
gloriant
Member
 
Registered: Sep 2004
Distribution: Debian{Woody,Sarge,Etch}, UbuntuLTS6.06, SuSE{6.2,8.0}
Posts: 42

Rep: Reputation: 15
Quote:
Originally posted by ocasta
What if updatedb doesn't work? Command not found or something of the like.
Then you should first install findutils-locate (in YaST installation section), or (if you don't have distribution copy) you can find it at
ftp://ftp.suse.com/pub/suse/i386/8.2/suse/i586/findutils-locate-4.1.7-545.i586.rpm
in which case you'll have to execute
Code:
$ downloadpath=/tmp
$ sudo rpm -i ${downloadpath}/findutils-locate-4.1.7-545.i586.rpm
$ sudo /usr/bin/updatedb
After which you should be able to execute prior given command
Code:
$ locate jackd
And if you can't find jackd, you haven't got it installed either :P, look for jack an qjackctl in YaST (or on the mentioned SuSE ftp-site or a mirror).

Last edited by gloriant; 09-29-2004 at 09:18 AM.
 
Old 09-29-2004, 09:15 AM   #5
gloriant
Member
 
Registered: Sep 2004
Distribution: Debian{Woody,Sarge,Etch}, UbuntuLTS6.06, SuSE{6.2,8.0}
Posts: 42

Rep: Reputation: 15
But to return to the original problem... rosegarden won't audio out...

I have installed jackd 0.99 from source
I launch jackd through qjackctr which states:
<pre>
loading driver ..
apparent rate = 48000
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 48000Hz, period = 1024 frames, buffer = 2 periods
Couldn't open hw:0 for 32bit samples trying 24bit instead
Couldn't open hw:0 for 24bit samples trying 16bit instead
Couldn't open hw:0 for 32bit samples trying 24bit instead
Couldn't open hw:0 for 24bit samples trying 16bit instead
**** alsa_pcm: xrun of at least 18.497 msecs
...
</pre>

Then I launch rosegarden. At startup I see:
<pre>
rosegarden: RosegardenGUIDoc::syncDevices - waiting for Sequencer to come up
rosegarden: RosegardenGUIDoc::syncDevices - devices = 1
rosegarden: RosegardenGUIDoc::syncDevices - i = 0
rosegarden: RosegardenGUIDoc::getMappedDevice - adding MIDI Device "MIDI software device" id = 0 direction = 0 recording = false
rosegarden: RosegardenGUIDoc::getMappedDevice - got "128:0 KAMix: qamix (write)", direction 0 recording false
</pre>

As suggested by thegnu
Quote:
Also in Rosegarden I had to click the "Manage MIDI Devices" button (keyboard with green over it" and under Record devices click the box next to my cards MIDI device so it says YES.
I opened Rosegarden settings, end selected sequencer, BUT the startup-tab is empty. so no -jackd to be set there. Furthermore, the General-tab (under sequencer) states "Sequencer status: midi ok, no audio"

And the "show detailed status" button returns
<pre>
Rosegarden 4-0.9.9 - AlsaDriver - alsa-lib version 0.9.6

ALSA Client information:

128,0 - (KAMix, qamix) (WRITE ONLY) [ctype 1, ptype 1048576, cap 66]

Creating device 0 in Play mode for connection 128:0 KAMix: qamix (write)
Default device name for this device is MIDI software device
Current timer set to "system timer"
AlsaDriver::initialiseMidi - initialised MIDI subsystem

AlsaDriver::setRecordDevice - attempting to set play device (0) to record device

</pre>

Does anybody (thegnu maybe) have any idea how to proceed here ?
 
Old 09-29-2004, 05:35 PM   #6
ocasta
LQ Newbie
 
Registered: Sep 2004
Posts: 3

Rep: Reputation: 0
Launch Jack via Rosegarden. Go to Settings>Configure Rosegarden>Sequencer>Startup and you'll have the option of starting Jack from Rosegarden. Now that I've done that, I've gotten wav sound out. I'm working on MIDI sound now...
 
Old 10-01-2004, 09:49 AM   #7
gloriant
Member
 
Registered: Sep 2004
Distribution: Debian{Woody,Sarge,Etch}, UbuntuLTS6.06, SuSE{6.2,8.0}
Posts: 42

Rep: Reputation: 15
I'd love love to.

Quote:
Originally posted by ocasta
Launch Jack via Rosegarden. Go to Settings>Configure Rosegarden>Sequencer>Startup and you'll have the option of starting Jack from Rosegarden. Now that I've done that, I've gotten wav sound out. I'm working on MIDI sound now...
I'd *love* to do that, but unfortunately
Quote:
I opened Rosegarden settings -> Configure Rosegarden -> Sequencer BUT the startup-tab is completely empty. so no jackd to be set for launching by rosegarden here. Furthermore, the General-tab (under sequencer) states "Sequencer status: midi ok, no audio"
This is in Rosegarde R4 0.9.9 with KDE 3.1.4

More hints ?
 
Old 10-01-2004, 01:57 PM   #8
thegnu
Member
 
Registered: May 2004
Location: St. Petersburg, FL USA
Distribution: Arch Linux, Fedora Core 3
Posts: 51

Rep: Reputation: 15
Quote:
Originally posted by gloriant
Does anybody (thegnu maybe) have any idea how to proceed here ?
I've successfully tricked someone into thinking I know something!!! YES!!!

In seriousness, launching jack outside of Rosegarden isn't really a problem, just to me it was more hassle. With qjackctl, you can connect Input and Output MIDI devices, but Rosegarden has to be open for it to show up. The Manage MIDI Devices button isn't in Settings (which is kind of confusing), it's on a toolbar. See if you can enter that section, and enable your Keyboard.

Like I said, I was only able to get MIDI working. At one point, I actually had it say "MIDI OK, audio OK", but that only lasted a minute and I can't remember what I did.

The results I was able to get were:
MIDI in from keyboard
MIDI out to keyboard (on playback)
no audio in
no audio out

If this is what you need, it sounds like all you need to do is:
a) run qjackctl while Rosegarden is running and enter the Connect dialog and connect your audio device on the left side to Rosegarden on the right side (and maybe vice versa).
b) Enter the Manage MIDI Devices dialog and enable your keyboard.

Stat- do you find the Manage MIDI Devices dialog? It's on the EDITOR'S TOOLBAR.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rosegarden 4 problem Johnno56 Linux - Software 2 11-04-2005 05:55 PM
Rosegarden Sequencer problem LinAck Linux - Software 1 07-08-2005 12:15 PM
Problem with lilypond/lilypond-book 2.4.4 - lost latin1.enc thegnu Linux - Software 1 06-02-2005 08:48 PM
Rosegarden + Midi.. cna this be done? trey85stang Linux - Software 1 05-26-2005 03:36 AM
Rosegarden problem Belegdol Linux - Software 0 08-30-2004 05:48 AM


All times are GMT -5. The time now is 01:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration