LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-25-2012, 09:31 AM   #1
curious95
Member
 
Registered: Oct 2012
Location: /home/v
Distribution: Slackware 14.0
Posts: 83

Rep: Reputation: Disabled
Post lilo unable to mount root-fs , lilo.conf


um, i was wondering what is the problem with my lilo.conf file. everytime i try to boot up my computer outputs this error and stops working:
Code:
No filesystem could mount root, tried: romfs
Kernel panic - not syncing: VFS: unable to mount root fs on unknown block(8,2)
my /etc/lilo.conf file enabled options:
Code:
lba32
append=" vt.default_utf8=0"
boot = /dev/sda
bitmap = /boot/slack.bmp
bmp-colors = 255,0,255,0,255,0
bmp-table = 60,6,1,16
bmp-timer = 65,27,0,255
prompt
timeout = 1200
change-rules
reset
vga = normal
image = /boot/vmlinuz-generic-3.2.29
        root = /dev/sda2
        label = "Linux"
        read-only
What's wrong with my lilo.conf file?
 
Old 11-25-2012, 09:35 AM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,650
Blog Entries: 2

Rep: Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095
You are booting a generic kernel without specifying an initrd. This can't work.
 
Old 11-25-2012, 09:45 AM   #3
curious95
Member
 
Registered: Oct 2012
Location: /home/v
Distribution: Slackware 14.0
Posts: 83

Original Poster
Rep: Reputation: Disabled
Interesting well i don't think i have one, ls /boot without the irrelevant files is:
Code:
System.map
System.map-generic-3.2.29
System.map-generic-smp-3.2.29-smp
System.map-huge-3.2.29
System.map-generic-smp-3.2.29-smp
config
config-generic-3.2.29
config-generic-smp-3.2.29-smp
config-huge-3.2.29
config-huge-smp-3.2.29-smp
inside.bmp
vmlinuz
vmlinuz-generic-3.2.29
vmlinuz-generic-smp-3.2.29-smp
vmlinuz-huge-3.2.29
vmlinuz-huge-smp-3.2.29-smp
can i boot without an initrd? because i was booting fine before without the initrd...

Last edited by curious95; 11-25-2012 at 09:50 AM.
 
Old 11-25-2012, 09:50 AM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,650
Blog Entries: 2

Rep: Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095
I assume that this is Slackware 14. You can boot without the initrd if you use the huge kernel instead of the generic kernel. An initrd is not delivered by default, that wouldn't make sense since the configuration of it is system dependent. As always with Slackware (and most other distributions) it is a good idea to read the docuemntation first: http://mirrors.slackware.com/slackwa.../README.initrd
 
Old 11-25-2012, 09:55 AM   #5
curious95
Member
 
Registered: Oct 2012
Location: /home/v
Distribution: Slackware 14.0
Posts: 83

Original Poster
Rep: Reputation: Disabled
yes slackware 14, thank you for your answer. I'll begin making my initrd right away I had read the README.initrd but i thought it wasn't a must to build the initrd since my system booted without it. well now i know.

Last edited by curious95; 11-25-2012 at 09:57 AM.
 
  


Reply

Tags
lilo, liloconf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Edit lilo.conf, run /sbin/lilo, but lilo won't take changes lukameen Slackware 2 02-10-2012 01:10 PM
trying to update lilo on my usb hdd tells me /etc/lilo.conf wasn't found daweefolk Slackware 8 04-23-2010 02:20 AM
Can't open grub.conf/lilo.conf with kate being root cola Slackware 6 09-28-2009 08:26 AM
Unable to reconfigure lilo.conf stenlyto Slackware 8 06-15-2009 03:53 PM
Upgraded kernel, lilo.conf, didn't run /sbin/lilo dtashima Linux - Newbie 4 10-18-2004 12:21 PM


All times are GMT -5. The time now is 07:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration