LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-25-2011, 05:17 PM   #1
ewsmith
Member
 
Registered: Oct 2010
Location: Weesatche, Texas
Distribution: Slackware
Posts: 72

Rep: Reputation: 7
lilo boot parameters question


I have used LILO for a while now and it does everything I need.
However, I am messing around with the boot parameters to see if I can
get acpi to work automatically. Passing the acpi=force parameter in
LILO works, but I have only done this at boot and not in the lilo.conf.
My lilo.conf has acpi=off in it.

My question is: Does passing boot parameters with lilo at boot override any existing parameters that contradict it? Or all of them?

If this is in the wrong place, feeling free to flame me. I've been here long enough. There's no excuse.
 
Old 01-26-2011, 11:19 AM   #2
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,321

Rep: Reputation: 141Reputation: 141
It's been a long time since I've fiddled with lilo, but IIRC, options passed to lilo at boot should override lilo.conf. It almost has to be that way otherwise you could never boot in anyway except as designated by lilo.conf which would make the ability to pass parameters at boot unnecessary.
 
Old 01-27-2011, 06:47 AM   #3
ewsmith
Member
 
Registered: Oct 2010
Location: Weesatche, Texas
Distribution: Slackware
Posts: 72

Original Poster
Rep: Reputation: 7
that's all I needed to know. thank you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A question about using lilo command at boot... trist007 Linux - Newbie 5 06-26-2010 07:32 PM
Boot parameters utilization during ks installation - question infernal211283_ Linux - General 3 01-14-2009 10:27 AM
Lilo vga parameters under SuSe Linux stevesk Suse/Novell 2 12-17-2004 07:10 PM
lilo boot question gram_vaz Mandriva 2 06-11-2004 08:57 PM
Passing kernel parameters at boot with LILO Crashedfiesta Linux - Laptop and Netbook 2 12-16-2003 08:51 AM


All times are GMT -5. The time now is 03:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration