LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-05-2003, 08:11 AM   #1
Aman9090
Member
 
Registered: Sep 2002
Location: Connecticut, USA
Distribution: Gentoo 2004.0
Posts: 174

Rep: Reputation: 30
LILO and Gentoo


I installed Gentoo yesterday but failed to have LILO boot correctly. When I do /sbin/lilo it said that /boot/map was a read-only drive. I mounted it and everything and I am confused on how to get this working. Other times it said that /boot/kernel-2.4.20-gentoo-r8 couldn't be found, even though i was pointing it to the right place. What may be the problem? Could it be that I just used gk_kernel wrong? Did i emerge the kernel incorrectly? Should I just try formatting and installing again? Thanks in advance

Last edited by Aman9090; 11-05-2003 at 08:14 AM.
 
Old 11-05-2003, 10:19 AM   #2
UB_KMA
Member
 
Registered: Jul 2002
Location: Austin,TX
Distribution: A mash of SourceMage, Lunar, Slack, Manny, and RedHat all smushed together
Posts: 94

Rep: Reputation: 15
I would suggest reconfiguring your kernel manually isntead of using the auto-config gentoo option. When you autoconfig you get an initrd setup and it is much "easier" to work with a bzImage alone if you are having problems... :
#make menuconfig
then
#make dep && make clean bzImage modules modules_install
and
#cp /usr/src/linux/arch/i386/boot/bzImage /boot

if you are having problems accessing your Gentoo setup because of the lilo problem, boot with your Gentoo disk and chroot into your instalation. Once you have entered your instalation root partition, mount your boot partition on its /boot.

Something like:

#mount /dev/(your root install partition) /mnt
#chroot /mnt /bin/bash
#env-update
#source /etc/profile
#mount /dev/(your boot partition) /boot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo vs Lilo Carroarmato0 Linux - Distributions 2 02-21-2005 01:25 PM
Get Gentoo to run with Lilo nr5 Linux - Software 8 01-31-2005 09:14 AM
Gentoo Lilo problem. Nz_Boy_2004 Linux - Distributions 1 11-27-2004 09:36 PM
reinstalling lilo in gentoo? bigjohn Linux - Newbie 11 02-18-2004 06:46 PM
Lilo question (Gentoo) Mithrilhall Linux - Newbie 5 05-26-2003 01:50 AM


All times are GMT -5. The time now is 04:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration